1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

USB not connecting - SOLUTION Samsung Galaxy ACETips


  1. DRGovernor

    DRGovernor New Member

    Hi guys,
    I hope this saves everyone else a lot of stress and time.

    FIRST ISSUE: My Samsung Galaxy Ace (Gingerbread) would not connect to my PC (desktop) via USB even after installing and the reinstalling Kies off the cd and then off the web. I kept getting "USD device not recognised" - tried a blackberry cable which did kind of work - BUT I then plugged the Samsung USB Cable into a back USB port on my desktop and suddenly everything worked fine (probably some power - data issue with the front usb ports). SO connectivity sorted.

    NOTE: Web-searches indicated there should be a "USB Utilities" menu under Applications - Wireless and Network" BUT if it is NOT there apparently Android 2.3+ does NOT have this menu so don't stress and freak out like I did. SO once the phone can connect via usb to the pc (Windows XP) A "USB Connected" notification and USB symbol will appear in the status bar - once you drag that down you should be offered an option to "select to copy files to/from computer." - then the green Android Man magically appears and there is a "Connect Storage to PC" button - press okay if you get a usb access warning message thingy. The Android man goes orange and voila your computer should see your SD card as a drive (also if you read about turning off "USB debugging" under - applications - development... mine doesn't stay off, it seems to turn itself back on automatically, however, but still seems to connect - another NOTE - KIES will only connect my phone if USB debugging is activated).

    NEXT ISSUE: My PC (Windows XP) kept telling me the 2GB SD Card was FULL (in KIES and EXPLORER) - even though I had maybe 100MB on it . I could however copy files across via Bluetooth which does take a while. SOLUTION: back-up apps and files on SD card to phone or computer using KIES or via BLUETOOTH (with the ace I had to go into each folder and press menu - select "more" and manually make files visible via "bluetooth visibility"). THEN connect via USB to the PC and format the SD Card via WINDOWS and that then gets rid off the no "Free Space" problem - allowing access to the SD Card.

    A bit long winded but it took me a good day of internet searching and hairpulling to sort this out - so I hope I have saved someone else from that..

    Advertisement
  2. allnighta

    allnighta New Member

    very long winded m8 ive had my ace like 2 days and well basically all i did was plug it into my pc via usb lead,pull down on the top menu were you basically get the option to connect your ace as a mass storage device and bingo
    no need to use programs
    try that,also put folders on ya sd card if ya want to set custom ringtones or notifications
  3. Lyta

    Lyta Active Member

    Where is this " pull down on the top menu " Located I want to connect my ace to the PC now, but wont show up :(

    This is after I burned a another rom and added the Cynogen 7.2 mod.

    Cheers.
  4. ayush29k

    ayush29k Well-Known Member

    Some CM roms does not have a working usb storage mode....
    Are you using the official version?


    That 'pull down menu' is just the pull down status bar notification menu, when you connect to pc a notification appears there and you have to click it to start the mass storage mode.
  5. Lyta

    Lyta Active Member

    Yep that worked I can now see whats on my phone from my PC ":)


    You learn something new everyday it seems :)

    Cheers.
  6. patspersonal

    patspersonal New Member

    I found this on Yahoo Answers Ireland & UK and it worked for me to detect the phone on my pc and copy files between my pc and the SD card.

    Do the following:
    1. Unplug the USB cable
    2. On the phone go to: Settings>Applications>Development>Turn off USB debugging.
    3. Re-plug in the USB cable
    My Results:
    My phone showed 'USB connected' (you can copy files
    My computer installed the USB driver and my phone was detected in Control Panel > Devices & Printers.
    NOTE: At work I have to turn on USB debugging just to use the cable for charging as my workplace disables driver installation for external devices.
    NOTE: Recommend getting a MicroSD adapter as backup.
  7. kevinbuck

    kevinbuck New Member

    ok iv looked n tryed every were n every thing im running CyanogenMod version 9-UNOFFICIAL-cooper. 4.0.4. I plugged my phone into a laptop it was fine USB MASS Storaged worked i put some music on and clicked dissconect. I pluged my USB lead back in to my PC and it wont pick it up and it wont work on any other PC/Laptop. Iv tryed Samsung Kies on my PC but that dunt work. I stuck and need help
  8. newbie2012

    newbie2012 New Member

    After spending several days searching the internet and downloading kies multiple times all with the same result, no usb connection, I tried this very simple solution, I sprayed my micro usb port on the phone with a compressed air can for several seconds then reconnected the usb wire to the phone and to my great satisfaction, the usb icon appeared in the upper left corner of the display. I would highly recommend that this be tried first before going on to any of the other mentioned items. The micro usb connection plug is very small and it would not take much pocket crud to fowl it.
    Charlie Whisk likes this.
  9. nbsm1

    nbsm1 Member

    Hi there,
    Thanks for all the advice. Did try but my PC simply doesn't see my phone (Samsung Galaxy Ace), although the notification bar on the phone shows the USB as being connected.

    I get an eternal loop situation: the PC tells me "USB loading", then "USB failed to connect".

    The phone says USB is connected, tells me to select to copy files to and from PC, the USB connected Android man comes on, I'm being asked to select "connect storage to PC", when I do that, the guy turns orange and warns me that some apps will stop working until I turn off USB storage, and when I click okay, I read "USB storage in use", and "before turning off USB storage, unmount SD card form PC". Which I can't do, as the PC doesn't think it's got anything connected to it.

    Kies won't see my phone, whether I've selected USB debugging or not.

    VERY frustrating! Where do I go wrong?? Please advise...
  10. pamenity

    pamenity New Member

    NBSM1
    Go to the ican on the top left hand corner of your phone screen and drag the line downwards click on USB connected and then connect storage to PC then OK.

    All will be well after that it will show up in Windows Explorer.
  11. Fombel

    Fombel New Member

    I am getting error 43 :( tried everything
  12. sanadbenali222

    sanadbenali222 New Member

    i got the samsung ace and when i connect it to the cable to my car via usb it keeps doing install sounds but nothing and on the radio it keeps flashing from usb front to regular radio channel
  13. Charlie Whisk

    Charlie Whisk New Member

    I have read extensively here and elsewhere about how to solve the problems in this series of posts but still could not get my Galaxy Ace (GT-S5820 - the basic model) to connect to a PC. But I now can! So my experiences might be useful to save the two days of agony and frustration that I had. And anyway this post may serve as a useful checklist for others of all the solutions I found (the one that worked for me is at the end!)

    I did the following using two separate PCs (Windows 7) and using two different data connector cables, one the original Samsung one, and also a brand new generic one:

    • Installed and reinstalled Kies: the phone did not connect even though I have several times used the troubleshooting option there to re-install the driver for USB connection.
    • Used both front and back USB ports.
    • Took my phone battery out and replaced it.
    • Unmounted and remounted the SD card
    • Checked for software updates on the phone
  14. Mr Blobby

    Mr Blobby New Member

    Sorry to resurrect an old thread, but I just had a couple of days having problems getting Kies to talk to an Ace, and thought I'd share the solution in addition to the lists above...

    Kies is trying to talk to your device using an NDIS driver (that is, it is using a NETWORK connection). It is expecting to to talk to a 192.168 address. If your PC is not using an address on this subnet, Kies will not talk to your mobile.

Share This Page