USB not detected, won't mountSupport


  1. Lommer0

    Lommer0 Member

    Model: SGH-I727R
    Android: 2.3.5
    Kernel: 2.6.35.11
    Build: GINGERBREAD.RUXKJ7

    Hi All,
    I have an SGS2 LTE from Rogers in Canada (same phone as the skyrocket) that has recently developed a USB issue. Whenever the phone is plugged in via USB it will begin charging, but the phone will not recognize a computer and give an option to mount (i.e. the usb icon does not appear in the drawbar). I have tried multiple usb cables including the stock sammy cable, multiple USB ports on each computer, and multiple computers. The USB used to work just fine, so I suspect it is an issue with the port on the phone.

    The catch is that I rooted the phone a few weeks ago using the SuperOneClick method. The usb issue began happening shortly after - no idea whether the two events are connected. I'm still using the stock ROM, but I'm concerned about trying to warranty the USB port if the phone is rooted, and I'd like to make sure that it is indeed a hardware issue and not related to the rooting.

    Questions:
    1) Any ideas on the USB issue and how to possibly fix it?
    2) Any ideas on how to unroot the phone, given that it won't mount via USB? Or advice on how to warranty it?

    Any help is appreciated!

    Advertisement
    :
    Albaraha likes this.
  2. Mr. Ed

    Mr. Ed Well-Known Member

    Have you tried uninstalling and reinstalling the device drivers?

    Which drivers did you install when you rooted the phone?
  3. Lommer0

    Lommer0 Member

    I used the drivers from the Samsung site to root the phone. (Galaxy S II LTE - Samsung Galaxy S II LTE - Smartphones - Mobile Phones | SAMSUNG)

    I've tried removing/reinstalling them, with no change. I've also tried taking the battery out and then cleaning the micro usb port with a qtip and some rubbing alcohol. Still no change. I really don't think the drivers are the issue, as the phone should be able to plug into any computer and function as a usb key without any special drivers.
  4. Mr. Ed

    Mr. Ed Well-Known Member

    That isn't always the case for some reason but you are right.. it does not appear to be cables or drivers.


    I will pop back in with more suggestions if I come up with some
  5. Mr. Ed

    Mr. Ed Well-Known Member

    OK try this...reboot into cwm and go to mounts and mount USB storage

    See if that works, if not its gotta be hardware

    Did you make a nandroid of stock after rooting?

    Oh have you tried a hard reset?
  6. Lommer0

    Lommer0 Member

    Thanks Mr. Ed - I've tried a hard reset with no dice. I did not make a nandroid backup after rooting, but I haven't done much since rooting either (certainly haven't flashed new ROMs etc).

    I'm unfamiliar with cwm. I just dl'd it and poked around - seems like it does not support the i727 by default - how do I flash cwm recovery? Is there a thread with explanation for the i727 you can point me to?

    EDIT: I just found instructions saying to use the TMobile S2 ROM for cwm recovery. Doing that now...
  7. Lommer0

    Lommer0 Member

    Ok successfully booted into cwm recovery. Then I plugged in the usb cable, went "mounts and storage" -> "mount USB storage". Nothing registered on the computer.

    If I try this with the SD card in the phone it doesn't say anything on the phone, and if I try this with the SD card removed it says "E:Unable to write to ums lunfile (no such file or directory)" and says that every time I press "mount USB storage" on the phone.

    Any further thoughts?

    EDIT: asking cwm to mount /efs, /data, /system etc gives the same result on the computer (no result at all).
  8. Lommer0

    Lommer0 Member

    Ok, I think I've figured this out. If I get a stock ROM onto the SD card and flash that using cwm will that unroot the phone to stock condition so that I can warranty it? I was thinking of using the ROM at (1) as it's an RUXKJ7 ROM (vs. the ROM recommended in the androidforums unrooting guide at (2) which appears to be an UCKJ2 ROM). I'm just figuring out how to do a nandroid backup to my SDcard since I gapped big time on that earlier and figure I may well do that now.

    (1) [ROM]SGH-I727R_RWC_I727RUXKJ7_I727RRWCKJ7_I727RUXKJ7 - xda-developers
    (2) http://androidforums.com/galaxy-s2-...rn-stock-fix-soft-brick-11-13-rogers-tar.html
  9. Lommer0

    Lommer0 Member

    Bah - the link in (1) is broken, and that appears to be the link that is referenced all over the internet according to google. I haven't been able to find another stock ROM. Anyone have any ideas?
  10. Mr. Ed

    Mr. Ed Well-Known Member

    It would be easier to restore the stock recovery and uninstall super user and busy box (if you installed them)


    When you rooted, how did you root?


    Also, you will need root explorer or es file manager

    I will try and type up instructions for ya tomorrow

    And I will fix that link
  11. Mr. Ed

    Mr. Ed Well-Known Member

    Odin is not going to work because you cannot connect
  12. Leroy10546

    Leroy10546 New Member

    I have the same issue. Phone is less than a week old. Switched from iPhone. Did not realize that you had to be an Android geek to get the phone to work right. I actually came to this forum here for another reason, much more mundane. How to get photos off the phone, but since my computer does not see the phone, I am where am. If you have a suggestion, keep it simple, please. I have a Ph.D., but not in Android Science.
  13. Mr. Ed

    Mr. Ed Well-Known Member

    can you walk me through the steps you have completed (drivers, usb cables, anything you have done to try and resolve the issue)

    Are the drivers installed? (in same cases they must be installed manually, or you must install Kies)

    Have you tried these steps?

    Quotes:
    Originally Posted by dizzll
    When you connect your phone via usb cable. The "removable drives" it displays in your My Computer are not accessible until you use the pull down on the Skyrocket and click "usb connected- click to move files".


    Originally posted by Midiman
    Maybe there is another way but this way worked for me.
    Your method may be quicker. I found the option in Settings > Wireless and Networks > USB Utilities > USB mass storage. I don't find it the pull down notification menu at all but I thought I did the first time you mentioned it. Odd.
  14. Midiman

    Midiman Well-Known Member

    These are pretty much the instructions straight from the manual. I had to change things slightly to make up for their use of graphics. This is what I've followed. It works all the time. I've only done it on one computer. I hear there might be issues if you try to move the phone between several different devices with USB connections that might require the phone to be rebooted before it will work. There is no mention in these instructions about installing any drivers and I have not done so. I'm using 64-bit Windows 7. You have to be sure you are using a standard MicroUSB cable. The spare cable AT&T sells is a Charge Only cable and won't work for data.

    ----------------------------------------------------------------------

    Connecting as a Mass Storage Device

    You can connect your device to a PC as a removable disk and access the file directory.

    If you insert a memory card in the device, you can also access the files directory from the memory card by using the device as a memory card reader. (They will show up as different drive letters)

    Note: The file directory of the memory card displays as a removable disk, separate from the internal memory.

    1. Insert a memory card into the device to transfer files from or to the memory card to your PC. (optional, there is an internal SD card in the phone already)
    2. From the Home screen, tap Applications > Settings > Wireless and network > USB utilities.
    3. On your phone, tap Connect storage to PC.
    4. Connect a USB cable from your phone to your PC. (shouldn't matter which end you plug in first, I wire to the PC first, then the phone)
    5. A pop-up window displays on the PC when connected. Tap Connect USB storage. Your phone will appear on your PC as a removable disk. (two if you have an external card installed)
    6. Open the folder to view files.
    7. Copy files between your PC and your memory card.
    8. To exit, tap Disconnect storage from PC.
  15. Lommer0

    Lommer0 Member

    Hi Mr. Ed - Work sent me on the road for a week but I'm back to working on this issue. Any ideas on where I can find a suitable RUXJ7 rom? I rooted using SuperOneClick. I didn't think I'd need instructions but I'm not sure what I'll need root explorer or es file manager for - what should I plan to do with those?

    All your help is very appreciated!
  16. hurricanegms

    hurricanegms New Member

    Ok so this is an ongoing problem all over the net and I am now a pat of this mess. I just bought this phone last week and am trying to connect it to my Win 7 64 bit Ultimate Edition PC but the PC does not acknowledge it and the phone does nothing but charge. I have tried the supplied cable as well as a high end cable I already had for other devices. Same result. Multiple USB ports same result. I have tried the USB settings in the phone but they do nothing but tell me to unplug my cable, then plug back in, then unplug, etc. Does nothing. I am an IT professional so I am not a noob to the Windows side of things, but am new to Android. But still, plugging in a device should connect automatically. This is not friggin unix and a prompt!! I did not root the phone (guessing that is same as jail break in the apple world). I've installed nothing. Have whatever came on the phone from ATT (USA).

    Please help. On verge of returning phone and giving up on Android after a few days. I went with Android as I HATE the closed nature of Apple and iTunes SUX, but then again, so far this has been a nightmare, too.

    Glenn
  17. LevelMarc

    LevelMarc Member

    I had the same problem. I deleted and re-installed Kies. To get the computer to see the phone as a USB device I have to have Kies open.
  18. catmek64

    catmek64 Active Member

    I've been having usb mass storage problems the last week, also. Nothing would fix it, including trying 3 other puters, one an XP. This, a Skyrocket. Then I stumbled upon this idea - from a guy in India.

    Quote -
    " Cannot connect to Windows7 64 bit no matter what
    johnmarlo1 likes this.
  19. Jayposer2000

    Jayposer2000 Member

    I just rebooted my cell phone and the connection re established on its own.
  20. FibrOptx

    FibrOptx New Member

    Guys, it has sumtin to do with ADB. My PC used to recognize my skyrocket when I first got it but then for the past 3 weeks it stoped recognizing it. What I did today was restored my phone to an old back up of mine just to check some things out then restored again to my latest backup while it was connected to my pc and for some reason my PC said sumtin about ADB and it recognized my skyrocket again :) . Hope this helps. If not, you can always use KiesAir which uses wireless transfers.
  21. JimSkyrocket

    JimSkyrocket New Member

    I am also having this problem. I'm using a Mac running OS X. When I first got the phone, I plugged it in and it connected just fine with the cable that came with the phone. Now it doesn't give me the option to use it as a usb storage device like it did when I forst got it. The phone has never been rooted or anything else done to it. I never had to install any drivers either. I'm ready to take this stupid thing back. It also has the problem where the battery shows it is 100% when it isn't.
  22. Riehlthing

    Riehlthing Active Member

  23. catmek64

    catmek64 Active Member

    Mine just did it again the other day, and the "trick" fixed it, again. I wish I knew what what was causing the blockage. Still won't work on the Captivate. [​IMG]
  24. shireeniebeani

    shireeniebeani New Member

    Thanks--that did it! I wondered why every time I connected my PC to the phone via Bluetooth it kept trying to act as a modem, and the USB connection did nothing. The last update must've tweaked a setting.

    "God bless the Internet!" :D
  25. PatrickBay

    PatrickBay New Member

    I had the same problem over the last few months and it progressively got worse. Yesterday, try as I may (and I tried all of the software-based fixes I could find), nothing would work. Even the charger would no longer juice it up.

    That made me think that it could actually be a physical problem, not a software one. So I looked at the micro USB port and the slot in the middle (the tongue, if you will), seemed to be tilted too far down. I stuck a glasses flathead screwdriver (one of those really slim ones) in there and bent the connector upwards so that it was roughly in the center of the cavity. Plugged the cable back in and, lo and behold, all functionality fully restored!

    I would caution that if you're doing this, do it as a last resort, and do it gently since you're forcing something that's fairly delicate.

    I've noticed this problem on other Nexus phones and I chalk it up to the way that the micro USB slot is unsupported (so it can bend easily).

    Hope this helps!
    pitajax and uofajac like this.
Loading...

Share This Page