USB Option List when plugging EVO into PC


Last Updated:

  1. TravisW0204

    TravisW0204 Member This Topic's Starter

    Joined:
    May 21, 2010
    Messages:
    9
    Likes Received:
    0
    This is really driving me crazy. Everytime I plug my EVO into my PC[​IMG] I'm not getting the option list to either charge it, sync it, etc. It happens quite frequently. I have the Ask Me checked under the Connect PC Settings but for some reason it doesn't ask me all the time. The only thing that fixes it is a soft reset. It'll work for the day but the next day it won't work again. I've done a hard reset twice and still it does it. It's really weird. Anyone else experience this?
     

    Advertisement
  2. EarlyMon

    EarlyMon The PearlyMon Moderator

    Joined:
    Jun 10, 2010
    Messages:
    57,614
    Likes Received:
    70,271
    No - but once your plugged in, if it's not the way you want, you can slide down your notifications from the top, tap the "Charge Only" or whatever state is there next to the USB icon, and it will give you the menu you want - no need to reset or power cycle.
     
  3. hawt

    hawt Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    106
    Likes Received:
    30
    EarlyMon, he is talking about the icon not showing up in the notification bar, even when "Ask Me" is checked.

    There is a whole thread related to this nightmare in the Support forum. No one knows why it does it, but it seems like as of right now the only fix is a soft-reset.
     
    EarlyMon and TravisW0204 like this.
  4. PapiLou

    PapiLou Member

    Joined:
    Jun 23, 2010
    Messages:
    21
    Likes Received:
    1

    This could be a problem with your PC/laptop you are connecting to and how the USB ports recognize your device. Does this problem happen on different machines or have you been using the same machine? I would test it on different machines if the latter is true.
     
  5. TravisW0204

    TravisW0204 Member This Topic's Starter

    Joined:
    May 21, 2010
    Messages:
    9
    Likes Received:
    0
    I have only tried it on my Pc at home. I don't own a laptop and. The only other place I go online is at work. I guess I can try it at my moms house to see if that works. I guess for now I'll just do the soft reset until a fix is made.
     
  6. PapiLou

    PapiLou Member

    Joined:
    Jun 23, 2010
    Messages:
    21
    Likes Received:
    1

    I had a similar problem with my Pre and found that my USB ports, for whatever reason, would not detect my Pre correctly when I plugged it in. I actually disabled the ports and re-enabled them and they would work, but from time to time it would occur again.

    You might try this. While your phone is plugged in.


    1. double click my computer
    2. right click on the drive that your phone is now assigned to
    3. select properties
    4. select your HTC Android phone from the list and
    5. click properties at the bottom
    6. on the general tab, select "do not use this device (disable)" towards the bottom.
    7. click ok
    8. Select properties from the hardware tab again
    9. select "use this device (enable) towards the bottom and click ok
    10. click ok again.
    11. Unplug your phone
    12. plug it back in

    If you are prompted to choose the connection type, its likely that your are having problems with your USB identifying your phone as a disk drive when you plug it in.

    Keep in mind I use XP, so this may not be so helpful if you have Vista or W7. Hope this helps!
     
    TravisW0204 likes this.
  7. TravisW0204

    TravisW0204 Member This Topic's Starter

    Joined:
    May 21, 2010
    Messages:
    9
    Likes Received:
    0
    Yeah I'm using Vista. It's worth a shot. Thanks for the info.
     
  8. jimcraig

    jimcraig Well-Known Member

    Joined:
    Jun 8, 2010
    Messages:
    145
    Likes Received:
    9
    I had this same problem but think I fixed it. Problem is I wont be able to give definitive info on how to fix it.

    I installed "autostarts" to try and stop some of the BS that auto starts on the phone. After I did this I started getting the above problem.

    I went back into "autostarts" and enabled some items that I had disabled, this fixed it. Also the pc recognized the EVO after I unchecked the USB debug option under Settings>Applications>Development>USB Debugging.

    so check Settings>Applications>Development>USB Debugging and ensure its unchecked, that might be it.
     
    TravisW0204 likes this.
  9. jimcraig

    jimcraig Well-Known Member

    Joined:
    Jun 8, 2010
    Messages:
    145
    Likes Received:
    9
    ok after a little digging it seems its the USB debugging that might have caused the issue.
     
  10. EarlyMon

    EarlyMon The PearlyMon Moderator

    Joined:
    Jun 10, 2010
    Messages:
    57,614
    Likes Received:
    70,271
    I access my rooted/nand access phone using adb and a command line. I'm not 100% positive, but I'm not sure why you'd want that turned on unless you're doing that. :confused:
     
  11. J03

    J03 Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    520
    Likes Received:
    66
    Same thing here. At work, the usb ports on the side of the monitor are hit or miss. The usb ports on the front of the tower work every time. This leads me to believe its a faulty port instead of an android problem though its odd that a soft reset would help some of you. I've even tried switching back and forth between the two right after each other and same thing, monitor no, tower yes, yet on occasion the monitor will work randomly.
     
  12. cary328is

    cary328is Well-Known Member

    Joined:
    Mar 1, 2010
    Messages:
    839
    Likes Received:
    427
    Also be aware that not all micro USB cables are charge and data capable. I learned this when I tried using a cable that came with an after market charger for data transfer. It didn't even give those options when plugged to a PC. I noticed the end connector had fewer pins than the stock HTC cable and other micro usb cables I had
     

Share This Page

Loading...