1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support USB question for Galaxy 2S Skyrocket


  1. rooster68

    rooster68 New Member

    I am new to this forum, I work for at&t, the cables that come in the box on all smartphones are the OEM data/charge cables. The zero charge chargers and cables we sell are charge only (except iPhone compatible cables) . I also own the skyrocket and am experiencing the same problem. Not only my computers but also my car. It worked before and just recently quit working. I have not had any of my customers complain of this, so notsure how common it is. If anyone has a solution that doesn't include a master reset, I would appreciate the info. Thank you.
  2. Midiman

    Midiman Well-Known Member

    So you can't make a USB data connection with your car? I'm not sure I'm following your problem...
  3. rooster68

    rooster68 New Member

    My car has an auxiliary input through USB to my car stereo, up until recently I was able to connect my skyrocket into the USB in my car and play my music through my car stereo's controls.
  4. WickR1

    WickR1 Active Member

    So I've tested this, and it seems my issue is the changing of the computers. I can plug it in all day at my house, but when I try to plug it in at work, I'll have to restart the phone for it to recognize it. After that, I can plug it into my work computer all I want with no issues, until I try to plug it back into my home computer. Restart fixes it, no need for a master reset.
    Midiman likes this.
  5. Midiman

    Midiman Well-Known Member

    Seems like it likes to "mate" with whatever device it was last plugged into... kind of like my last two Windows Mobile devices which would only allow connection to two computers... and similar to Apple. Restarting curing the problem is a lot better than the hard limits imposed by the other two devices I mentioned. Still... inconvenient.
  6. Mr. Ed

    Mr. Ed Well-Known Member

    Not having this issue and i regularly connect to 6 different PC's

    Can you guys give details on the PC's like os etc....same cable/different
  7. DFWRusty

    DFWRusty New Member

    Every time I plug my phone into either of my cpu's it pops up as a removeable disk, but when I click it, it shows the disc to be empty. I would rather not sync it, just because of the simplicity of docking it as a removeable disc. I used to to this with my blackberry torch (last phone I had before the skyrocket) and it worked fine! Is there a downloadable driver I can download?

    If that is not possible, what is a very basic and free sync program that I could use so that I can back up my music and pics?

    Thanks!
  8. Mr. Ed

    Mr. Ed Well-Known Member

    Try these drivers and make sure you are using a cable for charging AND data

    http://androidforums.com/3598368-post8.html

    I am going to go ahead an merge this with the existing USB connection thread.

    If I have misunderstood your question please let me know.
  9. Midiman

    Midiman Well-Known Member

    Actually, that's very cool. I don't drive so I haven't seen a lot of car stereo systems lately. Last I knew you were lucky if the head unit had an 1/8" line input. I have a home theater receiver that has a USB port which will play music off sticks and a couple of new Sony BluRay players that have USB ports which will let you play movies off sticks. I don't think I've ever even put a BluRay disc in either of them... but they play my 300+ DVD collection.
  10. WickR1

    WickR1 Active Member

    On mine, both PCs are running XP. Different data cords for both computers.
  11. Mr. Ed

    Mr. Ed Well-Known Member

    have you tried testing with just one cable?
  12. Midiman

    Midiman Well-Known Member

    Are you following these steps:

    Home Screen --> Settings --> Wireless and Network --> USB Utilities
    Then click "Connect Storage to PC"
    POP Up says: Connect USB cable to use mass storage.
    Plug in the USB cable.
    Pop Up says: USB connected,
    Click "Connect USB Storage"

    You should have some "Removable Storage Device" show up on your computer now.

    If that doesn't work, you may need to restart the phone as some phones like to get stuck on the last computer they were plugged into (if you're using multiple computers)
  13. Midiman

    Midiman Well-Known Member

    Do either of your cables have a small, black, plastic tag near the MicroUSB connector? Did you buy one of them from AT&T? If so, that cable is a charge only cable and will not work for data connections.
  14. WickR1

    WickR1 Active Member

    They are both data cables because I've used both cables with success.
  15. WickR1

    WickR1 Active Member

    I have not tired that. Figured if it works by just restarting the phone, it's not that big of a hassle.
  16. Mr. Ed

    Mr. Ed Well-Known Member

    true true.

    I wish I could be more like that. I waste so much time trying to figure out the "why"
  17. Ultimateone

    Ultimateone Well-Known Member

    So has anyone figured out how they heck to use this phone with a car stereo? I just switched from a Vivid to this and its not working at all.
  18. Mr. Ed

    Mr. Ed Well-Known Member

    Still have not tried...in the past it's been hit or miss with all of my androids ...I always just used bleutooth rather than the whole usb thing.

    I will add it to my list of things to try though
  19. Kailee135

    Kailee135 New Member

    My bf has the Samsung Galaxy S2 Skyrocket and it will not connect to the PC at all.
    We have tried installing the Samsung Mobile Phone driver, nothing changes. I have went through the steps using USB utilities and it shows its connected for 0.5 seconds and all the sudden its not connected at all. I have tried using USB debugging, connects for a moment and disconnects. I try to find it connected on my computer and its nowhere to be found as if the PC does not reconize the phone or the phone does not reconize the PC.
    As i said i have tried every driver i have read about on previous forums, Nothing works.
    Any other ideas?
  20. Mr. Ed

    Mr. Ed Well-Known Member

    Have you tried a different cable and or different USB port

    Lastly, uninstall the drivers through the control panel and reinstall via the link I provided

    Let me know how it goes
  21. JEngramAtty

    JEngramAtty New Member

    I'm sharing this because hopefully someone will find it, and get their problem solved. I wish someone else had posted this specific solution. It would have saved me 5 days of headache.

    I've read and tried all the advice in this thread and other places this week, and I've STILL been tearing my hair out. I just bought a new Samsung Galaxy S II Skyrocket with AT&T, and it installed PERFECTLY on my Laptop, (WITHOUT Kies, by the way!) but NOT my desktop.

    What I THINK happened was that when I first got the phone, I just assumed that Windows would recognize the phone on it's own. Silly me. When I first plugged it into my desktop, I had NOT installed the drivers. My Windows told me that it had found (in succession) a SAMSUNG_Android, a Samsung LTE Card USB Drive, and a Samsung LTE USB Drive, but EACH TIME, it immediately said that it could not find the right driver. Then I got the dreaded "UNKNOWN DEVICE" note, and then of course "A USB DEVICE HAS MALFUNCTIONED".

    INSTALLING THE DRIVERS AFTER THE FACT WILL THEN LIKELY BE USELESS

    I've spent about 6 HOURS EACH DAY this week pulling my hair out trying to determine the reason. I've found and followed more recommendations than I can count. Installed Kies. Uninstalled Kies. Install drivers, uninstall drivers, delete all the USB connections in device manager and let windows rediscover them, try to update the "Unknown Device" with any and all of the INF files in the Samsung USB Drivers directory. Ran two different Registry Cleaners.

    NO LUCK.

    SO I did it the hard way

    Set Device Manager to show you ALL devices, even the hidden ones, and unused ones. There's countless sets of instructions on how to do that on the web. Just Google it.

    1. Uninstalled Samsung Drivers.
    2. Uninstalled Kies (You really don't need it anyway.)
    3. Did a plain old "Search" for any remaining SAMSUNG folder in My computer and deleted them.
    4. Deleted all Unknown Devices under USB in Device Manager.
    5. Edited the System Registry to remove all references to Samsung or Kies.
    6. Ran a registry cleaner

    Here's the hard part:

    Dug into System Devices on XP on my LAPTOP (The machine with the "Known Good Configuration" that works). I determined that there are 2 ENTRIES EACH IN THE FOLLOWING AREAS FOR THE SAMSUNG GALAXY S II SKYROCKET on a computer that operates correctly:

    Under DISK DRIVES: SAMSUNG LTE CARD USB DEVICE and SAMSUNG LTE USB DEVICE
    Under Storage Volumes: 2 (Two) GENERIC STORAGE VOLUMES
    Under USB Controllers: 2 (Two) USB MASS STORAGE DEVICE entries.

    CAREFULLY examine the Driver Details Tab for these 6 (Six) entries, and write them down!

    It's the USB Controller entries that seem to be key, however: The Details will look something like this:

    USB\VID_04E8&PID_685B\10F918B6

    Whatever the string is, search your registry on that same computer for the last 8 digits: in my case, 10F918B6, and also for the PID_685B entries (Make sure "Match whole string is NOT checked)

    I ended up with 3 keys: HKLM\System\ControlSet001\Enum\USB\VID_04E8&PID_68 5B; HKLM\System\ControlSet002\Enum\USB\VID_04E8&PID_68 5B; and HKLM\System\CurrentControlSet\Enum\USB\VID_04E8&PI D_685B

    ALSO: Under those you'll note a DRIVER value that might start with: 36FC9E60...

    SEARCH FOR THAT TOO! I found: HKLM\System\ControlSet001\Control\Class\36FC9E60... But for THIS key, export ONLY subfolder that is referenced in the DRIVER value of the previous 3 keys for instance, mine was \0070. My computer had other subfolders referencing other programs NOT related to my phone, or software.

    SEARCH ALSO for "Samsung": You should also find: HKLM\Software\Samsung\USB\Driver Under that will be a string that starts: D0795B21...

    If you THEN search for D0795B21... you'll find HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall, and under it will be references to the Samsung USB Driver Directory files in Windows Explorer.

    EXPORT ALL OF THESE KEYS TO A LOCATION OF YOUR CHOOSING. 6 (six) if I counted right.

    Now that you have these keys exported to a Flash Drive or something, go to the machine that DOESN'T recognize your Skyrocket.

    Make sure you've uninstalled as good as you can, all the old attempts to install. Remove the Unknown Device, Uninstall the Samsung Directory, Do a search for SAMSUNG in "Search", and delete all the folders. Search your registry for Samsung (and you might as well search for the same keys you found on your good machine.) and remove all the old stuff.

    Run a registry cleaner if you have one.

    REBOOT.

    Install the Samsung Drivers again!

    I then verified in my registry that Samsung already was in it's place in HKLM\Software\Samsung\USB\Driver and so was the D0795B21 string. Also present was the HKLM\Software\Microsoft\Windows\CurrentVersion\Uni nstall entry with the references to the Driver folders.

    On a whim, I tried to have XP recognize the Skyrocket again, but mine AGAIN failed.

    I checked the registry, but the 3 registry keys containing 10F918B6 and the connected Class Key (36FC9E60) were NOT present (Yet!)

    Plug in your Flash Drive. Click each registry icon on the flash drive to incorporate the keys from your known good configuration into the registry of the computer that DOESN'T work. You'll have to confirm that you REALLY want to plug those entries into your computer.

    I then went back into my Skyrocket. Went into USB. Tapped Connect. Plugged the cable in.

    My computer IMMEDIATELY recognized a SAMSUNG_Android, a Samsung LTE Card USB Drive, and a Samsung LTE USB Drive.

    Bingo. Done. I tried to attach my pertinent Registry Keys, and I'm not sure why, but I couldn't upload as RAR. I changed the extention to ZIP. You might have to change it back to RAR before unpacking. As noted, I didn't need the Samsung Key, or the Uninstall Key, as reinstalling the Drivers added those, but I did need CS001, CS002, CCS, and Class.

    If you've tried everything else, I hope this helps!

    Attached Files:

  22. catmek64

    catmek64 Active Member

  23. satyaramisetty

    satyaramisetty New Member

    The drivers from this download really helped my T-Mobile SII connect with Kies software. Samsung sucks with their software
  24. LevelMarc

    LevelMarc Member

    OK I have the same problem. There is NO TAG on the USB cable. It is hit or miss on connecting. It is very dependent on the USB port used and as I'm finding out the USB cable. The ONLY cable that has worked is the one that comes with the phone. I have to have KIES open to get the phone to act as a USB storage device. I've talked to Samsung support and they know about all these issues but don't have an answer.
  25. catmek64

    catmek64 Active Member

    I've been having usb mass storage problems the last week, also. Nothing would fix it, including trying 3 other puters, one an XP. This, a Skyrocket. Then I stumbled upon this idea - from a guy in India.

    Quote -
    " Cannot connect to Windows7 64 bit no matter what

Share This Page