USB stops working after upgradeSupport


Last Updated: 2012-05-21 19:20:53
  1. galaxs2

    galaxs2 New Member

    Hello,

    I found tons of similar questions on the net, but none of them with satisfactory answers, so I'm posting precise details here.

    I have a brand new Galaxy S II (received 2 days ago) which started by working fine. This morning, it got a software upgrade (standalone, not through Kies) and after the reboot, the USB connectivity is gone (so is the modem one).

    I tried everything, including USB debug mode and stuff, reinstalling Kies, restarting the computer, but nothing. It seems to be a driver problem:

    when I connect the USB cable, my Mac (Snow Leopard) says it got a connection to a 7 CDCs. But then it complains on the console, saying that it failed to find a CDC driver.

    My phone specs are:
    - GT-I9100G
    - Android 2.3.6
    - Baseband I9100GXXKL4


    Can someone please help ?

    Many thanks in advance.

    Advertisement
  2. galaxs2

    galaxs2 New Member

    Given the success of this thread, I'm replying to myself :)

    After digging a bit deeper, I think the problem may be related to Kies (which has also been upgraded). I've monitored the installation of drivers in /System/Library/Extensions, and it appears that the latest Kies installs only a file called ssuddrv.kext.

    However, I think that some others are missing: com.devguru.driver.XXX, XXX being SamsungComposite, SamsugMTP, SamsungACMData, SamsungACMControl and SamsungSerial.

    These files are reported missing by the uninstall tool, so I'm assuming they should have been installed...

    Any idea where I could find those Mac drivers ?
  3. galaxs2

    galaxs2 New Member

    Miracle solution found by chance on facebook: dial *#7284#, then de- and re-select UART -> MODEM and USB -> PDA...
  4. gmureddu

    gmureddu New Member

    I had to manually reinstall the drivers which the last KIES update placed under /Applications in my system... Using some command-line magic I was able to get the drivers up and running again, but then even though KIES detects now the device, it fails to actually "connect" to it... What I had to do was:

    • Open a console terminal window from Applications→Utilities→Terminal.
    • Enter the following:
      Code (Text):
      1.  
      2. sudo chown root:wheel -R /Applications/ssuddrv.kext
      3. sudo cp /Applications/ssuddrv.kext /System/Library/Extensions/
      4. sudo kextload /System/Library/Extensions/ssuddrv.kext
      5. sudo kextload /System/Library/Extensions/ssuddrv.kext/Contents/PLugins/{ssudmtp.kext,ssudmdmdata.kext,ssudmdmcontrol.kext}
      6.  
      You may have to individually load ssudmtp.kext, ssudmdmdata.kext and ssudmdmcontrol.kext if the {} trick doesn't work for you (I did this on SnowLeopard)
    • Check everything is correctly loaded with
      Code (Text):
      1.  
      2. sudo kextstat | grep Samsung
      And you should see five com.devguru.driver instances listed.


    I will have to try and reboot to see if I can now connect to my SGS2. The modem/PDA trick listed above did not work for me.

    Edit: Forgot to mention the ssudserial.kext up there...

    Edit2: Had to reboot the SGS2 to be able to connect to Kies... Still no ICS for my region yet, though :(
  5. keeth

    keeth New Member

    Having the same problem with my Galaxy S2 (SGH-I727R).

    The latest Kies for Mac (1.3.0.12052_14) is definitely pretty broken. After installing, it did not detect the phone at all, with errors like:

    Code (Text):
    1. 5/21/12 10:54:07.000 AM kernel: 0        1 AppleUSBCDCACMControl: start - Failed to find the CDC driver
    2. 5/21/12 10:54:08.000 AM kernel: 0        2 AppleUSBCDCACMData: start - Find CDC driver for ACM data interface failed
    Initially I had two of the kexts running in the kernel (SamsungComposite, SamsungACMControl), after running the above kextload commands, I had four (first two plus SamsungMTP,SamsungACMData), but at some point SamsungMTP got kicked out of the kernel it seems, so now I'm back to three.

    The good news is Kies is now at least detecting the phone, but it spins endlessly trying to connect.

    When I connect the phone USB, in the console I see a lot of lines of:

    Code (Text):
    1. 5/21/12 12:05:01.198 PM Kies: writestring ====>>> AT+PROF=CONTINUE, timeout = 15.000000
    With the occasional line like:

    Code (Text):
    1. 5/21/12 12:04:58.233 PM Kies: writestring ====>>> AT+PROF="Phonebook_com.google", timeout = 15.000000
    2.  
    Then these two final lines:

    Code (Text):
    1. 5/21/12 12:05:01.264 PM Kies: writestring ====>>> AT+PROF=END, timeout = 15.000000
    2. 5/21/12 12:05:01.328 PM Kies: -[BTUIDeviceManager onReceiveDeviceNotification:] ENTER
    But Kies never connects. Tried rebooting computer and phone, factory reset, etc. Seems like a pretty common problem given all the forum activity, blog posts etc. Wonder if I'd have more luck on a PC?

    Is Kies required for OS updates, or does Samsung do OTA as well?

    Update: here are my specs:
    * SGH-I727R
    * Android 2.3.5
    * Baseband I727RUXKJ7
    * OSX 10.7.4
    * Kies 1.3.0.12052_14

Share This Page