USB Storage - Windows 7 won't recognizeSupport


Last Updated: 2011-08-31 20:59:55
  1. mike.mossop

    mike.mossop Member

    Hi,

    I recently purchased a Samsung Galaxy S2, and I am having trouble with moving files from my PC (Windows 7) to the USB storage on the device (I have yet to purchase a micro SD card, but there should be about 10 GB still available in terms of USB space).

    Thus far I have installed Samsung Kies to my desk top, and that seems to recognize the phone and be able to transfer files ok.

    When I plug the device into my computer there is a Windows 7 pop-up that appears and gives me the options to browse files on my device, synch with Windows Media Player, etc. In this way Windows DOES recognize the device and I can browse the files ok.

    That being said, if I don't go through that initial pop-up window I cannot find the device anywhere under My Computer in Windows (where different devices and drives typically appear).

    This is a problem because the program I am trying to use to sync my music (Songbird with Folder Sync plug-in) requires that I browse to the target folder on the phone that I want to sync to. Much like going through My Computer, the device simply does not appear where it should in this case.

    Any help would be much appreciated!!

    Mike

    Advertisement
  2. ziggyball

    ziggyball Member

    if you want you can connect the sgs2 in legacy USB mode by going to:
    options->wireless and network->USB Utilities
    In this way the phone and card appear as regular drives in explorer..

Share This Page