USB Tethering


Last Updated:

  1. reemas

    reemas Well-Known Member This Topic's Starter

    Joined:
    May 31, 2010
    Messages:
    128
    Likes Received:
    34
    I was able to use my EVO to tether for the last few days. I recently updated my EVO (with today's OTA update) and now it seems I can no longer tether via USB.

    When I go to:
    Menu -> Settings -> Wireless -> Internet Sharing

    and check the box, it gives me error 67. My mobile network says connected, but when I click Internet Sharing, it disconnects.

    Like I said, this was working previously, so if anyone has the same issue or knows of a fix, please let me know. Thanks in advance.

    edit: I called Sprint and they said that wired USB tethering is not available without paying the $30/month hotspot fee. But he also didn't seem too sure...
     

    Advertisement
  2. IPvFletch

    IPvFletch Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    441
    Likes Received:
    28
    Error 67 is a profile issue. Update your profile under Menu > Settings > System Updates and see what happens.

    I had no clue this was part of the hotspot feature, I don't recall them saying that. I've not tried this yet though (no need to as wifi hotspot is sufficient for me).
     
  3. reemas

    reemas Well-Known Member This Topic's Starter

    Joined:
    May 31, 2010
    Messages:
    128
    Likes Received:
    34
    IPvFletch, thanks for the response. I tried what you said, gave the phone a restart, updated the PRL and profile, and tried again.

    Still get error 67. I'm curious to see if anyone who updated today can tether with the built in options of USB tethering.
     
  4. BenChase7

    BenChase7 VIP Member VIP Member

    Joined:
    Jun 16, 2010
    Messages:
    2,233
    Likes Received:
    876

    I cold not USB teather via this route before the update. Havent tried after, as i assume its the same. I downloaded PDANet and use that. It works great every time.
     
  5. bvbull200

    bvbull200 Banned

    Joined:
    Jun 5, 2010
    Messages:
    999
    Likes Received:
    197
    I couldn't get it to work before the update using the built-in tethering (I was getting Error Code 67 as well), but it worked fine with PDANet.

    I did the OTA update tonight as well as updated my profile and now the built-in tethering works fine.

    As a matter of fact, I made this post while testing it out! I still think that PDANet works "better" as far as the speed with which it connects to your computer, but this gives the extra flexibility of using it on a computer that doesn't have the complimentary program installed on it.
     
  6. iamfunkyz

    iamfunkyz Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    89
    Likes Received:
    19
    Just curious...are you paying the $30 a month for the wireless hotspot? And when you tether, is it 3G you are sharing?
     
  7. maxx2496

    maxx2496 Active Member

    Joined:
    Jun 8, 2010
    Messages:
    33
    Likes Received:
    2
    I used tethering several times before the update. Havent tried It yet. I will let you know sometime tomorrow if It works for me. Check back later for a response. Also does anyone elses keyboard lag horribly when typing online like rightnow as I type woth my evo? Any fix for this?
     
  8. Roq

    Roq Well-Known Member

    Joined:
    Oct 22, 2009
    Messages:
    111
    Likes Received:
    16
    I get the same error, and ONLY updated the profile, I have not done the firmware update yet.
     
  9. BenChase7

    BenChase7 VIP Member VIP Member

    Joined:
    Jun 16, 2010
    Messages:
    2,233
    Likes Received:
    876
    ive updated everything and cannot teather (unless i use PDA Net).

    No Keyboard lag at all.
     
  10. bvbull200

    bvbull200 Banned

    Joined:
    Jun 5, 2010
    Messages:
    999
    Likes Received:
    197
    I'm not paying the $30/mo. and I was tethering 3g. I believe I had 4g turned off. No root either.
     
  11. probinson

    probinson Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    123
    Likes Received:
    47
    I USB tether just fine using 4G and no special apps loaded (no PDAnet). I also have the update installed. I do seem to need to have USB Debugging turned on.
     
  12. gelatinguy

    gelatinguy Member

    Joined:
    Jun 6, 2010
    Messages:
    16
    Likes Received:
    3
    It's been the same for me before and after the update. I can tether using USB with every set up except for 3G using HTC's sharing. I get error 67 if I do that. All the other tethering options still work (including 4G using HTC Sharing, easy tether, PDAnet). My 4G signal seems much worse now though, can't hold a connection for more than 1 minute. That might just be due to this area (Los Angeles) not officially having 4G yet though.
     
  13. Carl6

    Carl6 Well-Known Member

    Joined:
    Jun 20, 2010
    Messages:
    58
    Likes Received:
    1
    Easy tether, no root, 3G or 4G (or wifi actually) lets me tether before and after upgrade. Do need USB debugging turned on for it to work.
     
  14. fitforlife

    fitforlife Member

    Joined:
    Jun 26, 2010
    Messages:
    13
    Likes Received:
    3

    EasyTether is free and works perfectly with my laptops. Just installed the ET app on my phone and laptop and connected my phone and it worked the first time. Nothing else to do.
     
  15. reemas

    reemas Well-Known Member This Topic's Starter

    Joined:
    May 31, 2010
    Messages:
    128
    Likes Received:
    34
    weird, now it works. and while I'm roaming on Verizon. not sure what the issue was last night, but hopefully it doesn't happen again.
     
  16. bimmjo

    bimmjo Well-Known Member

    Joined:
    Oct 31, 2009
    Messages:
    131
    Likes Received:
    25
    weird, I had the same problem the night of the update I was unable to do it, now i am updating this using easy tether??

    As long as it works, i can live with the one nite off, although I am sitting in a customers home and unable to do some updates to their presentation cause I needed the internet access, still got the sale made so all is well.

    I am also able to do 3, or 4g and wifi (which would seem pointless) my speed tests were solid but not spectacular

    3G .63Mbps Down and .27 up
    4G 3.71 Down and .19 up - and my signal was very weak no bar to one bar

    wifi with clear - 4.31 down and .94 up
     
  17. XOS THW

    XOS THW Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    120
    Likes Received:
    12
    When some of you say that tethering doesn't work anymore after the latest upgrade...does that include PDANet not working anymore?

    I'm still holding out. (non-rooted)
     
  18. themrodc

    themrodc New Member

    Joined:
    Jun 17, 2010
    Messages:
    3
    Likes Received:
    1
    PDANet works just fine for me, even after the latest upgrade.
     
    XOS THW likes this.
  19. XOS THW

    XOS THW Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    120
    Likes Received:
    12
    Thanks.
    Anyone else?
     
  20. rramani

    rramani Member

    Joined:
    Jun 1, 2010
    Messages:
    6
    Likes Received:
    0
    Don't know about PDAnet, but Easytether works fine for me.
     

Share This Page

Loading...