USB won't connect on Samsung Galaxy YSupport


Last Updated:

  1. Dosage

    Dosage Member

    I bought this phone 2 weeks ago, and it worked fine for all that duration, but since yesterday it won't connect to my laptop (Windows 7). It charges when I connect it but it stopped recognizing it as a storage thingy.

    Advertisement
  2. chanchan05

    chanchan05 The Doctor Guide

    Install Kies on laptop so that it will download all updated drivers.

    Also when connecting, check notification bar for "USB connection" notification.
  3. Dosage

    Dosage Member

    Yeah that's where I usually connect from.

    And thanks, I will try downloading Kies.
  4. Dosage

    Dosage Member

    Downloaded Kies, updated the drivers, still the same problem...
  5. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Moved to Samsung Galaxy Y section. :)
  6. anilkumar666

    anilkumar666 New Member

    go to Device Manager and then to Universal Serial Bus controllers now will see yellow thing on drivers update them and try. if still doesnt work unistall it and plug ur phone. now drivers will be installed if not still working, install google usb driver. now my phone is detected in my laptop which has windows 7
  7. malania

    malania Member

    I was having the same problem few days back. I just searched for samsung galaxy Y USB driver, a 23 mb file (can't post link; not allowed) and it started detecting.
  8. This. :)
  9. This... doesn't fix the issue whatsoever.

    I have the same problem with my Galaxy 2 tab and my Galaxy s2 phone. I have to play with a bunch of settings and eventually it connects, but it's an ugly, buggy connection and after awhile it decided to stop transferring files.

    Here's what I do:
    Once it's plugged in, about 10% of the time it actually works right off the bat. 90% of the time, it says "Hardware ID Missing" or something along those lines. What I'll do then is go to my device and under the setting menu, select DEVELOPER OPTIONS, then select "USB Debugging". This sometimes does the trick.

    If it doesn't, I go to the dropdown menu at the top off the device. I select the usb symbol and switch between "MTP" or "camera". You have to give each selection a minute to register with your computer. More often than not, this works. IF not, I click on USB DEBUGGING again.

    Sometimes I have to disconnect the device and reconnect it and start all over again, but I always get it to work... eventually. It's been a nightmare though. I wish there was a fix.

    I was having a problem with windows 7 picking up a SanDisk Cruzer flashdrive I bought but luckily there was an easy fix to that: I just deleted and INF file and it created a new one automatically.

Share This Page