Use galaxy ace as USB driveSupport


Last Updated:

  1. praky

    praky Well-Known Member

    I wish to use my phone as a pen drive sometimes.
    The problem is when I connect to windows xp, XP detects a new hardware and tries to get drivers from net which is not possible on every computer (suppose I am in market to take a print-out).

    Is there any way to use my phone as mass storage?

    All nokia phones trigger a dialog upon USB connection where a 'mass storage' option is available. No drivers are needed on XP for that. I have tried that.

    Advertisement
  2. brumex

    brumex New Member

    Just go to settings>application settings>development and uncheck usb debugging.

    Now connect the ace to the computer without running kies.

    Then an android image will appear with the legend: USB connected

    Under that there is a button that says "turn on USB Storage" click on that

    now you can use the ace as a pendrive.

    Enjoy!
    charan4ever likes this.
  3. praky

    praky Well-Known Member

    Doesn't work. disabling usb debugging doesn't have any effect on a compu. which doesn't have the usb drivers already.
  4. Gammer

    Gammer Well-Known Member

    I use mine as mass storage all the time praky, I rarely use Kies to transfer anything to or from the phone.

    If you're using windows 7 once you plug the ace in via usb it will install the drivers to use as mass storage and open a prompt to view files.

    Have you checked in device and printers and tried running it that way?
  5. gandaran

    gandaran Active Member

    you don't have to disable usb debugging or install any drivers for mounting the phone, just plug in the usb cable then open the notification window and press the "turn on USB Storage" option wait a few seconds to complete then you can find the the usb phone drive in the file browser.
    or you can install a usb storage mount app from the market, it'll be faster mounting using the app.
  6. praky

    praky Well-Known Member

    Guys, you are not understanding....
    If there aren't any usb drivers installed, there is no notification on the phone. So no icon in notification box and no 'turn usb storage on' option.

    On the computer you get a dialog to install the drivers,
    On some win7 machines, i think the drivers get installed.
    But on win XP- never without an internet connection.

    A nokia phone on the other hand has no such problems.

    If you want to check, connect your phone to someone else's computer with net off and kies not installed. post your findings.
  7. gandaran

    gandaran Active Member

    no, it does work! at least here, I did connect to windows 7 first time with the phone before installing the drivers with the samsung kies software so it does work, you should look in the notification window for the select to copy files option first and then turn usb storage on.
  8. freespeech

    freespeech New Member

    Its a genuine problem i face with my Galaxy Ace but not with the Galaxy Fit. it works if you try to enable and disable the Debugging mode, but i am unable to connect using USB storage mode.
    Both my phones work perfectly fine on Linux Mint & Ubuntu but i face this problem on Windows Xp. so need a good solution for the same.
  9. fullspectrum

    fullspectrum New Member

    Ok...I know this is a dead thread but I thought I might be able to help someone out...I've taken so much from the internet I like to give back when I can.

    I was going crazy trying to get my Galaxy Ace to connect to my computer to transfer files. I just wanted to mount the USB and not install Samsung software. No matter what I did I couldn't connect. It was charging the phone but not connecting.

    THE PROBLEM...I was using a generic USB to phone cord and once I used the Samsung one I could hear the phone connect. Then I slid my thumb down from the top of the screen to get the little shortcut menu. And sure enough it said "connect USB" and BAM...I could see the phone as "removable storage" and could transfer files.

    It really pissed me off..I must have switched cords around and after 2 hours of **cking around :banghead: I thought of the cord:stupido2:....maybe I can save someone the trouble. USE THE SAMSUNG USB CORD....

Share This Page