Using Google Voice for texting, getting 2 notifications


Last Updated:

  1. iPhoneMilk

    iPhoneMilk Well-Known Member This Topic's Starter

    Joined:
    Oct 29, 2009
    Messages:
    207
    Likes Received:
    5
    Anyone else having this problem?

    When i get a text i get a notification from google voice, THEN from messaging.... anyone know a workaround?
     

    Advertisement
  2. lvlln

    lvlln Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    84
    Likes Received:
    10
    You could disable text forwarding on your Google Voice account. That way it doesn't also send you a regular text message (and you can save money on the text plan).
     
  3. iPhoneMilk

    iPhoneMilk Well-Known Member This Topic's Starter

    Joined:
    Oct 29, 2009
    Messages:
    207
    Likes Received:
    5
    I actually tried this out already assuming it would fix the issue.

    But when you disable text forwarding you don't even get a notification from google voice anymore.
     
  4. iPhoneMilk

    iPhoneMilk Well-Known Member This Topic's Starter

    Joined:
    Oct 29, 2009
    Messages:
    207
    Likes Received:
    5
    Nevermind fixed it guys... if you go into the messaging app you can remove notifications on that by itself. =)
     
  5. russell5

    russell5 Well-Known Member

    Joined:
    Nov 7, 2009
    Messages:
    206
    Likes Received:
    19
    If you disable text forwarding in google voice you should still get notifications form GV app on the phone. I do
     
  6. yehgermeister

    yehgermeister New Member

    Joined:
    Nov 15, 2009
    Messages:
    2
    Likes Received:
    0
    how do you disable text forwarding? i hate that i receive two different notifications, and the fact i'm being charged for the extra texts.

    p.s. if it's the send a text (sms) message to mobile under settings in google voice, it's already unchecked. but i'm still getting notifications under messaging on my phone. :/
     
  7. JoeC

    JoeC Well-Known Member

    Joined:
    Sep 23, 2009
    Messages:
    216
    Likes Received:
    1
    But that solution is going to eliminate notifications from all SMS and MMS messages. If the GV alert is the one you want to eliminate, just change the GV option for SMS forward to your phone.
     
  8. MichaelCampbell

    MichaelCampbell Member

    Joined:
    Nov 1, 2009
    Messages:
    15
    Likes Received:
    1
    And how do you do that? I can't find this option on the GV web page(s)...
     
  9. opgarlic

    opgarlic Member

    Joined:
    Nov 6, 2009
    Messages:
    10
    Likes Received:
    1
    edit settings under your mobile phone number, uncheck the box "receive SMS on this phone" texts will cost you through the "messaging" app....free through GV
     
    PittCaleb likes this.
  10. MichaelCampbell

    MichaelCampbell Member

    Joined:
    Nov 1, 2009
    Messages:
    15
    Likes Received:
    1
    PERFECT. Thanks so much!
     
  11. CycloneFever

    CycloneFever Well-Known Member

    Joined:
    Jan 15, 2010
    Messages:
    88
    Likes Received:
    3
    I'm having a similar problem. When someone sends me a text to my GV number, I get that text but it appears that I also get one in the messages application. I think the solution is in this thread but I just want to be clear.

    In GV web settings, I have went to my phone settings to edit them. I have unchecked the box for SMS forwarding. The explanation isn't very clear, but I think that checking this box causes a text sent to your GV number to be forwarded to your regular phone number, correct? So unchecking the box should allow a text sent to your GV number to go to the GV app on your phone, but will not send a duplicate text on to your regular number, correct?

    Hope this is right or I'm back at square one. I don't text a lot but getting dinged two dimes each time isn't fun.
     
  12. Wisdom

    Wisdom Well-Known Member

    Joined:
    Dec 19, 2009
    Messages:
    57
    Likes Received:
    1
    On the web client Settings>Phones>Edit (Whatever phone you are using)>UNcheck "Receive SMS on this Phone"

    When you've done this, incoming texts will ONLY show up using the GVoice app, and not be forwarded to your actual Verizon number.

    The only thing I don't like about this solution is that the maximum refresh rate for the GVoice app appears to only be 5 minutes. It is not a push notification. Can anyone verify if that's correct?
     
  13. CycloneFever

    CycloneFever Well-Known Member

    Joined:
    Jan 15, 2010
    Messages:
    88
    Likes Received:
    3
    Thanks. This is the exact situation I'm looking for. I don't text much so I don't rely on the instant communication and I can live with a slower refresh. But I absolutely do not want forwards to my regular number as I don't have a text plan.
     
  14. Douglas Hughes

    Douglas Hughes Member

    Joined:
    Jan 15, 2010
    Messages:
    10
    Likes Received:
    0
    I am having similar issues to others posting here. I was getting multiple notices and I think that I get why this was happening but I would love some opinions on the following;
    Trying to not pay for texting ( I have a droid and no text plan) I figured out that I have to send texts through voice not messaging. How do I stop texts from my verizon number and still allow them from my voice number on the motorola droid?

    and how can I be sure that I dont get 2,3 or 4 notices on texts?
     
  15. Nicks88

    Nicks88 Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    337
    Likes Received:
    59
    Rage building...
     

Share This Page

Loading...