Using GS2 with Att: unable to delete default APNSupport


  1. chanukya

    chanukya New Member

    Hi everyone,

    I ordered a Galaxy S2 from Amazon a couple of days ago to use with ATT here in the US. The phone appears to be a UK phone as the language setting was English on Power up.

    I have an iPhone 3G, and when I took the phone to the ATT store to swap the sim cards, I had voice but no data. On checking the APN configs, here's what I found:

    There were 2 APN configs, ATT Phone and ATT WAP. ATT Phone was editable/deletable, but ATT WAP (using wap.cingular) was not. ATT Phone was selected by default.

    There was a radio button that required that one option or the other be selected, selected option turned the button green.

    ATT WAP has both Proxy and Port entries blank, all else is the same as the Samsung Infuse which I checked out in the store.

    I've seen a lot of threads in the forums instructing to delete all APN settings and recreate. I would love to do that, however, the ATT WAP entry cannot be edited or deleted, but is simply greyed out.

    After trying multiple options all day, I'm not able to figure out how to get this APN entry deleted, and create 2 new APNs without selecting either of them. Could anyone help? Otherwise my only option at this point is to return the phone and wait for it to pop up on ATT at some distant point..

    Advertisement
    :
  2. Shotgun84

    Shotgun84 Well-Known Member

    When at apn settings press menu and then new APN. Then you can fill in all the data and select this new apn. When I created a new one I didn't delete the old ones, which isn't a problem as they aren't selected.
  3. chanukya

    chanukya New Member

    Actually, that is what I did - I created several new APNs leaving the greyed out default in place.

    However, I can select only option, and using a APN setting of 'phone' and 'internet' does not give me any data, but gives me voice.

    Using a APN setting of 'wap.cingular' with internet+MMS seems to work, but makes all phone calls data calls, consuming data instead of minutes.

    So at this point I don't know if we need 2 different APNs to get both voice and data to work the way they are supposed to, and if so, how do I select both when the radio button allows only one selection?
  4. Screech

    Screech Well-Known Member Contributor

    My settings are as follows from my mediaNet settings:

    APN: wap.cingular
    Proxy: <Not set>
    Port: <Not set>
    Username: WAP@CINGULARGPRS.COM
    Password: CINGULAR1
    Server: cingulargprs.com
    MMSC: http://mmsc.cingular.com
    MMS proxy: wireless.cingular.com
    MMS port: <Not set>
    .....
    Authentication type: <Not set>
    APN type: internet + mms
    rchao likes this.
  5. jaliy

    jaliy Well-Known Member

    Why would u want to delete apn?
  6. chanukya

    chanukya New Member

    Screech:

    Thank you for your settings, are you sure that your phone calls are not being placed as Data Calls? When I tried a simliar wap.cingular APN with internet+MMS, it appeared that all my phone calls were going through as data calls - my minutes were not being decremented, but phone calls were showing up in the data usage.

    Jaily:

    Because everywhere on the internet the instructions are to delete the default APN and re-enter the settings from scratch. And as I mentioned, I'm not able to delete the default WAP.cingular APN.
  7. stevehy

    stevehy Well-Known Member

    This is not correct as i have had my SGS2 for 4 months with those settings and never do phone calls go as data calls.
  8. Screech

    Screech Well-Known Member Contributor

    I'm quite sure it is using voice minutes for voice calls. I've been using this phone since June and gotten a few bills and looked at my account often after getting this phone to see if they bumped my data plan. I can make pure data calls using a SIP phone client, normally only do this on WiFi in areas that my phone's signal is weak though. Also do it for calls to/from the US while in EU, but I have my EU sim in then.
  9. chanukya

    chanukya New Member

    Screech,

    Thank you for the settings. I finally got the phone working with it, wanted to wait a couple of days to make sure both voice and data were working correctly, all appears well.
    Slug likes this.
Loading...

Share This Page