Using Telus HTC Desire on Rogers Network.. "No SIM Card in Phone" ErrorSupport


Last Updated:

  1. ehoulston

    ehoulston Member This Topic's Starter

    Joined:
    Oct 8, 2010
    Messages:
    7
    Likes Received:
    0
    I just got an HTC Desire that was locked to Telus (Canadian Carrier). I have read that numerous people are using it on Rogers network. From the day I got it when I put my rogers sim card in (the right way) it said "No SIM card in phone" so I could not enter an unlock code. Thinking the SIM was defective went to Telus and tried one of their sim cards and it worked fine, then I went to Rogers thinking it was a problematic card. We tried 4 cards and none of them worked. I then went to Bell (another canadian carrier) and tried their sim card. It worked as well but said that the phone was locked. I purchased an unlock code from the internet which worked. Now the Bell sim card works as well becuase the phone is unlocked. I put my Rogers SIM back into it and it still sais "No SIM card in phone". I also tried a SIM from a european company and it did not work as well. This HTC Desire works on the same 3G 850/1900 GSM that Rogers uses.
    Im close to giving up. Please help me:)
     

    Advertisement
  2. smoore22

    smoore22 Member

    Joined:
    Aug 30, 2010
    Messages:
    8
    Likes Received:
    4
    I had no problem getting the phone to work with my Rogers SIM. Since unlocking the phone does not void the warranty according to everything I have read, I would be inclined to contact HTC support for assistance.
     
    ehoulston likes this.
  3. bfksc

    bfksc Well-Known Member

    Joined:
    Aug 29, 2010
    Messages:
    1,262
    Likes Received:
    201
    Same here...in fact I've used three different SIMs in my Desire. The original Rogers SIM that I used when I unlocked the phone and it worked fine. The Bell one that I used from my wife to confirm it worked on their network ok. And the new Rogers micro-SIM that works in both mini and micro phones.
     
    ehoulston likes this.
  4. ehoulston

    ehoulston Member This Topic's Starter

    Joined:
    Oct 8, 2010
    Messages:
    7
    Likes Received:
    0
    I've thus far found out that I have a telus phone that has a non telus OS installed. The Baseband version is 32.41.00.32U_4.08.00.09. Im just migrating from a Blackberry so all of this is new to me. From what Ive read I think I have to make a gold card then install a different RUU??? Please let me know if im making a mistake. Any help is greatly appreciated!
     
  5. Tlove

    Tlove New Member

    Joined:
    Oct 9, 2010
    Messages:
    2
    Likes Received:
    2
    Try this thread, might be able to help : Update to stock HTC Froyo. Did you buy it directly from Telus? Wonder why you have different software than the rest of us.
     
    ehoulston likes this.
  6. ehoulston

    ehoulston Member This Topic's Starter

    Joined:
    Oct 8, 2010
    Messages:
    7
    Likes Received:
    0
    I bought the Cell online. Cant figure this one out at all. I made a gold card and upgraded to 2.2 successfully. Still the "No Sim Card In Phone" error.
    I think im going to give up unless someone has another suggestion.
    the worst part is that I have found some people online who have solved the problem but after they did they stopped posting to the thread! I promise not to be one of those people.
     
  7. ehoulston

    ehoulston Member This Topic's Starter

    Joined:
    Oct 8, 2010
    Messages:
    7
    Likes Received:
    0
    Update: When I go to Model # in phone identity it says its a A8181 which is 900/2100. Im thinking this is why it wont recognize my Sim card. In order to change the Model #, do I have to change RUUs, do I need to root the phone, or do I have to do something completely different. Sorry I just migrated from a BB. Please help as I cant wait to use this beauty!!
     
  8. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    I think you either need to return teh phone to whoever you bought it from or get a Telus sim.
     

Share This Page

Loading...