[Verizon] Bricked My GNex

Last Updated:

  1. RichSz

    RichSz Not Entitled VIP Member

    I realize this is fixable but at this point I can't figure out how to get out of it.

    I decided to install JBSourcery and followed Chief's instructions to the letter.


    It went horribly wrong.

    I can get to the TWRP bootloader but one of the steps...

    There are four partitions you want to completely wipe: wipe data (factory reset: do NOT wipe internal memory! NO NO NO!), cache, Dalvik and system. Take a deep breath and wipe those four partitions. You can also use a zip program called Superwipe: it formats the four partitions for you.

    ...seems to have wasted my internal memory thus the zips I had stored on the phone are gone. Poof! Tried mounting everything from TWRP to no avail. Luckily I copied EVERYTHING to my PC so I have all of that but now need to flash the ROM from my PC. Apparently this method is so antiquated that there are no useful instructions on how to accomplish this. Every one assumes a .img file which I do not have.

    So I stare at my dead phone (OK, my phone in recovery) and could use a hand getting things sorted out. Just pointing me in the right direction would be wonderful.

    Thanks in advance.

  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    Rich, please tell me you have a backup!
    Woops, misread your post. Are you able to mount your SD and push a full ROM?
    RichSz likes this.
  3. RichSz

    RichSz Not Entitled VIP Member

    This is the worst question I can ask: please define backup.

    I backed up my apps with Ti, I made a nandroid with TWRP, I copied everything off of my "sdcard" onto my PC. I hope that covers it.

    (Yes, I'm a noob, this is the second time I've done this.)
  4. breadnatty08

    breadnatty08 pain rustique VIP Member

    No worries. So is the Nandroid on your device or was it wiped as was your entire SD card?
    (ah, forgot MTP is really difficult to achieve with the Gnex in order to push a file in recovery. I'll try to get some other help since this isn't something I've done)

    Sorry, Nandroid/backup should be that done with TWRP before (hopefully!) you flashed Sourcery.
    RichSz likes this.
  5. RichSz

    RichSz Not Entitled VIP Member

    I'm pretty sure the nandroid is toast.
  6. RichSz

    RichSz Not Entitled VIP Member

    In /data/media I have a TWRP directory. Does that count as mounting my SD?
  7. breadnatty08

    breadnatty08 pain rustique VIP Member

    So you can't boot and are just stuck in recovery, is that correct?
    RichSz likes this.
  8. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    So you are in recovery with no ROM.zip to install? You should be able to use ADB to push a rom zip to the phone and install it using TWRP. Unless I missed something.

    Or use ADB to push a nandroid back to the phone and restore that using TWRP
    RichSz and breadnatty08 like this.
  9. RichSz

    RichSz Not Entitled VIP Member

  10. breadnatty08

    breadnatty08 pain rustique VIP Member

    Pup's right. I'm not an ADB user, but that should be the way to roll.
    RichSz likes this.
  11. RichSz

    RichSz Not Entitled VIP Member

    Also correct. It's a matter of how to push anything to the phone. Instructions I found assume a .img file.
  12. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    you can push anything I think.

    I believe the syntax is adb push [source file name and path] [destination file name name and path]

    Let me see if I can find an ADB tuturial
    RichSz likes this.
  13. breadnatty08

    breadnatty08 pain rustique VIP Member

    RichSz likes this.
  14. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    RichSz likes this.
  15. The_Chief

    The_Chief Accept no imitations! Moderator

    I don't want to insult your intelligence, Rich; just trying to get all the details:

    Did you happen to accidentally "Wipe Internal Memory" in TWRP (the thing my guide says to NOT do)? In the scores of times I have used Superwipe, it has NEVER touched internal memory. I'm not saying it's impossible... but I am frankly shocked that Superwipe would erase your Nexus' internal memory when it doesn't for others :confused:

    EDIT: Seems to me that you can go into TWRP, Mount the phone to the PC via USB and move the ROM & Gapps to the internal memory as a way out of this...
    RichSz likes this.
  16. RichSz

    RichSz Not Entitled VIP Member

    OK, I think I got it. I pushed the zip files (ROM, GAPPS, TI's Update.zip) to root ("/") and TWRP sees them.

    Damn, that fails with an error:

    E:Mount: Unable to find partition for path '/jbs

    ...and it scrolls off the screen at that point.
  17. RichSz

    RichSz Not Entitled VIP Member

    I didn't Wipe Internal Memory, I did the Factory Reset as the guide dictates.

    Edit: Not blaming, just reporting.
    The_Chief likes this.
  18. iowabowtech

    iowabowtech root@android:/ #

    RichSz, breadnatty08 and Unforgiven like this.
  19. RichSz

    RichSz Not Entitled VIP Member

    You may have put me on to something. I tried flashing from / but followed the instructions and pushed the zips to /data/media/ and it looks like something positive happened. Flashed GAPPS and rebooted. I can see the JBSourcery boot anim. It seems I'm on my way!

    Thanks everyone for the help! I'm not out of the woods yet but good stuff is occurring!
  20. iowabowtech

    iowabowtech root@android:/ #

    Please note, I just edited the tutorial. I realize I hadn't yet updated the instructs to account for the file structure changes we saw from Jellybean. (/data/media/0). It may work without adding the "0" but the file may not be recognized by your recovery is my fear.
    RichSz likes this.
  21. RichSz

    RichSz Not Entitled VIP Member

    The phone booted into the new ROM. I'm in the process of copying many GB of data back onto the phone (still following Chief's tutorial and haven't signed in to Google yet).

    Quite a relief. Now I remember why I ran a version of XenonHD from the summer. This ROMing is a pain!
  22. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    Glad your back up and running RichSz:thumbup:
    RichSz likes this.
  23. Stigy

    Stigy Some say... VIP Member

    Hopefully that gets you back on your feet Rich - you might not need the /0 as IBT mentioned but its JBs new file system convention now that the OS supports multiple users.
    RichSz likes this.
  24. breadnatty08

    breadnatty08 pain rustique VIP Member

    Thanks guys! :)
    RichSz likes this.
  25. sneakking

    sneakking Well-Known Member

    this is why you need to be a crack flasher

    you'll never get rusty:D

Share This Page