[Verizon] Galaxy Nexus root / un-root without unlocking bootloader


Last Updated: 2012-11-10 04:29:36
  1. scary alien

    scary alien not really so scary Moderator

    :) :) :)

    Happy to help!

    Be sure to throw a 'thanks' to onfire4g05's post above--it was clearly very helpful :).

    Use your new root powers wisely ;) -- take your time and read and learn...tons of folks and threads around here to help you along your journey.

    Cheers!

    Advertisement
    eagle nexus likes this.
  2. eagle nexus

    eagle nexus Active Member

    Yeah, i used to have a rooted droid 1. Did a lot of things to that phone... Anyways, I'll be sure to throw a 'thanks' to onfire4g05's post. Again, thank you!
    scary alien likes this.
  3. eagle nexus

    eagle nexus Active Member

  4. scary alien

    scary alien not really so scary Moderator

    It sure will! That's OTA RootKeeper for those that don't read URL (;)) and I mention that in the first post as a great thing to have in your back pocket--especially if you plan on rooting with an locked bootloader after getting an OTA.

    I've used it several times now--its actually very clever how it works in making itself survive an OTA (it does this my making the /system folder where it installs itself "immutable" (unchangeable)--a property of the filesystem).

    Cheers!
  5. lickwidravr

    lickwidravr Well-Known Member

    Hey Scary,

    Sorry for any delays in response. I used your absolutely incredible and simple non-unlock/root meathod. The addition of the .bat really made this about as easy as double clicking a file........actually thats exactly all you have to do! :).

    You are correct, i did mean that i used ROM Manager after rooting with your method. After rooting with your method i downloaded "OTA RootKeeper by Project VOODOO and backed up root(this allows you to restore root after updating to 4.0.4, I then copied the 4.0.4 update zip (after renaming it "update.zip") to the /root of the storage of the phone. Then within Rom manager i rebooted to recovery. From there you scroll to the update option and select the update.zip and confirm you want to update. Thats it, once it finished, the phone rebooted and tada, i was running 4.0.4 without issue. All i had to do from there was run OTA RootKeeper to restore root and i was done with the update. Officially on 4.0.4 rooted with your method originally and just restored your root with OTA RootKeeper after updating. :)
    scary alien likes this.
  6. scary alien

    scary alien not really so scary Moderator

    Excellent, lickwidravr! Thank you for the reply :).

    Yeah, I also restored back to stock and re-locked my bootloader to verify the flashing of custom recovery can be done while still locked.

    You can't use fastboot to flash it (or soft-boot it), though... ROM Manager will flash it, but its obviously not being done with the flash_image utility... I still can't figure-out how it does it because manually using flash_image fails for me.

    I'm guessing that its either a coded routine in ROM Manager or a reference to something other than the recovery partition in "flash_image recovery <recovery image file>".

    I'll keep digging and report back when I figure this out ;) :).

    Cheers!
    lickwidravr likes this.
  7. eagle nexus

    eagle nexus Active Member

    If you you flash clockwork mod recovery with rom manager, will you still get ota's and be able to update your phone "officially"?
  8. scary alien

    scary alien not really so scary Moderator

    If you have not installed a custom ROM, but have only rooted and installed a custom recovery (like ClockworkMod), then you will receive the OTA, but it won't be able to be applied because you don't have the stock recovery installed.

    Its pretty easy to restore the stock recovery if you have an unlocked bootloader, but the only way I can see that you can while being stock and rooted with a locked bootloader is to make sure you have the /system/etc/install-recovery.sh and /system/recovery-from-boot.p file present and installed.

    I'm trying to figure-out a way to manually flash a recovery (stock or otherwise) outside of ROM Manager and without having to use fastboot...still searching for the key piece of information re. that...

    I'll let you know.

    Cheers!
  9. eagle nexus

    eagle nexus Active Member

    Ok, cool. One last thing, how would i deoxed the stock rom so that I can get custom mods. Is it even possible?
  10. scary alien

    scary alien not really so scary Moderator

    I'm sure you could find a deodexed stock ROM to install / flash through ClockworkMod.

    Just keep in mind that if you're not careful, you might find yourself in a position to have to unlock your bootloader in order to use fastboot (depending on what you've done, of course ;) :)).

    The first thing I would do if I were you would be to take a Nandroid backup of your stock (but obviously newly-rooted) setup...that way, you should be able to restore that if things ever go south on you (assuming that custom recovery is still available).

    At some point though, depending on how many mods / changes, etc. you made, you might as well unlock the bootloader ;) :).
  11. eagle nexus

    eagle nexus Active Member

    Ok. Thanks! :)
  12. scary alien

    scary alien not really so scary Moderator

    Okay, just wanted to report back here and follow-up re. the flashing of recovery outside of fastboot or via the something like the ROM Manager app.

    Its actually pretty simple--just use the flash_image utiltity to write to the proper block device that maps to the recovery partition. The recovery partition is actually /dev/block/mmcblk0p8.

    This could be used to re-flash stock recovery--something that ROM Manager doesn't do which folks would want/need in order to install OTAs, etc.

    I was actually tinkering with the idea of making an app that would allow you to select and flash a selectable file (i.e., stock recovery for various versions, various versions of ClockworkMod, etc.). I'd release it for others if I could find a way to help ensure you couldn't goober-up your phone like flashing an improper file (i.e., keep a verified list of files' MD5 checksums and only allow those to be flashed).

    Anyway, I'll keep you posted if I make something ;) :).

    Cheers!
  13. VijS

    VijS New Member

    WOW!! This is exactly what I was looking for. Less than 30 mins later, I'm rooted without having to do a wipe. Thanks very very much.

    Widgets in Nova Launcher now working!
    scary alien likes this.
  14. scary alien

    scary alien not really so scary Moderator

    No problem--happy to have helped and you are very welcome! :)

    Also, welcome to the AndroidForums--glad you signed-up and hope you end-up hanging-around with us.

    Cheers!
  15. Paul1201

    Paul1201 Well-Known Member

    scary,

    Make it 2 GNex's rooted this way. Used this to root and update my wife's brand new GNex today. A bummer was that the 4.0.4 OTA would not install and kept giving me an error type 7 message on her phone so I restored hers to stock using the files from before and then re-rooted. The 4.0.4 OTA installed no problem after that. Anyhow thank you again for all that you do.

    Paul
    scary alien likes this.
  16. Larzzzz

    Larzzzz Active Member

    Pleh (help), lol.
    First off, Many thanks to Scary for setting up this nice lil batch file for us.
    This Galaxy Nexus is my first Android device and it shows up in the windows explorer as such. When I select it to view, I am only presented with internal storage to select further. Looking into that, I do not see any folder labeled cache, but there are several cache folders in the Android/data/ com**** folders. There is an SD card in the list of folders.
    Is the SD card the cache everybody is referring to where the 4.0.4 update goes?
    I am an Android noob and don't want to turn this phone into a paper weight.
    Thanks.
  17. scary alien

    scary alien not really so scary Moderator

    Larzzzz,

    Thanks and welcome to the AndroidForums! :)

    I'm guessing you're talking about copying the 4.0.4 update.zip file to the /cache folder, eh?

    And, you have successfully rooted your 4.0.2 device with my script?

    Well, Astro File Manager is not a root-enabled app, so it won't be able to see the files and folders in the /cache directory like Root Explorer (paid app) or ES File Explorer (free app) can.

    Since I don't use Root Explorer (great app, though, from all reports that I've read and fully worth it), I typically navigate the phone's filesystem manually via adb or with ES File Explorer if I'm not near my computer. Since ES File Explorer does not start-out with root enabled, you have to tell it to be, so that you'll be able to see /cache and other protected files, etc. Here's my notes for how to do this (assumes you are already rooted, by the way):
    - download / install / launch ES File Explorer

    - press the menu icon (bottom right)

    - select Settings

    - select Home Directory

    - change your Home Directory to "/" (without the quotes, of course)

    - return to the Settings screen

    - scroll down to the bottom of the screen

    - check the "Root Explorer" box in the Root Settings area (you'll get the Superuser whitelist app's pop-up asking for permission for this app)

    - when you want to mount / and /system as writeable, check the "Mount File System" box under the "Root Explorer" checkbox

    - hit the back button to return to the file navigation

    - press the "Up" directory icon in the toolbar at the top of the screen--that should take you to the / (root) filesystem
    Take your time, read-up, and ask questions...:), someone will be around to help you out [although I myself might be signing-off pretty soon for the evening].

    Hope that helps!

    Cheers!
    Larzzzz likes this.
  18. Larzzzz

    Larzzzz Active Member

    Wow, ty for the speedy reply!
    I am, and I have. I unrooted it before I dug a hole I couldn't get out of.
    The adb is part of the Android sdk I D/Ld from Google? I've installed it but haven't messed with it yet.

    Thanks again.
  19. scary alien

    scary alien not really so scary Moderator

    Well, the adb (Android debug bridge) is a PC client (Windows, Linux, Mac) that can communicate with the adb server (daemon) on your Android device to do some special things.

    Its pretty handy when you'd rather have manual control from your PC vs. using a GUI tool / file manager, etc.

    adb does with the Android SDK, but you can also just download it from a mini-SDK package I created--see this thread (especially the "Mini-SDK" section):

    ADB Guide

    There's also lots of other good info in that above thread, too, re. examples for using adb, etc. (click the various "Show" buttons to expand things).

    Also, here's a few other root-related threads you might be interested in, too:

    http://androidforums.com/faqs/443075-root-terminology.html

    http://androidforums.com/faqs/450904-rooting-best-practices.html

    Hope that helps :).

    Cheers!
  20. Larzzzz

    Larzzzz Active Member

    Scary, you da man. Lol.
    Just got the ES file manager and found the cache on the device.
    I have some reading to do now....
    ty ty ty
    scary alien likes this.
  21. Larzzzz

    Larzzzz Active Member

    hahahaha, it's been a loooooooooooooooong time since I've played in a DOS box. Anyone remember the TRS 80, or the Commodore 64?

    So, I got the adb installed and the daemon is communicating with moi and my DOS box; but I think my syntax is wrong when I try to push the update.zip folder to the cache. I moved the update.zip folder to the same folder where my adb commands are located because I thought it would be easier, not, for me rather than typing and typing and typing.

    Here is the line I use when trying to push the zip folder to the cache and I either get something saying the folder or file doesn't exist...

    "C;\sdk\sdk\platform-tools\adb push /update.zip /cache"

    I have tried many variations and sometimes I get the command list for adb.

    Something I shouldn't be doing at 2,3,4 o'clock in the morning I guess....lol
  22. scary alien

    scary alien not really so scary Moderator

    LOL, do you also remember CP/M? I've still got a Kaypro II downstairs that still works ;) :).

    Probably the simplist thing to do would be:

    c:\> cd c:\sdk\platform-tools
    c:\sdk\platform-tools> adb push update.zip /cache/update.zip

    I think your syntax was just broken because of the extra forward slash prefixing the "/update.zip" portion of your command.

    Kudos to you for working to learn adb--that'll serve you well in the future :).

    Cheers!
  23. Larzzzz

    Larzzzz Active Member

    I do not remember the CP/M. The C64 is collecting dust in my attic now. Do you know where I can get some 5 1/4" floppy discs?

    Thanks again, I will try again AFTER I get some more coffeeeeeeeee
  24. Larzzzz

    Larzzzz Active Member

    grrrrr. Running Scary's "root-for-windows" now. OTA says I am rooted, but when I push the update file to the cache, I am getting a permission denied response.... lol. Maybe I haven't had enough coffee yet.
  25. scary alien

    scary alien not really so scary Moderator

    Larzzzz,

    How exactly are you trying to push the file over?

    Did you invoke "su" from your adb shell to get root? (you need to have root permissions in order to write to /cache)

    Or re-use the mempodroid binary to run the shell it starts with root access to do your copy...

    Typically, you would use a root-enabled app like Root Explorer or ES File Explorer (as we discussed last night) to copy / paste your update.zip file to /cache.

    If you are wanting to use adb, you'll have to do something like this (after you've rooted, of course):

    c:\sdk\platform-tools> adb push update.zip /data/media/update.zip
    c:\sdk\platform-tools> adb shell
    $ su
    # cat /data/media/update.zip > /cache/update.zip
    # exit
    $ exit
    c:\sdk\platform-tools>

    Make sense?
    Larzzzz likes this.

Share This Page