[Verizon] Having trouble with wifi tether-treve mod

Last Updated:

  1. collinv620

    collinv620 Member

    I recently rooted my nexus, accidentally rooting it to twrp instead of clockwork..but dont really know the difference in the first place. I hear a big benefit of rooting is the free tethering. I DLed the wifi tether-treve mod app. im trying to tether my laptop but its not working and when i start the tether on my phone it says error, enabling mss clamping failed in the show log. Any advice? im still fairly new to this rooting thing. Thanks

  2. jmar

    jmar Nexican VIP Member

    Hey there collin!

    Sorry to hear you are having difficulty getting all the functionality from your device that you wish to have.

    First things first...

    Root access allows for deeper access inside the OS, namely the system files which are not normally accessible. It also allows for things such as tethering, though not all tethering requires root, such as certain wired tethering solutions.

    Secondly, TWRP and CWM are recovery programs that are a user accessible backup and flash tool. Standard or "stock" recovery is the built in version of the tool, initiated and accessed by things such as a carrier update to your phone's OS or when you perform a factory reset from within the settings menu on your device.

    So...why the background? I wanted to distinguish two terms you may have lumped together, which is easy to do. I know I did back in the day when I was in need of help. Glad you are asking for help. :)

    Moving on now...

    Root will give your device the ability to access and use WiFi tethering, whether built-in or by third party app. Not all apps work and this sounds like your problem. The app you are using quite possibly doesn't work or is not configured correctly.

    One easy solution...flash a custom ROM (May I suggest Jelly Belly?) which has WiFi tethering built-into it and the problem is essentially solved. That said, let me ask a question or two or three...

    ...Does the above info make sense?

    Do you know how to operate/navigate your custom TWRP recovery?

    Do you know how to perform a proper installation of a ROM and Google Apps (GApps)?

    Get back to me so I can continue to assist you.

  3. collinv620

    collinv620 Member

    Hey Jmar! thanks for going into detail for me. It is slowly starting to make sense, like i said im still new to this. I do have another issue on my hands now. I flashed some aokp rom through moo manager a little while ago. Now i just have this pink unicorn load screen "initiating swagger." I read somewhere a few minutes ago to go to my recovery page and wipe davlik and flash the aokp again and it should work...to no avail. Screen is still loading and annoying me. How do i get back to my original "rom", i hope im using the right term, and restore my phone to before this unicorn annoyance?
  4. collinv620

    collinv620 Member

    where do i dl and install jelly belly? via app on my phone or from computer?
  5. just install jb sourcery and use the tether app it comes with.
  6. collinv620

    collinv620 Member

    I cant get rid of this AOKP unicorn load screen. I tried everything in my recovery page!!! HELPPP!!!! Do i have to unroot and unbrick my phone or something?! im freaking out over here havent been able to use my phone for hours because of this SWAGGER pink load screen!!!!!
  7. relax. go back into recovery mode, flash stock. download a jb bootloader, flash it, and try a different rom. a lot of the aokp 4.2.1 ones have issues.
  8. collinv620

    collinv620 Member

    how do i flash stock from the twrp recovery page? like i said im new to this and im having a hard time. My options on the home screen are install, backup, mount, advanced,wipe, restore, settings, reboot. I went to restore and chose the 12-31-1999 and it loaded into the unicorn screen. Then i restored the 12-26-2012 which i would assume is the aokp rom?...that came up with the unicorn load screen as well. Not finding an option to flash...

  9. wipe, then factory reset.
  10. collinv620

    collinv620 Member

    just go to the wipe menu then wipe factory reset? tried it, unicorn pops up.......
  11. collinv620

    collinv620 Member

    ok nevermind. the aokp load screen poped up but then it actually loaded. now i cant access the the internet and its the aokp interface. how do i get to use the network?
  12. collinv620

    collinv620 Member

    Now i have network but cant sync contacts, apps, nothing. Don't even have Google play store app. How do i get the play store app?!
  13. teddyearp

    teddyearp A guide with guides

    Almost every custom rom has a seperate gapps package which is why you don't have the market. While it is very convenient to download and flash roms with our phone, the instructions aren't included. It is always best to read up about them first on the internet, that way you'll have some background on how to flash them correctly so you'll have less problems.

    The usual standard for flashing a rom is this:
    1. boot into recovery
    2. make a nandroid backup
    3. factory data reset
    4. some say also wipe dalvik cache and system as well
    5. flash rom
    6. flash gapps (if needed, most times they are)
    7. reboot phone-first time will take a lot longer than usual.

    good luck

    p.s. if you have more questions and before you proceed further, I would like to refer you to the guide that is stickied at the top of the page, there's a lot to read with alot of links, but you'll start to understand stuff better.

    jmar likes this.
  14. jmar

    jmar Nexican VIP Member

    Just woke up. Thank for chipping in to help. :)

    How's it going Collin? Still stuck?

  15. collinv620

    collinv620 Member

    whats up jmar. Been at work all day, getting used to not having any contacts or applications...or being able to dl any for that matter. The AOKP rom i installed and flashed last night finally loaded this morning. I have no google apps. Want to change this rom immediately but not really sure how to without having the google store to dl goo manager, rom manager, etc. Im not even sure if i can get my contacts and apps back if im even capable of fixing this problem. Anyway can you walk a newb through?
  16. PsyMega

    PsyMega Well-Known Member Developer

    Don't have this device but it appears as if the reason you don't have Google apps is because you don't have a gapps pack installed, do you have link to the rom you downloaded?,
  17. tdevaughn

    tdevaughn Well-Known Member Developer

  18. teddyearp

    teddyearp A guide with guides

    Hope this helps.

    good luck

  19. glad to hear it worked. just get some gapps. the 12-12-2012 ones are the most recent. you can get them on team sourcery's website. there's a much better rom than any of the aokp ones on there too. way more features, less bugs. actually haven't found any bugs on the newest sourcery.
  20. collinv620

    collinv620 Member

    I downloaded the gapps on my laptop. How do i transfer them to my phone? I tried to drag themy phone but it wouldn't let me. By the way thanks for all the info and assistance in my first root venture guys. Cant wait to be up and running normally.
  21. jmar

    jmar Nexican VIP Member


    Can you connect your phone to a WiFi network? If so, then download the GApps directly to your phone from the links provided in previous posts. Then go into recovery and flash. The file will be in your downloads folder. Let me know where you are at. I am not going to give up on helping you until you are set.

    teddyearp likes this.
  22. PsyMega

    PsyMega Well-Known Member Developer

    Mount usb mode, then drag and drop them to your phone

Share This Page