[Verizon] How to: Unroot the Galaxy Nexus, Re-lock the Bootloader and Return to a Factory State

Last Updated:

  1. BringTheRain403

    BringTheRain403 Well-Known Member

    kool kat2, bevardimus, Mahalo and 3 others like this.
  2. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    This does fit in with the "factory image" thread where you posted it, Rain, but I think it still should have a thread in its own right, so I've used your post as the OP for a new thread here in GNex ATR. ;)

    From that linked site, the steps:


    1. Download the Android 4.0.2 factory images to your PC. [Download]
    2. Unzip the file and its contents into your SDK/Tools folder (wherever your adb.exe and fastboot.exe files are).
    *Make sure they are not in their own folder, but have all been extracted to Tools.
    3. From within your Tools folder, open a command prompt (SHIFT + right click – “open command prompt here”):
    4. Type the following commands, allowing each to finish before moving onto the next:
    adb reboot bootloader
    fastboot flash bootloader bootloader-toro-primekk15.img
    fastboot reboot-bootloader
    fastboot flash radio radio-toro-i515.ek02.img
    fastboot reboot-bootloader
    fastboot flash radio-cdma radio-cdma-toro-i515.ek05.img
    fastboot reboot-bootloader
    fastboot -w update image-mysid-icl53f.zip
    fastboot reboot-bootloader
    fastboot oem lock
    5. Reboot your phone by highlighting “Start” and pressing the lock switch.
    6. It really is as simple as that. Your phone is now back to a 100% stock, unrooted and locked state.
  3. Yeahha

    Yeahha Usually off topic VIP Member

    I am not sure these instructions are correct. Someone unrooted in the how to thread and had some issues. I would suggest altering it like this

    1. Download the Android 4.0.2 factory images to your PC. [Download]

    2. Unzip the file and its contents into your SDK/Tools folder (wherever your adb.exe and fastboot.exe files are).
    *Make sure they are not in their own folder, but have all been extracted to Tools.
    3. From within your Tools folder, open a command prompt (SHIFT + right click – “open command prompt here”):

    4. Type the following commands, allowing each to finish before moving onto the next:
    Code (Text):
    1. adb reboot bootloader
    2. fastboot flash bootloader bootloader-toro-primekk15.img
    3. fastboot reboot-bootloader
    4. fastboot flash radio radio-toro-i515.ek02.img
    5. fastboot reboot-bootloader
    6. fastboot flash radio-cdma radio-cdma-toro-i515.ek05.img
    7. fastboot reboot-bootloader
    8. fastboot -w update image-mysid-icl53f.zip
    At this point if you wish to keep the unlocked bootloader go to step 5 if your phone did not reboot (if it did reboot and you want the unlocked bootloader you are done), to lock the bootloader follow these steps
    Your phone may reboot after the flash done by the last ADB command. If your phone reboots and you wish to lock the bootloader use the following commands:
    First you will need to skip the google sign in (just press next over and over until it is done. Then go into settings and turn USB debugging on again. Now you can begin using the command prompt again with the following commands
    Code (Text):
    2. adb reboot bootloader
    3. fastboot oem lock
    If your phone does not reboot after the last ADB command and you wish to lock the bootloader use the following commands:
    Code (Text):
    2. fastboot reboot-bootloader
    3. fastboot oem lock

    5. Reboot your phone by highlighting “Start” and pressing the lock switch and you are unrooted

    I am also not sure that radio flashing is needed currently either (yet at least) there are only the stock radios available and I don't see a reason to risk 2 extra bootloader flashes if they aren't needed.
  4. BringTheRain403

    BringTheRain403 Well-Known Member

    I followed these steps and they worked perfectly. First boot takes a LOOOOOONG time. However I did stop before I re-locked the bootloader as Yeahha states above...
    Frisco and Yeahha like this.
  5. Yeahha

    Yeahha Usually off topic VIP Member

    After you ran "fastboot -w update image-mysid-icl53f.zip" did the phone reboot itself or did it stay in the bootloader?
  6. BringTheRain403

    BringTheRain403 Well-Known Member

    rebooted itself. I did go back into the bootloader though to make sure it still said "unlocked." I have to manually put it into the bootloader because when I ptu the command in to reboot into the boot loader it kept saying "waiting for device" which I assume was because it no longer had root access. either way it worked out and everything was fine.
  7. Yeahha

    Yeahha Usually off topic VIP Member

    adb reboot bootloader should reboot it to the bootloader stock as well.

    Did you have USB debugging turned on?
  8. BringTheRain403

    BringTheRain403 Well-Known Member

  9. Yeahha

    Yeahha Usually off topic VIP Member

    Okay that is odd. Seeing as you have already finished my next step wouldn't work which would be to use "adb devices" to see if your cpu realizes the phone is connected.

    Also did you turn on USB debugging after the reboot? (that is what I sould have asked) the last command you did before the reboot would have reset the device in turn removing the USB debugging system option being checked.
  10. BringTheRain403

    BringTheRain403 Well-Known Member

    For some reason my phone has always (even straight out of the box from VZW) had USB debigging enabled..

    Hey how knowledgeable are you about CWM? I'm having trouble with it ob the Gnex. Are you on GTalk?
  11. scary alien

    scary alien not really so scary Moderator


    I've just spent the last hour and a half trying to re-flash back to stock...the first three attempts "sort-of" worked...but the "writing 'system'..." part never finished...it just sat there. Tried this with different fastboot programs and finally realized that the USB port I was using was a 3.0 port. When I switched to a USB 2.0 port, things took off:

    Code (Text):
    1. c:\gnex\sdk-tools>[COLOR="Blue"]fastboot -w update image-mysid-icl53f.zip[/COLOR]
    2. archive does not contain 'boot.sig'
    3. archive does not contain 'recovery.sig'
    4. archive does not contain 'system.sig'
    5. --------------------------------------------
    6. Bootloader Version...: PRIMEKK15
    7. Baseband Version.....: I515.EK02
    8. Serial Number........: xxxxxxxxxxxxxxxxxxxx
    9. --------------------------------------------
    10.               checking product... OKAY [  0.006s]
    11.    checking version-bootloader... OKAY [  0.003s]
    12.      checking version-baseband... OKAY [  0.000s]
    13.          checking version-cdma... OKAY [  0.016s]
    14.       sending 'boot' (4074 KB)... OKAY [  0.526s]
    15.                 writing 'boot'... OKAY [  0.266s]
    16.   sending 'recovery' (4406 KB)... OKAY [  0.561s]
    17.             writing 'recovery'... OKAY [  0.863s]
    18.   sending 'system' (325583 KB)... OKAY [ 40.820s]
    19.               writing 'system'... OKAY [ 36.349s]
    20.             erasing 'userdata'... OKAY [  6.172s]
    21.                erasing 'cache'... OKAY [  0.189s]
    22.                      rebooting...
    23. finished. total time: 85.800s
    Now, I only updated the system image and didn't flash the bootloader or radio (they shouldn't have been different and there's no good that can come from tempting fate, eh? :) ;)).

    Also, what is curious is that ALL of my apps are still there in the app drawer...even the busybox and Superuser apps--of course I am not rooted anymore, but the telltale signs are there.

    Okay, I'm off to test rooting via using ClockworkMod custom recovery...

  12. BringTheRain403

    BringTheRain403 Well-Known Member

    Mine sat at "writing system" for a long long time. I was only using USB 2.0 though...
  13. HanSolo

    HanSolo Guest


    Guys, I think I made a boo-boo.

    I was unrooting/unlocking according to the instructions at DL.

    I got to where I finished this step:

    fastboot -w update image-mysid-icl53f.zip

    It then went into a bootloop with the flying squares. I was not patient and pulled the battery. I am able to boot into recovery and Odin, but my command window on the computer is not recognizing the device.

    When I type "adb reboot bootloader", it says:

    "error: device not found".

    I think it might not be in debugging mode, although it most definitely was until I pulled the battery.

    If I start the boot, it doesn't get past the "Google" logo with the unlock symbol, just keeps repeating itself.

    Can someone help me please???


    Guys, I just went ahead and made this a separate thread.
  14. BringTheRain403

    BringTheRain403 Well-Known Member

    I'm not sure about that one. Maybe try booting into recovery and then doing a factory reset?
  15. teddyearp

    teddyearp A guide with guides

    Hey guys, nice find. But I have asked this all over the place and I think it is a very relevant question, especially if one uses this method to return the phone; so I ask it here as well.

    P3Droid says that when you boot into bootloader/fastboot mode there is a counter visible on the screen showing how many times the bootloader has been unlocked/locked. Has anyone seen this? And if so, when you go through this method, does the counter in fact reset?

    I hope someone takes a look at this as I feel it's an important thing to take note of in this endeavor.
  16. scary alien

    scary alien not really so scary Moderator


    I just rebooted back in to bootloader (fastboot) mode and do not see any such counter...:confused:

    Perhaps that was only on P3droid's development device (presuming that's what he has)?

    My fastboot screen looks nearly identical to this (this is not my screenshot, by the way):


    except that mine says "VARIANT - toro" and different serial numbers, etc. -- but no unlock counter (I actually think I remember reading / hearing about this a long while back, too).

    teddyearp likes this.
  17. BringTheRain403

    BringTheRain403 Well-Known Member

    ^^^what he said
    scary alien likes this.
  18. teddyearp

    teddyearp A guide with guides

    Thanks, and yeah if that was a screenshot of your device, I'd say ???? not on VZW. P3droid's was a engineering device, now returned.
  19. Mr. Orange 645

    Mr. Orange 645 Well-Known Member

    Ive been reading that the signal issues for many users got much worse after the 4.0.2 update. I dont know bc I accepted the upgrade as soon as it appeared. Im wanting to fo back to stock 4.0.1 just to test my signal and see if its any better. I assume these steps will work with the older factory image, judt substituting the older files in these steps? I want to run a day original locked and stock on the older firmware.

    Also, can Odin program be used to flash this instead of adb and fastboot?
  20. soy.lor.n

    soy.lor.n Well-Known Member

    Just realized I have a flawed screen and I want to get a replacement so I'm gonna have to lock/unroot it seems.

    How do I do this if I followed the "slightly easier manual method" of rooting. I never had to download the SDK or use adb for that so I don't know how that translates to doing the unroot... :(
  21. BringTheRain403

    BringTheRain403 Well-Known Member

    you need those in order to do this. I'd recommend doing it...
  22. soy.lor.n

    soy.lor.n Well-Known Member

    but once I've got the SDK-tools.zip from the "how to root" thread then I can follow the steps on this page?
  23. scary alien

    scary alien not really so scary Moderator

    Yes, since you should have the fastboot utility in from the sdk-tools.zip, that's all you'll need to reflash back to stock using the information Frisco listed in post #2 above.
    soy.lor.n likes this.
  24. Yeahha

    Yeahha Usually off topic VIP Member

    I think you will need to download the SDK and setup ADB to unroot. The instructions linked in the OP, quoted in post 2 and edited by me in post 3 should unroot you (they are all basically the same ;))

    I am not sure what all remnants of root are left behind when you unroot, perhaps SA will chime in with what will need to be removed. I assume you will need to do this via ADB as well.
  25. civicsisedan

    civicsisedan Well-Known Member

    Okay, I dont see a clear method on how to do this on here.

    I want to take this phone and not be rooted and lock the bootloader all over again. Then factory reset or whatever as if I was going to take it to Verizon. No traces of anything...

    I really want to get back to stock and retry Google Wallet, as I had it working and reset data and its throwing errors at me now.

    But I download this:

    Stock image for VZW (Verizon) CDMA/LTE "toro/mysid" from Google:

    https://dl.google.com/dl/android/aosp/mysid-icl53f-factory-65895fa8.tgz (version 4.0.2)

    Then what? Use ODIN? What is that? And what am I checking for the MD5, I know how to find it on astro however what am I looking for?

    Need the steps to get back to stock. I can update this post afterwards so everyone else knows how..


Share This Page