[Verizon] I Seem To Have Kept Root After The OTA


Last Updated:

  1. RichSz

    RichSz Not Entitled VIP Member This Topic's Starter

    Joined:
    Jul 9, 2010
    Messages:
    2,087
    Likes Received:
    1,174
    I didn't expect it but that may be what happened. I got tired of the nagging about the OTA of a week or so ago (yes, they wore me down) so I took the stupid OTA from the stupid carrier and let it do whatever to my stupid phone. I figured I'd lost root so I didn't even check.

    This morning I remembered I installed Voodoo OTA Rootkeeper and protected root. https://play.google.com/store/apps/details?id=org.projectvoodoo.otarootkeeper

    That couldn't really work, could it? For a goof I had it restore root. It said it worked. OK, rebooted and noticed the initial Samsung screen now has a opened padlock like my unlocked GNex does. I never noticed that before (it may have been there, I don't reboot a lot). Finished booting and opened TiBU which agreed that I had root! I accidentally did the impossible, I think.

    Full disclosure, I actually paid for the root app so maybe that was a factor. https://play.google.com/store/apps/details?id=com.noshufou.android.su

    Now when I look at the about screen it says my SELinux status is "permissive". Do they all say that? I never paid attention.

    Here is the "proof".

    [​IMG]

    If you all agree that this worked as I believe, I'll add it to the sticky. In any case, do your research and don't trust me blindly. I just stumbled around and here is the result. There may be important factors I haven't documented. Proceed at your own risk.
     

    Advertisement
    Covert_Death, Hadron and Podivin like this.
  2. ackoolness

    ackoolness Well-Known Member

    Joined:
    Aug 4, 2010
    Messages:
    103
    Likes Received:
    10
    wow -_- I also installed voodoo yesterday jussssssssssst incase it would actually work, knowing that on the google play page it states that it doesnt work with samsung phones.

    I disabled/froze the update programs to stop that stupid pop up, but for safe measure im still going to wait.
     
  3. ackoolness

    ackoolness Well-Known Member

    Joined:
    Aug 4, 2010
    Messages:
    103
    Likes Received:
    10
    Hey RichSz, did you have a custom recovery installed?
     
  4. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,224
    Your thread title reminded me of my Fascinate experience.. I'd rooted it just to learn about it so I could help others, but then unrooted using the method provided at XDA.. re-rooted with another method to learn about that one, then along came an update via OTA and root access remained (checked with su in terminal, Root Explorer system file access, etc).

    No VooDoo stuff, though.. other than my chicken blood stuff with the Mikey doll. But that's a different story. :D
     
  5. RichSz

    RichSz Not Entitled VIP Member This Topic's Starter

    Joined:
    Jul 9, 2010
    Messages:
    2,087
    Likes Received:
    1,174
    No I don't. 100% stock just rooted. I've disabled a lot of Verizon and Samsung bloat but did that through Settings/Application manager not with TiBU.
     
    Covert_Death likes this.
  6. Hadron

    Hadron Well-Known Member Contributor

    Joined:
    Aug 9, 2010
    Messages:
    17,371
    Likes Received:
    10,181
    How big an OTA was it? I could imagine some small patch leaving the superuser binary intact maybe.
     
  7. RichSz

    RichSz Not Entitled VIP Member This Topic's Starter

    Joined:
    Jul 9, 2010
    Messages:
    2,087
    Likes Received:
    1,174
    I don't know. I seem to remember the OTA was smaller than the desktop version released earlier but both were supposed to kill root and screw up tethering. I haven't tested that part yet.
     
    Covert_Death likes this.
  8. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,397
    If I recall, the desktop version was like a full image flash which is why it was bigger. It was also why rootkeeper didn't work because it would destroy the copy made by the program to protect root. The ota didn't touch the place where the copy was stored and thus was safe.
     
    RichSz and Hadron like this.
  9. Covert_Death

    Covert_Death Well-Known Member

    Joined:
    Feb 2, 2010
    Messages:
    2,091
    Likes Received:
    665
    i think im going to go ahead and try this... i downloaded VooDoo and user SuperSU and have it protected.

    im going to accept the OTA and then try to flash to CM10.1 afterwards and then flash back. ill post back here if everything works
     
  10. Covert_Death

    Covert_Death Well-Known Member

    Joined:
    Feb 2, 2010
    Messages:
    2,091
    Likes Received:
    665
    i can confirm this works... i used VooDoo to keep root and then simply accepted the OTA (it must be done on the phone, if you read the instructions for VooDoo, it says it will not work with kies or oden for samsung phones but OTA works)

    i did loose my recovery and was able to reinstall it. so for all of those concerned this DOES seem to work. thank you very much RichSz

    EDIT: seems installing the recovery did not stick, im going to try a few other things
     
    RichSz likes this.

Share This Page

Loading...