[Verizon] Phone Won't Mount as a USB drive when connected to the computer

Discussion in 'Android Devices' started by shaddyyy, Mar 11, 2012.

  1. shaddyyy

    shaddyyy Well-Known Member
    38

    Oct 1, 2010
    130
    17
    38
    I have no idea what's going on, this never happened to me before until now on my galaxy nexus. When the phone is connected to the computer the phone doesn't automatically mount the storage and enter USB debugging mode. Any suggestions guys? I'm currently running AOKP M3 (was planning on flashing M4 until i noticed this big problem) with R61 Franco Nightly
     

    Advertisement
  2. dasanman69

    dasanman69 Well-Known Member
    38

    Nov 22, 2010
    117
    16
    38
    Are you running a different kernel than the one that came with the ROM?
     
    shaddyyy likes this.
  3. Crashumbc

    Crashumbc Well-Known Member
    213

    Apr 7, 2010
    1,810
    550
    213
    IT god
    B'more
    AFAIK, since the Galaxy Nexus doesn't support UTP it will never mount as a USB Drive(with a drive letter).

    You should see "Galaxy Nexus" appear under "devices" though. You should select "MTP" if asked.

    The other thing I've heard is it doesn't work real well with XP, I think there's a driver/app fix on the Samsung website.
     
    shaddyyy likes this.
  4. Flying_Hellfish

    Flying_Hellfish Well-Known Member
    78

    Jun 7, 2010
    612
    65
    78
    Illinois
    settings > storage > menu button > USB Computer connection > make sure MTP device is checked.

    For some reason some ROMs don't have this checked as default (CM9 for TP for example)
     
    shaddyyy and Thats like this.
  5. Thats

    Thats That guy is This
    VIP Member
    173

    Feb 19, 2010
    1,169
    383
    173
    Male
    Air Force
    Fargo, ND
    Hellfish pointed you in the exact direction! If that doesn't work please make sure you post back with your results!
     
    shaddyyy likes this.
  6. shaddyyy

    shaddyyy Well-Known Member
    38

    Oct 1, 2010
    130
    17
    38
    Thank you all for the responses and help.

    This ended up being the problem. I didn't think to remember that maybe the kernel had something to do with it. I just flashed back to 16.0 Franco Kernel and was able to have the computer recognize my phone again. Thank you all

    Edit: Also I was told by my friend that if you have the Franco Updater App installed and enable fast charge on USB it doesn't allow the phone to mount its internal memory.
     
    SamOliver, Mahalo and JevyJav like this.
  7. bagarwal

    bagarwal New Member
    5

    Apr 19, 2012
    1
    0
    5
    Thanks a lot buddy for the tip. I had installed the Franco updater and enabled fast charge. And then my PC stopped mounting my GNex. I thought there might be something wrong with the latest franco kernel that I had just flashed using the app. I flashed imoseyon kernel. Same thing. Flashed nightly build of franco. Same thing. I was about to do an old nandroid restore, which would've taken my cell back ages. :mad: Thankfully I saw this post and unchecked the fast charge option. And it worked. :adore:
     
  8. shaddyyy

    shaddyyy Well-Known Member
    38

    Oct 1, 2010
    130
    17
    38
    Glad I was of help to you =)
     
  9. jbfuson

    jbfuson New Member
    5

    May 16, 2011
    4
    0
    5
    Im having the same prob with my gnex. aokp. fast charge is off and debugging is on. all it does when i plug it into windows 7 is charge the phone. the pc dont even notice i plugged anything in to it. driving me nuts.
     
  10. shaddyyy

    shaddyyy Well-Known Member
    38

    Oct 1, 2010
    130
    17
    38
    I would suggest installing the drivers again and restarting your computer. That happened to be before and what i just said fixed that problem. Hope that helps
     
Tags:

Share This Page

Loading...