1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

[Verizon] Red Triangle when booting into recovery


  1. Sharpe Man

    Sharpe Man Well-Known Member

    Tried to do a search for this but it keeps saying that the token has expired.

    Anyway, LTE GNex unlocked and rooted(stock) with one click method.

    From Clockwork I tried to boot into recovery and got the red triangle. Then got it again when I tried to manually boot into recovery. Was able to get into recovery through Clockwork the second time after I reflashed it but could not get in it again with out flashing cw first.

    Downloaded root explorer to look to change the /system/recovery-from-boot.p but could not find it.

    Randomly opened titanium backup for the first time on this phone and it had a pop up that said something was wrong with the su I think, but I pressed the button for them to fix it before I read what it said.

    I really do want to understand how all of this works but I am lost at the moment. Do I need to unroot and lock it back then retry? Or use a different method? I could never get adb setup on my computer, that's why I finally used the one click method.

    Thanks in advance!

    Advertisement
  2. scary alien

    scary alien not really so scary Moderator

    AlwaysLurkin,

    I know that the /system/recovery-from-boot.p file is not present when you restore to stock using the stock/factory images from Google. I know that the 4.0.2 OTA puts the /system/recovery-from-boot.p file on the phone...were you initially 4.0.1 and at some point took the 4.0.2 OTA? (if so, that file should be on your phone).

    Let's first establish that you actually do have root in another way... Download and install Android Terminal Emulator. When it starts, type "su" and you should be prompted by the Superuser app for permission to give ATE root permission. Go ahead and say "allow" and see if your "$" prompt changes to a "#" prompt. If it does change to the pound-sign (#), then you are indeed rooted.

    I think the warning from TiBu may have something to do with the version of su and/or Superuser.apk and probably doesn't mean that you don't have root.

    I haven't used the one-click app/method myself so I don't know the ins and outs of how it flashes CWM.

    Can you re-flash it (see How to install ClockworkMod custom recovery) again via ROM Manager and see if that will make it stick?

    Good luck and let us know.
    Sharpe Man likes this.
  3. iowabowtech

    iowabowtech root@android:/ #

    Just to be sure, we are talking about Wug's one click root tool right? If so, kinda strange that it isn't sticking, I thought it performed that action but I haven't used it either, just read some things here and there. Unless the recovery-from-boot.p file is missing as SA eluded to along with your account of not finding it.

    Anyway, another thing you could try is to flash the clockwork.img (linked below) using that same tool, it has an option to do so according the screenshots I've seen (edit: added the screenshot from Wug's thread below). I'm not sure why that would work why the Rom Manager reflash fails but it's just another tool in the bag since you're not an adb/fastboot fan.

    http://download.clockworkmod.com/recoveries/recovery-clockwork-5.5.0.4-toro.img

    [​IMG]

    ^Note the option toward upper right for permanent flash. Which in your case would be to recovery partition. You just need to figure out where to place the clockwork file above. Is there a special folder included in the toolkit for such purposes? Again, idk having not used it.
    scary alien and Sharpe Man like this.
  4. Sharpe Man

    Sharpe Man Well-Known Member

    Thanks for the quick replies!

    Yes I am using Wug's one click but it is the older interface. I had to use the android naked drivers but otherwise everything was flawless.

    I am on 4.0.2 ota and have done nothing but run Wug's one click root.

    Downloaded ATE and it did indeed turn from $ to #.

    So from rom manager when i click reboot into recovery, i noticed that right before the screen goes black, it says Unfortunately something has stopped. I've seen that box before and it says that the launcher has stopped. Not sure if that means anything.

    Should I be able to find /system/restore-from-recovery.p from the root explorer app or do I have to look for it through my pc? Under the /system folder there is a notepad icon next to restore-from-recovery.p but no folder or anything. I've added the .bak to the end of that but still can't boot into recovery.
  5. scary alien

    scary alien not really so scary Moderator

    AlwaysLurkin,

    Well, its good that you indeed, rooted.

    You should be able to see recovery-from-boot.p from Root Explorer (I would imagine--I don't personally use that utility). Could it be that there's a setting in Root Explorer to hide system files, etc?

    But it sounds like you've finally found it by your comment about adding the .bak extension? If so, you'll just have to flash CWM just one more time to make it stick (when the recovery-from-boot.p file is present, Android will re-flash the stock recovery each time you shut down; so until that file is renamed or moved, it will have done that). So, just reflash it one last time and I think you'll be good.

    Let us know :).

    Cheers!
    Sharpe Man likes this.
  6. Sharpe Man

    Sharpe Man Well-Known Member

    Thanks SA. That did seem to do the trick.

    If your Indy location is the Indianapolis area, than one can always count on Hoosier hospitality!
    scary alien likes this.
  7. Tim K

    Tim K Well-Known Member Contributor

    I had the same issue yesterday. I believe it was a corrupt recovery.
    Following the instructions HERE to correct a 'stuck' recovery. Basically, go into the system folder, rename the recovery file and then flash a new one. You'll need something like estrongs file manager, you need to put it in root mode and mount the drive as writable (2 checkmarks in the settings menu). Then I went into clockwork and chose 'flash clockwork recovery'. It reloaded the recovery and I was able to boot to recovery after that.
    Sharpe Man and scary alien like this.
  8. scary alien

    scary alien not really so scary Moderator

    Thank you very much! :)

    Yes, this alien is indeed assigned to the Indianapolis area ;) :).

    Cheers and let me know if you have any other questions!
  9. AntimonyER

    AntimonyER AF Addict VIP Member

    I had this same problem yesterday, but flashing recovery fixed it.

Share This Page