Verizon S4 stuck downloading 4.3Support


  1. SirToasty

    SirToasty New Member

    My Verizon S4 started downloading Android 4.3 this morning around 10. It is now past 12 and is still on the screen that reads "Downloading...do not turn off target!". Up in the corner, in red, it says, "Could not do normal boot" and "ODIN Mode". The phone is rooted but has no custom ROMs. Is it actually still downloading or is it stuck?

    Advertisement
  2. jj14x

    jj14x Guides Guide

    I don't think it is 4.3 - I suspect this is Android 4.2.2 update, VRUDMI1
  3. SirToasty

    SirToasty New Member

    Thanks I was just informed of that elsewhere. Regardless, it's still stuck.
  4. valorian

    valorian Well-Known Member

    If it did not finish downloading have you tried rebooting the phone? If it didn't finish downloading it shouldn't have installed anything yet.
  5. SirToasty

    SirToasty New Member

    Holding down power brought it straight back to this screen.

    e: Pulled the battery, rebooted holding down vol down and power. Selected cancel and it booted fine.
  6. spin360

    spin360 Well-Known Member

    So after you restarted the popup went away??
  7. bhageman

    bhageman Member

    Same problem here and my phone isn't rooted.

    Stuck at downloading for several hours. Tried all the standard reboot tricks. Nothing works.
  8. bhageman

    bhageman Member

    Called Verizon. They were useless. Luckily, it is open enrollment for phone insurance, so I insured the phone and then immediately put in a claim. New phone on the way. Looks like the upgrade bricked it.
Loading...

Share This Page