[Verizon] Secure element problem(Google Wallet)... Help!

Last Updated:

  1. BeastMD

    BeastMD Well-Known Member

    So I used the Root Toolkit by Wug to root my phone and upgrade it to 4.0.4. Everything worked fine except now I have the dreaded Secure Element problem.

    I did use the toolkit to backup my apps and settings, however.

    Is that backup a full phone backup or does it just backup the apps/setting and not the OS?

    Or do I go back to stock 4.0.2 again using the functionality in the Toolkit and then restore my apps and data will that correct the secure element problem or am I just boned. I wish I had seen that issue before I rooted and upgraded. I hadn't seen it mentioned until I ran into the issue.

    What a ridiculous way for google to implement the software...

    Thanks for any help.

  2. bjanow

    bjanow Well-Known Member

    You will need to return the phone for another if you want it to work.
  3. nkk

    nkk Well-Known Member

    Two things:

    1. You need a new phone. Your NFC will work for all non-secure functions (Beam, etc), but all functions accessing the secure element are now blocked.

    2. It is not a ridiculous way for Google to implement software. You rooted, installed non supported alternative firmware and now want to blame Google for something not working. I am not blaming you (you probably did nothing wrong, per se. You just took a risk), but it is incorrect for you to in any way blame Google or Samsung or Verizon (well..blame for Verizon for being Verizon, but not for this :p ).

    Also, note that you voided your warranty when you rooted, that was explicitly stated in a warning on the phone and you agreed to it.

  4. BeastMD

    BeastMD Well-Known Member

    I know what chances in general you are taking, but I have never lost an important/basic functionality of the phone with no recourse. I can see this issue happening to "legitimate" users who don't root their phone down the road because of the way its implemented. I took a chance sure, as far as warranty I never intended returning the phone. Am I a little pissed that I cant use a function I was hoping to use, sure.

    I put the phone back to stock and I am going to try to restore my backup I made later to see if it will come back to normal. I was really looking for clarification to restore procedure and if it would possibly work, not start a battle about blame. I was reading about some nandroid backup fixing it and while I dont have one of those I am hoping the system/app/data restore I made will correct it.

    I am also hoping that some of the newer ROM's and upgrade developers mention it in their docs so others know what to do ahead of time.

    But man I'm bummed out.
  5. nkk

    nkk Well-Known Member

    Yeah..I hope it works out for you. I hear rumblings (a month or so back) about the devs trying to get a way around it. I do not know if anything came of that. If you really want to see if a reset will work (hey...anything is worth a try) I would go all out and the the full reset to factory using factory images. It probably will not work, but as I said...anything is worth a try.

    Your problem made me thing of something...when you return a phone with a secure element error (not you per se, but the general population), is it ever fixed? Or is it returned to the wild via the refurb/CLN program? If it is fixed, how? It would seem all they do is a factory flash. That would suck to get a refurb with that type of error.

    iowabowtech likes this.
  6. iowabowtech

    iowabowtech root@android:/ #

    Definitely worth a shot. I, too heard of some success stories. Let us know how it goes.
  7. BeastMD

    BeastMD Well-Known Member

    Well, no go. Hope someone comes up with a fix...
  8. DannyJSlone

    DannyJSlone Well-Known Member

    Not a secure element problem here but after rooting my phone now google wallet just sits on the initializing your device screen and spins. Is it broken for good now because of root. I also used the wegfresh system to root my phone. Everything else works great.
  9. Greek

    Greek Active Member

    So, I decided to go ahead and root my phone like every other phone I've had, and of course ran into a "prepaid unavailable" error, which according to whoever Google support forwarded me to, will be fixed within a week or two.

    But once I researched the error I see that some people are getting much worse errors and bricking their secure element.

    My question is, how can I avoid this in the future if I ever want to install a new rom? I feel like I somehow dodged a bullet, but I have no idea how or where that bullet came from.

    I just wish there was a sticky, or a note, or something like that as I had no idea these errors were happening to everyone until after the fact.... eh I guess I had to get screwed from rooting at some point... I just hope it's not too serious. :(

    Thanks for any help
  10. ZeroOne

    ZeroOne Guest

    Are you manually using fastboot commands?
    Or wugfresh root kit? This is the first I've heard of
    This situation.
  11. Greek

    Greek Active Member

    I used the root kit, and yeah what support told me was that the prepaid card can't be used on different phones, so when you reinstall google wallet (or root and install it again) it just deactivates. She told me that it will be fixed within a couple weeks, but they honestly can't say that they know for sure.

    I guess other people have completely bricking their chips though too.
  12. Greek

    Greek Active Member

    I just decided to restore all my apps with the toolkit and now it isn't giving me that error. I guess I'll go give it a try at a grocery store self checkout and see if it works or not.

    EDIT: Nevermind when I tried to select it, it forced me to reset it, sending me back to this error. :(
  13. ZeroOne

    ZeroOne Guest

    I'm lost on this sorry find a guide in here mayhaps they can help? :confused:
  14. iowabowtech

    iowabowtech root@android:/ #

    Only thing I've heard of working in some cases was a nandroid backup to an earlier time where the Wallet was working properly. Not sure if that's a possibility for you or not.
  15. sdrawkcab25

    sdrawkcab25 Well-Known Member

    From what I've been reading, there is no going back once you get the secure element error. The NFC chip is bricked (for purchases).

    The only for sure way to avoid the error is to reset the wallet app before doing any factory resets or flashing of new roms, kernels or radios. The reset has to be done from WITHIN the app, clearing data for the app is not enough.

    Secure Element Error Locking Users Out of Google Wallet

    The second issue people are having is that provisioning of prepaid cards is still under maintenance.

    **scroll down to february 11th**
    jmar likes this.
  16. vishious89

    vishious89 New Member

    I just recently added the wallet through the browser market exploit. It worked the first time, but was stuck on adding the prepaid card. I closed the app, wiped its data, and restarted. Now it is just stuck on initializing. Once, after an hour of initializing, it got to the screen where it asks me to enter my gmail account, did that, and it went back to initializing. It's still just initializing, but I have never actually received ANY error message. Anyone know of a case like this? Have I actually locked the Secure Element, and if I have, why is their no error message? I'll let it do its thing all night and see if anything happens.

    Stock rom btw, never rooted. Yet.
  17. duke69111

    duke69111 Active Member

    You say "reset the wallet app before doing..." by that I assume you mean clear data and cache in the app settings, before wiping, installing an update, nandroid backup, ect.

    Just wanting to be clear, so I can hopefully avoid this problem.

  18. nkk

    nkk Well-Known Member

    No. that is not what he means. Go into the wallet app and go to menu>settings>reset google wallet.

    Doing it from the android OS application settings menu will delete cache etries, but will not clear the certificate/whatever it is from the Secure element on the NFC chip. Only resets from inside the wallet app clear that.

    iowabowtech and Neera like this.
  19. duke69111

    duke69111 Active Member

    Thanks for this.

    Unfortunately, after I enter my pin to unlock, when I click menu, It only shows help and feedback.

    When I click on my prepaid card and then menu, I get refresh, view card transactions, about card, remove card, help, send feedback.

    Is it the remove card that you are talking about, or do I have to have an actual credit card added to be able to reset google wallet?

    Or am I missing the reset google wallet setting all together?
  20. jmar

    jmar Nexican VIP Member

    Anytime I have needed to rid my phone of Wallet's info to move from one ROM to the next, I clear data from within app settings. This ensures that anything you might do to your device until you fully reactivate Wallet will not put you at risk for shenanigans.

    Unless there is a problem or issue that Google is trying to remedy and thus interferes with the app directly, this is the best way to avoid problems.

    I got this info after talking to a Money Network rep who has a Verizon Nexus and our beloved, now "unsupported," Wallet. He runs Liquid ROM!
  21. iowabowtech

    iowabowtech root@android:/ #

    Press the padlock in the upper right corner. It will prompt you to enter your pin again. Once entered, check settings again. I think you will find the expanded options now. Not sure why that little workaround is sometimes needed.
  22. duke69111

    duke69111 Active Member

    Locking and reunlocking did not work, but it triggered a thought.

    I went to app settings and Force Stopped the app and then reopened it. It then took me to the main screen where it shows payment cards, rewards cards, offers and transactions.

    From here I was able to see Settings then Reset Google Wallet.

    Thanks everyone.

    Update. There is no need to click force stop...just click the words google wallet at.the top left and it will take you to the main screen. You can then choose menu, settings and then reset google wallet.
  23. Madrox17

    Madrox17 New Member

    Ok....help! Total newb here trying to prevent bricking my NFC chip. It may already be too late, but I figured I'd come ask for advice before doing anything else.

    I used WugFresh's utility to unlock/root my phone last week. After doing some reading, I decided to try a CM9 Kang that I found on RootzWiki as my first custom ROM.

    I read about the secure element issue before the wipe required to unlock/root my phone, and cleared the payment data out of Wallet. I was able to set it back up post-root with no issues. However, I did NOT think to do it once again before flashing this custom ROM. The ONLY thing I've done since booting CM9 up for the first time is install Titanium Backup and start restoring my app backup. The only reason I thought of this was that I saw Wallet flash by during the restore progress. I instantly got that feeling in my stomach and knew that I screwed up.

    I have not opened Wallet. Is there ANY way to ever open it again without bricking my NFC chip and getting the dreaded secure element warning? I did not do a Nandroid backup specifically the way I've read how to do it (wasn't really that worried about the settings of my phone) but I did use RomManager to make a backup right before I rebooted into CWM to flash the ROM. From what I've read elsewhere, maybe by using ROM Manager to do the backup, it did the same thing as a Nandroid? Does that mean it's possible for me to restore that backup and escape the secure element error since I've never fired up Wallet?

    Hope this makes sense. I use Wallet several times a week, and am both terrified and furious at myself for making such a newbie mistake and possible disabling one of my favorite features of my Nexus. :(
  24. nkk

    nkk Well-Known Member

    A couple of things:

    some nitpicks: This does not brick your nfc chip. It merely disables the secure element in it. Things like beam or just reading tags still work.

    Real info:
    Doing a backup in ROM manager is the exact same as a nandroid. Not as in they look alike and maybe work the same, but as in ROM manager boots into recovery and actually does a nandroid. So despite your lack of actually having done a backup, you have one (you got lucky :p ).

    You need to understand where the problem comes from. It is when the card data (not payment log...that is NOT stored on the secure element) that is being used to charge your account is left on and then GW tries to make new card data, thus throwing errors everywhere (this is a very simplified description). It does not happen every time, so you may actually be safe. However, to be certain, restore the backup (the one that you had used wallet with), clear data through the wallet app, and then either reflash a backup of CM9 that you make now, or just reflash the ROM. That will ensure that there is no info on the secure part of the nfc chip to cause problems. note that this problem is not completely understood yet, so there are really no guarantees.


Share This Page