[Verizon] Stuck at "Samsung Galaxy S4" boot logo

Last Updated:

  1. crackface

    crackface Well-Known Member

    Really hoping someone can help, don't know what to do.

    Rooted a week and a half or so ago, went fine and phone seemed to work as normal. I then installed the TWRP recovery a few days ago, and the next day tried loading the Synergy ROM. It began to have a problem booting up, and would freeze at "Samsung Galaxy S4" white letter logo in the beginning. Tried restoring stock nandroid, tried reloading Synergy, with many wipes in between. Once in a while it would boot up, but today I couldn't get it to boot at all.

    I then followed the flash to stock instructions with Odin, which allowed it to boot the first time (though it was weird, it didn't look it did when I first got the phone with initial setup, and icons on the homescreen were much bigger than normal). I then tried rebooting it, and I get the same hangup at the logo.

    Is there anything I can do, or should I be trying to return the phone for another one? If I have to return it, is it "stock enough" that I could return without a hassle from Verizon?

    Any advice would be HUGELY appreciated! Thanks in advance....

  2. crackface

    crackface Well-Known Member

    Just realize I put this in wrong section, can a mod move it to root?
  3. Kelmar

    Kelmar Done by choice VIP Member

  4. mrawesome22

    mrawesome22 Well-Known Member

  5. jhawkkw

    jhawkkw Chinchillin' Moderator

    I can move it if you specify which version of the S4 you have.
  6. Kelmar

    Kelmar Done by choice VIP Member

    Verizon (per his initial post)
    jhawkkw likes this.
  7. jhawkkw

    jhawkkw Chinchillin' Moderator

    Thanks, can't believe I missed that. Thread has been moved :)
  8. crackface

    crackface Well-Known Member

  9. Kelmar

    Kelmar Done by choice VIP Member

    Missed that in your initial post, apologies (but a second try never hurts). :)

    If that doesn't work, I'm not sure (nor fluent enough to assist further). Safe to assume you've tried booting into the bootloader and clearing everything you can?

    Best of luck!
  10. crackface

    crackface Well-Known Member

    I just retried stock flash via Odin (seemed to flash ok), it booted once past the logo, I got the little green robot, it rebooted again, and now it's stuck on the logo again. This is different than yesterday where it booted up phone eventually and didn't get stuck on logo until after I manually rebooted. Will try a few more flashes...

    I guess at this point I'm thinking the phone may be defective, so my primary concern is that the phone appears "stock" enough if I were to swap it with Verizon. I don't wanna send it in and have them be able to tell I messed with it.
  11. crackface

    crackface Well-Known Member

    I just tried stock flash with Odin 4 times, all with the same result. It seems to flash OK, reboots to Samsung Galaxy S4 logo with blue "booting recovery" small font in upper left, shows picture of android robot facing left'ish with blue spehere-like thing in it's belly with a progress bar on bottom that makes it all the way to right, then it reboots again to Samsung Galaxy S4 logo and freezes there. If it makes any difference, here's the status output from Odin:

    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> VRUAMDK_NoWipe.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/005> Added!!
    <ID:0/005> Odin v.3 engine (ID:5)..
    <ID:0/005> File analysis..
    <ID:0/005> SetupConnection..
    <ID:0/005> Initialzation..
    <ID:0/005> Get PIT for mapping..
    <ID:0/005> Firmware update start..
    <ID:0/005> NON-HLOS.bin
    <ID:0/005> NAND Write Start!!
    <ID:0/005> aboot.mbn
    <ID:0/005> boot.img
    <ID:0/005> cache.img.ext4
    <ID:0/005> hidden.img.ext4
    <ID:0/005> modem.bin
    <ID:0/005> persdata.img.ext4
    <ID:0/005> recovery.img
    <ID:0/005> rpm.mbn
    <ID:0/005> sbl1.mbn
    <ID:0/005> sbl2.mbn
    <ID:0/005> sbl3.mbn
    <ID:0/005> tz.mbn
    <ID:0/005> system.img.ext4
    <ID:0/005> RQT_CLOSE !!
    <ID:0/005> RES OK !!
    <ID:0/005> Remain Port .... 0
    <OSM> All threads completed. (succeed 1 / failed 0)

    I dunno if it worked, but I tried to attach screenshot of Odin too.

    Think I'm OK to return to Verizon as-is? Any suggestion on whether I can just try and swap it out in a store or if I have to call it in?

    Attached Files:

    • odin.jpg
      File size:
      140.1 KB
  12. Atma

    Atma Well-Known Member

    It looks like the stock rom loaded ok. Can you go to recovery and do a factory reset?
  13. crackface

    crackface Well-Known Member

    Interesting you should say that...I just tried that figuring it couldn't hurt, and shame on me for not taking better notes on what I saw on screen to relay here, but will do my best from memory.

    I booted to recovery OK, and it had some red txt about being unable to mount something. I tried factory reset from in there, and it seemed to take, but when phone rebooted it got stuck on Verizon logo this time. I pulled battery, booted back to recovery, noticed this time there was no red txt about being unable mount something, and this time cleared cache first, then factory reset. It got stuck again on Verizon logo, but pulling battery and rebooting seemed to do the trick. I've now manually rebooted 5 times now and no hangups!!!!! :) :)

    Any idea what could have been going on?
    Atma likes this.
  14. Atma

    Atma Well-Known Member

    I'm not sure. It sounds like it couldn't mount sd card maybe?

    Often when getting an update or using odin to go back to stock, a factory reset will fix bugs that may cause, especially stuck on the bootup screen. So it boots ok now?

    Your problems before may have been with TWRP, but I don't know for sure. I know version was having problems with the t-mobile phone.
    crackface likes this.
  15. crackface

    crackface Well-Known Member

    I've been up running fine on both stock, and I went back to TWRP and Synergy ROM which is running after many reboots without issue. Not one freeze up at Samsung logo through a few reloads of stock and couple ROM flashes. For some reason the Odin stock restore, on first boot after completion, will hang at Verizon screen. But a battery pull and another boot and it goes into Android updating mode and eventually brings me to stock config as expected.

    I can't thank enough for the help here. I thought I was gonna hafta do the walk of shame with Verizon. Very much appreciated!!!
  16. o M O N O o

    o M O N O o New Member

    hey im having the same problem on my i337 but i am not able to access recovery just odin mode, any help?
  17. Atma

    Atma Well-Known Member

    Welcome to the forum mono :hello:

    Are you rooted? On the stock rom? Try pulling the battery and then going to recovery.
  18. o M O N O o

    o M O N O o New Member

    hey thanks for the welcome, no i am not rooted. maybe thats bwhere it went wrong but everything was fine until the phone was reset. i could access odin mode but it gets stuck with the little blue letters top left when i try to access recovery. ive used kies and odin to flash back to stock but no luck. any ideas?
  19. Gorillafist

    Gorillafist New Member

    Thanks everyone. This same situation happened to me almost exactly, accept that I was rooted previously and the freezing at the samsung logo started after I did a restore in twrp. It booted fine once after the restore but then started after I rebooted. Really weird butI do think it has something to do with twrp.

    Its still froze after an odin but then worked after a factory reset
  20. JMS23

    JMS23 New Member

    Hi Omonoo, I have exact same issue, and odin/wine emulation in mac does not recognize it, what did you do to fix it?
    Been searching since yesterday over the internet. Thanks!

Share This Page