[Verizon] The SuperUser Binary (su) must be updated

Last Updated:

  1. Phoenix_Boston

    Phoenix_Boston New Member

    Hello -

    I've tried to root my Samsung Galaxy S4 (Verizon) with Motochopper, however when I try to open Superuser, I get the message "The superuser binary (su) must be updated". When I try to update, it fails. Any help?


  2. Shotgun84

    Shotgun84 Well-Known Member

    Hello and welcome to the forum:ciao:

    I'm not familiar with your version of the s4 so I'll move this over to the verizion all things root forum where they'll be best equipped to help:)
  3. killajoe

    killajoe Well-Known Member

    What build are you me7 or earlier
  4. killajoe

    killajoe Well-Known Member

  5. beowulf7

    beowulf7 Well-Known Member

    SuperSU was updated on 7/29/13, which is of course more recent than when this MDK root was created. So update that app, then update the binaries.
  6. nacttion

    nacttion New Member

    hey guys, I just tried to root my Samsung GS4 with motochopper and I got that message when I try to open Superuser App (The superuser binart (su) must be updated).

    Is there a solution for this? Can I root with Odin after I tried with motochopper?

    Please help me, the info of my device is

    Model number: GT-I9505

    Android Version: 4.2.2

    Baseband version: I9505XXUBMGA

    The S4 is International unlocked

  7. Crashumbc

    Crashumbc Well-Known Member

    Natticon- this is the VZW subforum most of the info here won't apply to you and could damage your phone.

    Try posting in the below link to get the best info. for your phone.

    (International) Galaxy S4 - All Things Root - Android Forums
  8. Togopogo

    Togopogo New Member

    Hi Nacttion, sorry to hear your having trouble rooting your phone and that people don't know what is the problem because all they can say is post somewhere else meaning ask someone else. I know cause I checked other post on this topic in other forums say the same "post in another chat/forum" well just ignore them and hope someone will know how because its not working for me either on my Samsung galaxy I just bought about 2months ago. When I open the Superuser app and try both install and Recovery Install get error: Install, There was an error installing Superuser. Please send a log of the error to the developer. When I hit OK it opens the app and says "There are currently no Superuser app policies. Even checked using Root checker app and says device does not have proper root access. Anyone out there know about this?
  9. HaTrEd360

    HaTrEd360 Well-Known Member

    You don't just install Superuser and have root. That's just an app to access root. The root file is su and has to be written to the system of the phone using exploits and currently there are none I guess for the latest update. Good luck.

Share This Page