[Verizon] Titanium Backup Issue

Last Updated:

  1. NSutherl

    NSutherl Well-Known Member

    I've been having this problem since clean flashing the Clean AOSP JRO03R ROM. When I rebooted after flashing it, I stopped the Play Store from auto restoring my apps, and went into TiBu to restore the ones I wanted. To my surprise, there were no user apps to restore, just system data (image, taken after restoring my apps 1 by 1 from the Play Store). You can see in this shot that it thinks there are no user apps to backup and that there aren't any existing user apps to restore, even though I have my apps installed from the playstore and I run scheduled backups of user apps in TiBu.

    Has anyone seen this issue before? TIA.

  2. gapi

    gapi VIP Member VIP Member

    Not sure its related but I found restoring backups made in ics onto a JB ROM gave me issues.
    I restored an ics nandroid. Allowed Google to backup my apps and accounts.
    I backed up my SDcard TBU stuff and then flashed a JB Rom and let Google restore my apps. This also confirms GPlay is working fine. If GPlay doesn't restore it it may be a JB compatibility issue.

    Then I made sure my TBU was in place and made new BU's.
    NSutherl likes this.
  3. The_Chief

    The_Chief Accept no imitations! Moderator

    The "conflict" between Play & Titanium Backup restoring apps has plagued me as well... and other than simply restoring backed up USER DATA to the apps Play restored, I found this work-around:

    When you flash the ROM, don't sign into Google yet. That way, Play can't interfere.

    TiBU has a function that allows you to create an "update.zip" file (actually, I name it TiBU.zip) in your internal memory.

    Back up everything, verify you have your zip file and wipe/flash away.

    After flashing the ROM and getting to your home screen - having SKIPPED Google sign-in - reboot back into recovery and flash the zip it created. Then reboot system. That will place TiBU in you app drawer, allowing you to restore your apps and data with no interference from Play.

    Once your restore is complete, THEN you can set up your accounts and Play... remembering, of course, to turn off that annoying "Auto-Add" thing.

    I tried to flash TiBU.zip in the same recovery session as the ROM and Gapps, but that didn't work... just to early in the process for TiBU to "take". So you will have to do that in a separate recovery session.

    If TiBU updates to a new version, make sure you delete the old zip file and create a new one.

    Hope this helps :)
    NSutherl likes this.
  4. iowabowtech

    iowabowtech root@android:/ #

    Seems strange to me. Check /system/app and note if all our market apps are being placed there somehow? You should see your market apps along with copies of Gapps at /data/app.
    NSutherl likes this.
  5. NSutherl

    NSutherl Well-Known Member

    I've been on JB ROMs for a while now, and have had no problems backing up and restoring apps (either ICS to JB or JB to JB) until now. It started happening after flashing that Clean AOSP JRO03O ROM, and now it's happening after flashing another JB ROM that was working before.

    I will try this, but when I went into TiBu after stopping the Play Store auto restore, there were no apps in TiBu to restore. Maybe once the Play Store starts the auto restore process it messes with the data in TiBu?

    I found all gapps in /system/app and gapps + market apps in data/app.
  6. The_Chief

    The_Chief Accept no imitations! Moderator

    That's because the option I'm thinking you selected was "Restore missing apps with data" and there weren't any missing apps. You can always restore DATA to the apps Play downloads, just selected "data only" as your restore option for each one.

    But on a fresh install, without Play involved, TiBU will restore any and every app you select... as well as MMS/SMS, call log and alarms (if you backed up system data as well - those are a few of a handful of system data elements that generally can be safely restored).
    NSutherl likes this.
  7. iowabowtech

    iowabowtech root@android:/ #


    How about try settings > market tools > market doctor. Try user apps, if there's none listed, try user and system apps and only restore links on apps you've personally downloaded from the market.

    Also, check for the presence/absence of the Titanium Backup folder on the /sdcard and make sure it's populated with your apps. If you have the older school Tibu (not sure if it's still done this way), check for the sdcard txt file that is your license/recognition file. When you first open Tibu, it should list your name + email addy so I guess that's another way to verify what should be the same thing.

    Finally, open Superuser or SuperSU and make sure Tibu has been granted root permission. I'm thinking you would be notified up front if that were the case but just trying to rule out all possibilities.
    NSutherl likes this.
  8. NSutherl

    NSutherl Well-Known Member

    TiBu is acting like there are no user apps installed, so there is no data to restore to the apps (see the image linked in OP). It's like it's looking for apps in the wrong place, so it doesn't see any to backup. It's also like it's looking for the previously backed up apps in the wrong place, so it doesn't see any apps to restore.

    If what you're saying was the case, TiBu would either see that there are apps to back up (that are already installed) or that there are missing user apps (and/or data). It is seeing neither of these.

    In a weird twist, it is backing up and restoring all my system data fine (I use TiBu to restore SMS/MMS, launcher settings, etc...).
  9. NSutherl

    NSutherl Well-Known Member

    In Market Doctor > user apps, the only 2 apps I get are Titanium Backup (which I installed manually from the Play Store), and Wallet (which I sideloaded). When I select user and system, I get all my gapps, system data, and the 2 user apps from the previous step.

    The TiBu is on my SD Card and appears to be populated with all my apps and data.

    TiBu is on the allowed list in Superuser.
  10. gapi

    gapi VIP Member VIP Member

    Curious, did you try the advanced/reboot recovery option and then flash. That would be a kind of 2nd part of a session eh?

    I'm gonna try it on my next flash.
    The_Chief likes this.
  11. The_Chief

    The_Chief Accept no imitations! Moderator

    Good thinking, Gapi, no that had not occurred to me...
  12. gapi

    gapi VIP Member VIP Member

    I just did it while checking out the BLACK BEAN rom and it did not show up. :rolleyes:
  13. iowabowtech

    iowabowtech root@android:/ #

    In Tibu at menu, preferences, backup settings...which options are checked?
    NSutherl likes this.
  14. NSutherl

    NSutherl Well-Known Member

    (checked) Normal apps
    (checked) Protected apps
    (unchecked) System apps
    (checked) Market link
    (unchecked) Backup app cache
    (checked) Advanced app control
    (checked) Restore app external data
    (checked) Migrate system data (though I just turned this on today)
  15. iowabowtech

    iowabowtech root@android:/ #

    Ok, I don't have the migrate option checked but I do have system apps checked and always have. I did just now try to uncheck it though and I couldn't replicate your issue. My only idea is to clear the play store app's data and cache and perhaps also uninstall and then reinstall Titanium but don't restore its data. Start with default setting and then rebuild your auto backup profiles. :dontknow:

    Aside from that, I think I'd be contacting Joel (tibu app dev) who is amazingly responsive to questions in my experience, for a developer of his stature.
    NSutherl likes this.
  16. gapi

    gapi VIP Member VIP Member

    TBU is working for me better in JB than it ever has.
    I have always ran it as is and restored all apps with data.

    Now my email (2 accounts) and Gmail accounts restore configured. If flashing a new version of the same ROM it restores all my home screen icons.
  17. NSutherl

    NSutherl Well-Known Member

    How do you reinstall Titanium Backup without its data? I cleared TiBu's data, uninstalled, cleared Play Store data, reinstalled TiBu. When I opened it, it already had all my schedules set up, still no apps to backup or restore though.

    I checked the system data box ((which turns out is the default option), but it didn't change anything. Thanks for your help so far.
  18. iowabowtech

    iowabowtech root@android:/ #

    That should not be the case unless on your phone at settings > backup and restore, you have "backup my data" selected, your gmail account identified, and automatic restore checked. If those are selected, deselect all of them before uninstalling/reinstalling Titanium. If you still run into problems, try deleting the Titanium folder on the sdcard prior to uninstalling. You can copy it's contents elsewhere if you want although if you don't have market apps backed up, it's semi useless anyway imo.
    NSutherl likes this.
  19. Droid_Junky

    Droid_Junky Well-Known Member

    Not sure I completely understand what is going on but I have stumped myself before by forgetting that I had a filter in titanium backup. If you type anything into the search function at the top, even one letter, it will appear that I have no apps backed up. If you type a search for a specific app it will only show that one app until you clear the filter.
    NSutherl likes this.
  20. NSutherl

    NSutherl Well-Known Member

    This was it! I had a filter that was only showing user data. Score!

Share This Page