1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[Verizon] Turn USB Debugging on in Recovery Mode?

Last Updated:

  1. GalaxyNexus

    GalaxyNexus Well-Known Member

    Does anybody know how to do this? I turned off my phone at night and in the morning I got stuck in a random reboot. Now I'm wanna unroot my phone. Unfortunately I can't seem to turn on USB debugging.:confused:

  2. scary alien

    scary alien not really so scary Moderator

    USB debugging is turned on in ClockworkMod [i.e., in the default.prop file in the ramdisk] (you can use that to your advantage to run adb while booted in custom recovery).

    What makes you think that it isn't enabled?
    GalaxyNexus likes this.
  3. GalaxyNexus

    GalaxyNexus Well-Known Member

    I did the Wug-something easy method root... Not adb or sdk. Sorry, I don't really understand your terminology: prop file? Ram disk? I'm not sure what your talking about the USB being on in recovery mode because my computer doesn't recognize it. Sorry.
  4. scary alien

    scary alien not really so scary Moderator

    No worries. I was just trying to point-out that USB debugging is already turned on in custom recovery mode (not stock recovery, though).

    I don't know if the Wugfresh toolkit installs both adb and fastboot drivers for you, but I'm guessing that might be your issue.

    Check out this post for help with installing the adb and fastboot drivers:

    How to install the adb & fastboot USB drivers (MS/Windows users only)

    GalaxyNexus likes this.
  5. GalaxyNexus

    GalaxyNexus Well-Known Member

    This is the only way?
  6. Mahalo

    Mahalo Well-Known Member

    Scary Aliens toolkit can probably help you, right SA? Check his sigline for a link.
    GalaxyNexus likes this.
  7. iowabowtech

    iowabowtech root@android:/ #

    Did you ever make a backup in recovery (or with rom manager)? If you could restore to stability, it'd probably be easier to unroot with a toolkit. Otherwise, you're looking at fastboot most likely.
    GalaxyNexus likes this.
  8. scary alien

    scary alien not really so scary Moderator

    Well, if he's in a bootloop, he wouldn't be able to install it...even then, if he's trying to un-root, then using the flashing recovery operations wouldn't help him that much unless he's lost CWM, etc.

    Not sure if the OP has tried a battery pull or not or exactly what condition / status his device is in...more information would be most helpful ;).


    It does look like Wug's toolkit will flash you back to stock... It'll do all the dirty work for you:

    Galaxy Nexus Root Toolkit | WugFresh

    Good luck!
    GalaxyNexus and colchiro like this.
  9. colchiro

    colchiro Well-Known Member

    GalaxyNexus and scary alien like this.
  10. GalaxyNexus

    GalaxyNexus Well-Known Member

    Here's the whole story...

    Galaxy Nexus Milestone 4 AOKP no mods or kernels
    I have a TON backups

    So several days ago I walke into the movie theatre ( Hunger Games is a good one!:) ). I turn off my phone before going in. After the movie I try to turn my phone on and after the first pony thing my phone freezes up and then continues trying to turn on. Keeping my calm I took out the battery and tried to flash a backup. The same thing happened (except w/ stock android boot animation).

    At that point I decided I must've done something stupid, and posted a question on trusty AFs. I figured messing around with the phone could only do more harm than good. Sorry about the lack of info guys, I'm just worried that I somehow messed up again.

    Honestly, I've played everything really safe and conservative after my last mess up. You might remember my last panic attack...

    Again, thanks for the help.

    P.S. I still don't know why my 10 or so backups aren't working properly.:mad:
    scary alien likes this.
  11. colchiro

    colchiro Well-Known Member

    Thanks, much easier to help when we have more info.

    Can you wipe caches and reflash AOPK? (or flash anything?)

    Then if you can get it running, you can try renaming a backup, if needed. My keyboard likes to add a space after every typed period.
    GalaxyNexus and scary alien like this.
  12. iwoloschin

    iwoloschin Well-Known Member

    A friend's GNex was doing something similar...though she took it to Verizon before I could get a chance to look at it :mad:. VZW totally flubbed and gave her a refurb, but I'm pretty sure there was just an issue with the battery "sense" file thinking that the battery was depleted, even though it wasn't really. Can you try wiping the battery stats? I think there's an option for that in CWM.

    I don't remember where I found this info, but it was apparently a well known bug in AOSP.
    GalaxyNexus and scary alien like this.
  13. GalaxyNexus

    GalaxyNexus Well-Known Member

    Yeah, I tried that. The reboot messed each time. I tried flashing every rom I have and it still didn't work.

    Thanks for trying though.
  14. GalaxyNexus

    GalaxyNexus Well-Known Member

    Deleted everything, cache, battery stats, and did a factory reset. Flashed aokp b28 and it did the pony thing about 4 times before it started over.

    Thanks 4 the help guys. I installed adb and sdk but I can't get anything to work if I can't find my phone so I don't know what to do. :(
  15. colchiro

    colchiro Well-Known Member

    Format system, data, cache, dalvik cache, then flash your rom.

    I was stuck on the Google screen going from liquid to aopk until I also flashed system.
    GalaxyNexus likes this.
  16. scary alien

    scary alien not really so scary Moderator


    Have you tried restoring a known, good Nandroid backup?

    That's your best, first thing to try...

    Also, for the other ROMs you are flashing, did you double-check the MD5 sums on them to make sure the downloads are good?
    GalaxyNexus likes this.
  17. GalaxyNexus

    GalaxyNexus Well-Known Member

    Where's the option to format dalvic cache? I found everything but that.
  18. GalaxyNexus

    GalaxyNexus Well-Known Member

    Yes, I have. I had been using M4 for a good couple weeks with no problems until I encountered this mess up.
  19. scary alien

    scary alien not really so scary Moderator

    Its under the "advanced" menu.
  20. scary alien

    scary alien not really so scary Moderator

    Yeah, that's a little worriesome that a Nandroid restoration wouldn't fix you up...:( [it should].
  21. GalaxyNexus

    GalaxyNexus Well-Known Member

    I've already returned the Nexus once, so I'm afraid to do it again.
  22. GalaxyNexus

    GalaxyNexus Well-Known Member

    Wait, is a Nandroid the same thing as a normal backup? Sorry bout the stupid question.
  23. scary alien

    scary alien not really so scary Moderator

    You make a Nandroid backup in custom recovery (ClockworkMod) under "Backup/Restore"...does that ring a bell?
  24. GalaxyNexus

    GalaxyNexus Well-Known Member

    Yes I did.

    When downloading it, it says everything worked fine but there's an error recovering data.
  25. colchiro

    colchiro Well-Known Member

    What's the backup name you're try to restore? Is it all numbers or did you rename it to something more meaningful in Rom Manager or a file browser like Root Explorer?

    This is a normal backup name (it's date-time stamp): 2012-04-
    GalaxyNexus and scary alien like this.

Share This Page