[Verizon] "Your device isn't compatible with this version"


Last Updated:

  1. ganj_420

    ganj_420 Well-Known Member This Topic's Starter

    Joined:
    Jun 29, 2011
    Messages:
    101
    Likes Received:
    22
    Anybody else have this issue? I hear of updates to apps and I almost always get this message in the Play Store when I go to update them. I can't even get the official Facebook app without side loading the .apk file because it says my device isn't compatible. Even worse is I can seldomly update even stock apps such as Google+, Google Maps etc because of it and its kinda frustrating.

    Rooted running LiquidSmooth v1.35 with 4.0.4 radios if that makes any difference
     

    Advertisement
  2. jbdan

    jbdan Well-Known Member

    Joined:
    Jan 31, 2010
    Messages:
    7,121
    Likes Received:
    3,187
    Have you changed the dpi? Make sure it is set to 320

    Have you tried clearing your data for Google play store?
     
  3. ganj_420

    ganj_420 Well-Known Member This Topic's Starter

    Joined:
    Jun 29, 2011
    Messages:
    101
    Likes Received:
    22

    That worked great! I guess going full-screen and using LMT launcher messed up the pixel density, it was set to 330 instead of 320. So I set it back, cleared data for the play store and rebooted and have like 30 apps updating lol. Thanks for the help, much appreciated!
     
  4. jmklei0

    jmklei0 Active Member

    Joined:
    May 2, 2010
    Messages:
    29
    Likes Received:
    3
    This is crazy. I'm having the same problem, but your fixes are not working. I've tried different LCD Densities (240, 300, 320), rebooting after each time, and a separate data-clear of the Play Store. Yesterday, I reinstalled the Play Store too.

    I'm using Liquid 1.4 ROM.

    Any other ideas? I had a tough time finding some other apps, but I'm seeing this specifically now for Facebook. There may still be others, though.

    Thanks,
     

Share This Page

Loading...