VERY Basic Question (Opening an Android Project)


Last Updated: 2013-01-01 13:47:18
  1. KansaiRobot

    KansaiRobot Member

    Hello everybody.
    this is my first post. In fact my question is VERY similar to the one posted in

    http://androidforums.com/application-development/32654-how-open-project-eclipse.html

    I also have tried my first two android projects and run them successfully.
    But now I want to open someone else's project (some example codes). But I can't and I don't know how.

    1) Which one of the numerous files is the "project file"?? (is there one?)

    -----
    Now, the thread above got two responses, both of them don't work

    one poster said:

    File->New->Project and create project from existing source...

    I tried that but it says "it already exist another project on the workspace, try importing"

    so i tried that other option (like the last poster on that thread suggested)

    File >Import >General> Existing Projects

    When I did that it "opened" the project but very weirdly. First it is FULL of errors..(and obviusly cant run it) and even in the source section there is not only the source files but also com and com.androidbook etc other files that never should appear...

    I dont remember the error message but will post it later

    so please

    How do you guys open an existing android project in Eclipse? (a step by step tutorial would be great)

    Thanks for all the help..

    Advertisement
  2. dcparham

    dcparham Member

    Wow, that sounds frustrating big time! ok, what they said do, basically works. does it work for you for any projects? it sounds like the right way to open them. is possibly this project corrupt somehow? have you tried when opening that project and give it a name [when it then gives you the error ["it already exist another project on the workspace, try importing"] so change the name you're giving it? actually, i got that same error after trying to open a project i copied to another name - ex: i had an app named "Addition - Copy" i wanted to preserve so i copied/pasted it into same folder as "Addition - Copy2". i tried to open it and got that "already exists... try importing...". so i turned around and imported, and it opened. now all u should have to point to is the main folder where it exists, then eclipse finds what it needs to open.

    sorry that i am not giving u what may be needed to crack this mystery but it is just plain weird and begs snooping around into the basics. otherwise, again, is it a corrup project? listen i feel for u i really do. i have posted multiple forums and gotten so many views and zero replies, including on this site!
  3. dcparham

    dcparham Member

    btw, KR - here's a group of legit projects we use in my Android class - go here first - Beginning Android 2 - then go to the Source Code/Downloads tab and download the plethora of projects. then in eclipse, File>New>Android Project>then select radio button: "Create project from existing source">then drill down to the main folder of each different project [there's a whole list]. the folder you download and unzip should be named "sourcecode". i placed it into my C:/Data1/Software1/Android [of course ur's will be your unique location] - then the file u download named "sourcecode" u will put into your location. then in eclipse u will browse for the "existing source" into for example: "sourcecode\commonsguy-cw-android-f1de3a5\Database". we just opened the Database project in eclipse on Saturday. so, just drill down to and select "Database" and the project should open [i suppose there's just 1 project in "Database" and it grabs it]. try that would you? let me know how it goes, i do understand frustration when the basics are not working.
    KansaiRobot likes this.
  4. KansaiRobot

    KansaiRobot Member

    Hello dcparham!
    thanks for the reply and sorry for my lateness.. I am going to try what you said right now. I ll let you know how it goes...

    Well so far i could "open " the eskeleton project but when running it it doesnt appear on the emulator...
  5. KansaiRobot

    KansaiRobot Member

    well almost two years later I still cant open projects

    and the "create project from existing sources" dont appear anymore

    :(

Share This Page