VERY poor quality sound from headphonesSupport


Last Updated: 2014-07-20 14:30:18
  1. steve1401

    steve1401 Well-Known Member

    Hi,

    I've just recieved my black GS4 from T-Mobile (UK) and all seems well apart from the headphones produce a very, VERY poor quality sound. It is crackly and tinny and even at max volume not very load.

    So, I tried the Samsung headphones from my GS2. The sound from these was as expected and pretty decent. The same with some Sony over ear phones I have.

    I'm not happy that the supplied phones are not functioning correctly, partly out of principle - they are new right - but mainly becuase I don't know that this isn't a phone hardware fault.

    I was thinking of spending about

    Advertisement
  2. tastycaramel

    tastycaramel Guest

  3. steve1401

    steve1401 Well-Known Member

    Thanks, I'll try and get into the local T-mobile store tomorrow and see if they can replace them... I just tried the earphones on my galaxy tab and they're just as bad...
  4. tastycaramel

    tastycaramel Guest

    In that case, the earphones definitely has some issues since they would not work on another device. Hopefully you can get them replaced!
  5. lotus49

    lotus49 Well-Known Member

    My S4 headphones are better than the S2 headphones, which I kept.

    I think yours are broken.
  6. Shocky

    Shocky On Probation

    I never even tried the headphones that came with my Galaxy S4, I gave them away.

    Get yourself some decent headphones, at least if the sound quality is still poor you know it's a problem with your S4 ;)
  7. Sandcracka

    Sandcracka Member

    The S4 headphones are of poor quality. My Klipsch S4A's are much louder and sound much better, with more bass and clearer highs. I never even tried my S3 headphones so I don't know which are better, but the S4's you would think would be louder/more bass due to the bigger size and dual drivers.
  8. tastycaramel

    tastycaramel Guest

    For me, the S4 earphones were quite decent. At least better than the ones that came with my iTouch.
  9. trparky

    trparky Well-Known Member

    I never did like earbuds. How can such tiny little speakers produce any decent sound? I'll take my big Sony MDR-XB500 headphones any day of the week. Those things sound great when connected to this phone.
  10. tastycaramel

    tastycaramel Guest

    I have a similar pair of sony headphones as yours. :D
  11. NZtechfreak

    NZtechfreak Well-Known Member

    To the OP - I would definitely try and have the stock buds replaced initially, there shouldn't be crackling with the stock buds.

    With low input impedance IEMs there is indeed a very major problem with the i9505 headphone output as detailed here.
  12. tastycaramel

    tastycaramel Guest

    It is strange how I don't have such problem with my earphones.
  13. steve1401

    steve1401 Well-Known Member

    Thanks for the feedback everyone. I intend going to the tmobile shop today to see if they can help, if not I'll call them and see if they can send a different set.

    Cheers
    Steve
  14. tastycaramel

    tastycaramel Guest

    Hopefully it works :D
  15. NZtechfreak

    NZtechfreak Well-Known Member

    What are your earphones?
  16. stereoeclectic

    stereoeclectic Well-Known Member

    I also switched from the stock headphones. My other set works well.
  17. MISS DIVA

    MISS DIVA Well-Known Member

    If you get no joy with T mobile (nightmare company) contact Samsung. They swiftly replaced my dodgy Note 2 charger . All they needed was my IMEI number
  18. steve1401

    steve1401 Well-Known Member

    Good thinking. Did you call our email them? I get a bit bored of explaining myself on the phone. ..
  19. MISS DIVA

    MISS DIVA Well-Known Member

    I called, it was swift and painless unlike T mobile... Who seem hell bent on testing my last nerve.
  20. tastycaramel

    tastycaramel Guest

  21. steve1401

    steve1401 Well-Known Member

    Tmobile shop couldn't help, they said I need to call them, so I did and I'm getting a new set of earphones sent out. If they're just as bad I'll call Samsung - wish I'd done that to start with now.
  22. tastycaramel

    tastycaramel Guest

    Hopefully your new set works
  23. steve1401

    steve1401 Well-Known Member

    Yep, me too. I'll report back in a few days when they're here.
  24. tastycaramel

    tastycaramel Guest

    Sure :D
  25. NZtechfreak

    NZtechfreak Well-Known Member

    Well then it's not strange at all, the stock ones aren't low enough impedance for it to be a problem.

    In any case, reports coming in now that the latest German firmware has fixed the problem.

Share This Page