Vibration problem after ICS update [GT-I9100G]Support


Last Updated:

  1. Madaro

    Madaro Active Member This Topic's Starter

    Joined:
    Nov 10, 2011
    Messages:
    38
    Likes Received:
    0
    A couple of days ago,I flashed the official indian ICS ROM for I9100G with odin...but there's a problem,vibration doesn't work after rebooting...and the only way to make it work again is to keep rebooting a random number of times then goes away again after more reboot(s).I've tried the 3 official ROMs(Indian,French and Malaysian) all got the same problem.Even after flashing CM9,the problem is still there...I told codeworkx(a CM developer if you don't know about him and he's the 1 who made CM9 for both S2 variants) about it but he has no idea how to fix it.There are other people who got this problem but it seems that the majority don't have it..I reverted back to gingerbread to see if its a hardware problem but the vibration was working well...Any help ?
     

    Advertisement
  2. uaeboo

    uaeboo Member

    Joined:
    Jun 30, 2012
    Messages:
    7
    Likes Received:
    0
    Has anyone found a solution to this, ive been having the same problem, and have been complaining on the i9100G xda forums since weeks and still no go. At first i thought my motor fried, but i just reverted to 2.3.6 from cm9 and its working fine.
    HOW IS NO ONE ELSE GOING THROUGH THIS?
     
  3. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,240
    Likes Received:
    20,547
    Don't quote me on this, but I think vibration is turned off by default in the ICS updates ... or something in the update turns it off. I think you have to re-enable it for it to begin working correctly again.
     
  4. uaeboo

    uaeboo Member

    Joined:
    Jun 30, 2012
    Messages:
    7
    Likes Received:
    0
    Doesnt it switch on from the drop-down notification? ive tried that, nothing happens. I read some where that A solution is to put it on vibrate and restart the phone, that works for some apparently, not me.
     
  5. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,240
    Likes Received:
    20,547
    Go to menu>settings>sound and see if the vibrations are setup properly.
     
  6. uaeboo

    uaeboo Member

    Joined:
    Jun 30, 2012
    Messages:
    7
    Likes Received:
    0
    Vibration intensity: all full
    Silent Mode: Vibrate
    Everything ticked under system.

    Anything im missing?
     
  7. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,240
    Likes Received:
    20,547
    Vibration can also be enabled or disabled at the app level which will override the system settings. Check any apps that get notifications.
     
  8. uaeboo

    uaeboo Member

    Joined:
    Jun 30, 2012
    Messages:
    7
    Likes Received:
    0
    Updated to ICS 25 mins ago from 2.3.6. No apps installed other than the stock ones. Any suggestions if a stock app could be doing this? i couldnt find any that would be.
     
  9. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,240
    Likes Received:
    20,547
    Email, SMS, freinds, etc. all can set individual vibration profiles.
     
  10. uaeboo

    uaeboo Member

    Joined:
    Jun 30, 2012
    Messages:
    7
    Likes Received:
    0
    Checked and double checked, nothing. Also did a factory reset, still no vibration/haptic feedback.
     
  11. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,240
    Likes Received:
    20,547
    I'm outta gas with this one. Hopefully someone else will be able to help you. Sorry.
     
  12. uaeboo

    uaeboo Member

    Joined:
    Jun 30, 2012
    Messages:
    7
    Likes Received:
    0
    No problem, thanks for trying though. Ive been at it for weeks now. Eventually i might have to give it in at samsung, i dont know if they'll help with me running a cm9.
     
  13. uaeboo

    uaeboo Member

    Joined:
    Jun 30, 2012
    Messages:
    7
    Likes Received:
    0
    Anyone have ANY ideas. I dont want to revert back to 2.3.6 just for the vibration, cm9 is amazing. Im desperate.
     
  14. btfan

    btfan New Member

    Joined:
    Jul 16, 2012
    Messages:
    3
    Likes Received:
    0
    I have the exact same problem on stock ICS firmware with the I9100G as well. Never had this issue with GB. The only way to get fix it is to keep on rebooting the phone until the haptic feedback work again. I have tried up to 5 reboots before it works again.

    I'm starting to think it could be a bug inherent in the firmware.
     
  15. LNG4GOLF

    LNG4GOLF New Member

    Joined:
    Oct 3, 2012
    Messages:
    1
    Likes Received:
    0
    Similar issue with similar results. Only difference and solution I've been able to find at this point is (via youtube user video suggestions) is to go to settings>sound> and cycle the options (on mine it's Off/Vibrate/Mute). The first time I cycled through the options twice and the vibration reactivated. At some point it stopped working again and has not corrected after doing the above again.

    No solution found as yet. Anyone find anything else? Any firmware update changes/improvements fix this???
     

Share This Page

Loading...