1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Video guides, tests and previews for Geniatech devices


  1. gio965

    gio965 Well-Known Member

    Hi all, I thought to open a new thread where everyone can post his own videos
    (preview of the latest firmware, tutorial for a new application, tests and solutions
    to various problems) and where it will be easier and less dispersive to find them.
    I add my last video that shows how, easily, we can root or unroot our device,
    using z4root vers.1.3.0

    Here is the link to app: MEGAUPLOAD - The leading online storage and file delivery service

    and video: Root Permissions on Geniatech ATV1000 (z4root and Superuser) - YouTube

    Please, any reply inside main thread "Geniatech Enjoy Tv"

    Advertisement
    :
  2. gio965

    gio965 Well-Known Member

    A new video that shows how to do, easily, a complete backup of our device using MyBackup Pro.apk
    You can download it from Android Market or (if you have not access to Market) you can try to search it,
    typing inside the google search bar: MyBackupPro.apk

    Here is the video: Complete backup on Geniatech ATV1000 (home, bookmarks, data and apps) - YouTube

    Please, any reply inside main thread "Geniatech Enjoy Tv"
  3. gio965

    gio965 Well-Known Member

    Hi all, I realised a new video where I show how to connect easily (without any setup)
    our android device to PC using WiFi File Explorer PRO vers.1.5.0
    (even though the name, the app works greatly both in wireless and ethernet connection).

    You can download it from Android Market or (if you have not access to Market) you can try
    a search, typing inside google bar: WiFiFileExplorerPro.apk (appname.apk)

    Here is the link to video: Easy File Transfer between ATV1000 and PC - YouTube

    Please, any reply inside main thread "Geniatech Enjoy Tv"
  4. gio965

    gio965 Well-Known Member

    Hi all, I made these two following videoguides to show how to get more apps from Android Market.

    I had already explained, step by step, how to do here: http://androidforums.com/google-tv/408166-geniatech-enjoy-tv-20.html#post3990926
    ...but I thought that it could be more interesting to show, visually, all passages.

    The first videoguide shows how to get those apps (as for example: facebook and tweetdeck)
    missing due to lack of right permissions: Full Access to Android Market: permissions trick (Geniatech ATV1000) - YouTube
    This is the link to folder, that I called "full_permissions", which gathers many more
    permissions than original: full_permissions.zip


    ------------------------------------------------------------------------------------------


    The second videoguide shows how to get those apps (as for example wealth tv)
    missing due to a not performing fingerprint: Full Access to Android Market: fingerprint trick (Geniatech ATV1000) - YouTube
    This is fingerprint to use:
    ro.build.fingerprint=verizon_wwe/htc_mecha/mecha:2.3.4/GRJ22/206244.9:user/release-keys


    Please, any reply inside main thread "Geniatech Enjoy Tv"
  5. gio965

    gio965 Well-Known Member

    Hi all, in this videoguide I show how to install and update Android Market,
    on a rooted device without Market installed.

    You need rootexplorer (or similar) and these files:
    GoogleServicesFramework.apk, Vending.apk, Vending_3.3.12.apk

    (You can download them here: market_installation_and_upgrade.zip)
    You will install 3.3.12 Market that, in a short time, will update to latest 3.4.4

    Here is the video: Android Market Installation and Upgrade to 3.3.12 version (Geniatech ATV1000) - YouTube
    Please, any reply inside main thread "Geniatech Enjoy Tv"
  6. meggiedude

    meggiedude Well-Known Member

    @ gio965
    Hi, just to point out - the Megaupload link does not work, since the US gov got their hands on the Megaupload guys. A new upload link would be very appreciated. Thanks. :cool:
  7. gio965

    gio965 Well-Known Member

    Hi meggiedude, generally speaking, if you need an app you can find it, easily,

    writing in google search bar: nameapplication.apk

    Try, and you will get your link to z4root.apk from Mediafire...;)
    meggiedude likes this.
  8. meggiedude

    meggiedude Well-Known Member

    Cheers dude
  9. gio965

    gio965 Well-Known Member

    Hi all, if you should have problems to apply permissions and fingerprint trick to your device, I can suggest this alternative procedure, tested and fully working on latest 2.3.4 release (20120111).

    I have previously described all passages here: http://androidforums.com/google-tv/408166-geniatech-enjoy-tv-21.html#post4048466

    This is the link to videoguide:Permissions and Fingerprint trick: alternative procedure for any release (and device) - YouTube

    Edit:
    *For more working apps, you must add this missing file: com.google.android.maps.jar
    to "framework" folder in: /system/framework and change its permissions to rw-r-r
    *For more compatibility, I suggest to use this new fingerprint line:
    ro.build.fingerprint=google/passion/passion:2.3.4/GRJ22/121341:user/release-keys
    (from 2.3.4 Nexus One)
    *More fingerprint lines here: Google Nexus One - OpenGL ES performance and system information
    *If your market release is 3.4.4 or superior, you must remove this file: android.hardware.nfc.xml
    from "permissions" folder in: /system/etc

    ------------------------------------------------------------------------------------------------

    *Even if tested only on ATV1000, this procedure should be working also on any other android device


    Please, any reply inside main thread "Geniatech Enjoy Tv"
  10. webcris77

    webcris77 Member

    Hi, i need this UI app, anyone can share it?
  11. gio965

    gio965 Well-Known Member

    Hi all, in this video, I show how to modify, easily, an android Rom.

    You need Java installed, on your PC: Download Free Java Software

    Winrar or 7-zip, and Update.Zip Manager 3.0:
    (new working link): http://www.mediafire.com/?7j9z6c75mycqll3
    (from xda-developers): http://forum.xda-developers.com/showpost.php?p=29432097&postcount=271

    Here is the link to the video: How to modify an android Rom (Update.zip manager 3.0) - YouTube

    Full appreciation to Daneshm90 for his script.

    Edit:
    This is the link to the first post in "Geniatech Enjoy Tv": http://androidforums.com/google-tv/408166-geniatech-enjoy-tv-23.html#post4170694
    This is the link to developer's thread in "XDA": Update.zip 2.0 Modifier/Creator [Script] Drag/Drop Support [Windows] - xda-developers

    If you have difficulties with the creation of the update.zip file, you could solve changing
    Heap Size value from 512mb to 1024mb (option 5: Set Max Heap Size) and using
    an older, slow PC (I successfully use a Pentium III, 1000MHz, 512MB RAM and Windows XP sp2 installed)



    Please, any reply inside main thread "Geniatech Enjoy Tv"
    enviro8, vikidroid and sku|| like this.
  12. gio965

    gio965 Well-Known Member

  13. grindinonyourm

    grindinonyourm Well-Known Member

    hello gio965! im a big fan of your work! i have a question for you though...your integrated samba.apk and associated files , do they allow for logins to NAS samba shares like in 2.3.4 samba.apk? cos so far i can't get into my network shares because they all have passwords and ICS never throws up a need user/pass window at me like gingerbread did...what do you think?
  14. gio965

    gio965 Well-Known Member

    Hi grindinonyourm, I can't give you any answer because I have not a NAS device
    over network and I can't test this kind of configuration...
    You could try to install Cifs.apk and a file manager like Astro.apk
    (you can find them, freely, in Google Play Store)...but I don't know
    if you will have the right results.
    However, it's also right to say (as already referred by other users), that video streaming
    is more smoothly with Gingerbread than with ICS...so, probably, you should prefer GB if
    your device is used, above all, for it.
    I use ICS, mainly, for web browsing and it's really great.
  15. grindinonyourm

    grindinonyourm Well-Known Member

    i installed cifsmanager and astro..works pretty well...still not as good as samba.apk...what i meant was that my NAS is a samba server...So are the shares on my windows machines...and with your samba.apk integration, the username/password box never pops up so i cannot enter my login info for samba.apk. on GB, samba.apk opens a dialog window for username/password on secured windows shares.
  16. gio965

    gio965 Well-Known Member

    The samba.apk in full-patched ICS release, was not made by me (I'm not a developer), but by Geniatech
    in an update firmware released on 20120426 (named by them, always, as update20120420).
    I could suggest to try the samba.apk from update20120111.zip (it has different dimension)
    and verify if it can work more properly (you can find it, unzipping update20120111, in: /system/app).
    Save this file into your usb pendrive and plug it to your device --> using rootexplorer, go to: /mnt/sda1 and copy it --> go to: /system/app --> rename inbuilt samba.apk (for example as samba.apk1) and paste this
    GB samba.apk --> give the same permissions of the inbuilt one.
    As just told, I haven't any samba device so I can't test if, in this way, it opens
    a dialog window for username/password.
    Try and let us know.
  17. grindinonyourm

    grindinonyourm Well-Known Member

    so i discovered that the samba integration is fine if it is compiled by geniatech...because they compile the boot image that creates init.rc on the root of the drive. init.rc is where you would start the /system/bin/smbd service for samba sharing to work right on ICS. but if i run your upgrade samba package, it doesn't work, because starting the smbd service never happens...i verified by going to terminal and doin a su , then a smbd start and suddenly i got my username popup that i wanted...i can log into share and browse...but then it won't play in the media player once i have selected a movie. so question is, how to make smbd start at system start without adding anything to init.rc. FYI, init.rc is overwritten at every boot from init.rc that is hidden inside uimage.
  18. gio965

    gio965 Well-Known Member

    I will make some research and if I have results I will inform you.
    In the meantime, I would suggest the following update package posted by gboijhpok and made by Geniatech (few days before the latest update20120420.zip with samba.apk integrated): http://androidforums.com/4272292-post1217.html
    Try to install it, and verify if it works better...
  19. kwuw4sale

    kwuw4sale Member

    Guys I have been here just for a day or so and really am impressed with the "quality" of the contributions are all making here.

    I do have one question related to singing the zip files (hopefully its not misplaced here).
    It seems that at a certain size of the zip file every approach I try fails.

    I have about 150 MB or so of apps that I wanted to include in the latest firmware 0529:

    - using update.zip manager 3.0 if the zip is bigger than 150 MB it just quits after deleting the update_old.zip (and without creating the signed update.zip), it works fine for smaller sizes.

    - signing the files manually using the JAR class finishes without errors but I get "verification failed error" when attempting to reflash.

    - singing the files using "dsixda's Android Kitchen" also fails in similar fashion to the manual JAR (with a verification failed error message on updating).

    Your insights are aprriciated.
    Tanks,
  20. gio965

    gio965 Well-Known Member

    Hi kwuw4sale, after various trials I have found a solution...

    Pratically I solved using an older, slow PC (Pentium III, 1000MHz, 512MB RAM and Windows XP sp2 installed)

    and changing Heap Size from 512mb to 1024mb (option 5: Set Max Heap Size).

    Just for testing, I added more than 160MB of apps in the latest 20120529 ICS firmware.

    All perfectly working, also after installation.
    kwuw4sale likes this.
  21. kwuw4sale

    kwuw4sale Member

    Thank you for the reply gio.

    Actually it didn't work for me, but it pushed me to check further and correctly directed me to the solution.

    When you pointed its related to the heap size, and I noticed that I can't catch any errors thrown by the script, I did revise it to remove all the "cls" so I can see whats happening.

    Java crashes as it goes out of memory, this should be fixed by increasing the heapsize as you correctly pointed up to a certain size (max size 1.5GB on 32 bit Java installation).

    Now the problem is it didn't work for me because I went further an decreased the APK compression level to 0. Which made the script run super fast but the resulting zip was about 400MB.

    Pumping the heap size past 1.5GB crashes the script as it goes past 1.5GB, I remembered you mentioned the script working on an older P2 PC, it came to me that my issues might be related to running 32bit Java JRE on a 64bit Win7.

    Solution was to install 64bit Java JRE, set the compression level to 0 (from 9) and the heap size to 2048MB.

    Worked like a charm, thanks.
  22. avirex

    avirex Well-Known Member

    Hi guys.

    I took kwuw4sale's advice and I'm using the 64-bit JRE on my laptop (which has 64-bit Windows 7).

    I am not getting any errors during the compression or signing but for some reason the device is not recognizing the update.img file. It also is not giving me any error except System Update Aborted.

    Any ideas?

    Some screenshots:

    [​IMG]

    [​IMG]

    [​IMG]


    Thanks for any help...
  23. avirex

    avirex Well-Known Member

    Hi Gio.

    I was able to get it working, using a different PC. Not sure why mine didnt work, but anyway I was able to build the ROM using your instructions. Thanks for those.

    I am having trouble with Google Play. Whenever I open any app in Google Play (just to see details of the app) it crashes. Here is the log from logcat. Have you seen this before?


    E/AndroidRuntime( 716): FATAL EXCEPTION: main
    E/AndroidRuntime( 716): java.lang.NullPointerException
    E/AndroidRuntime( 716): at com.google.android.finsky.utils.Nfc$GingerbreadMr1NfcHandler.setPushMessage(Nfc.java:150)
    E/AndroidRuntime( 716): at com.google.android.finsky.utils.Nfc$GingerbreadMr1NfcHandler.onResume(Nfc.java:138)
    E/AndroidRuntime( 716): at com.google.android.finsky.activities.DetailsDataBasedFragment.onResume(DetailsDataBasedFragment.java:158)
    E/AndroidRuntime( 716): at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:917)
    E/AndroidRuntime( 716): at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1080)
    E/AndroidRuntime( 716): at android.support.v4.app.BackStackRecord.run(BackStackRecord.java:622)
    E/AndroidRuntime( 716): at android.support.v4.app.FragmentManagerImpl.execPendingActions(FragmentManager.java:1416)
    E/AndroidRuntime( 716): at android.support.v4.app.FragmentManagerImpl$1.run(FragmentManager.java:420)
    E/AndroidRuntime( 716): at android.os.Handler.handleCallback(Handler.java:587)
    E/AndroidRuntime( 716): at android.os.Handler.dispatchMessage(Handler.java:92)
    E/AndroidRuntime( 716): at android.os.Looper.loop(Looper.java:130)
    E/AndroidRuntime( 716): at android.app.ActivityThread.main(ActivityThread.java:3683)
    E/AndroidRuntime( 716): at java.lang.reflect.Method.invokeNative(Native Method)
    E/AndroidRuntime( 716): at java.lang.reflect.Method.invoke(Method.java:507)
    E/AndroidRuntime( 716): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
    E/AndroidRuntime( 716): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
    E/AndroidRuntime( 716): at dalvik.system.NativeStart.main(Native Method)
    W/ActivityManager( 135): Force finishing activity com.android.vending/.AssetBrowserActivity
    W/ActivityManager( 135): Activity pause timeout for HistoryRecord{40644338 com.android.vending/.AssetBrowserActivity}
Loading...

Share This Page