[Virgin Mobile] just rooted and flashed my new s3...now no mobile data?


  1. droiddekka

    droiddekka Well-Known Member

    hey guys, just ditched my evo and got the s3.


    i am trying to run AOKP (preferably 4.2) and cannot get any mobile data 4g love.

    i odin'd the mg4 stock rom and am using Philz recovery.

    so i'm showing an MG4 baseband...is that the one i want? also which modem do i need to be using? are modem and baseband the same thing?


    out of the box this phone was an MD7.

    how do i choose and/or modify an AOKP rom to make the 4g happen? if you can point me to a tutorial or any information i'd be greatly appreciative.

    Advertisement
  2. nathan75

    nathan75 Active Member

    Go to system setting, data usage may sure mobile data is on.
  3. droiddekka

    droiddekka Well-Known Member

    Yes I have done that. Mobile data preferences are set to cdma/lte/evdo
  4. droiddekka

    droiddekka Well-Known Member

    Also, I did not accept the OTA 4.3 update when I first got the phone. There is no Knox msg when the phone is in d/l mode
  5. upconvert

    upconvert Well-Known Member

    You need to flash one of MopedRyder's APN patches:
    http://androidforums.com/showthread.../MMS FIX [WIP][CM/AOSP/TW] (Update 2014-1-18).

    #2 and #3 work perfectly, will give you mobile data, and will allow you to send and receive MMS using hangouts.
  6. droiddekka

    droiddekka Well-Known Member

    Ok I'll get on that immediately. Thank you sir
  7. droiddekka

    droiddekka Well-Known Member

    do i need to modify the apns_conf.xml file myself or does that mod do that for me?


    i flashed the mod along with a couple of different md4 roms and so far no love.
  8. evo5droid

    evo5droid Member

    Are you on Virgin mobile USA? In all I've read in these forums and the sprint forums, there is no mention of MG4 baseband. We nee more info.


  9. droiddekka

    droiddekka Well-Known Member



    that's my bad, i'm sorry


    i am on virgin mobile US


    aaaand my baseband is currently MD4



    the APN fix from step 2 WORKS!!!! kinda...the com.android.phone process FC's alot when i first boot up. i've tried adjusting different roaming and network modes but i am seeing decent 4g speed after it settles down.


    also...when i go to check those mobile data settings i get asked to "complete action using:" and am presented with 2 identical copies of the "network settings" (blue phone icon)

    ^^that kind of suggests that i have a rogue duplicate maybe causing this problem...where does that process live? can i delete the duplicate with root explorer?




    also...i solved the mms problem by restoring a copy of my old 4.2.1 inverted mms app...if anyone wants me to post it up let me know.
  10. Tokens210

    Tokens210 Well-Known Member

    On almost all Roms you'll see for our device mopedryders fix and a non stock message app seem to be required, on stock based or stockish ones u can get a way with default messanger sometimes but for most of us on non stock usually cm based roms we use the fix plus an app like Google hangouts, handcent, evolve SMs or chompsms have all been reported as working for both texts and SMS with almost nothing else needed
    droiddekka and struckn like this.

Share This Page