[Virgin Mobile] Samsung Galaxy Victory ROM files, app2sd

Last Updated:

  1. connorb89

    connorb89 Active Member

    Hey there I heard something about how I might need a new ROM for my Galaxy. It is a rooted device. On my HTC One V had the ability to move apps to my external sd card. I would go through app info and move to sd.
    So is the a ROM like the htc one that will allow me to transfer apps to the external sd card????

  2. Tejer

    Tejer Well-Known Member

    So far I believe there are no additional roms for this device. But, g60madman is currently in the process of developing CM10.1 for this device! I am not sure if that will be a feature or not...

    I am pretty certain there are other ways to achieve this, but nobody has gotten back with me yet on how to do it.
    connorb89 likes this.
  3. connorb89

    connorb89 Active Member

    Hey thankyou.
    Ill look to see when he has finished thr ROM!
    I downloaded a random rom for a samsung galaxy s3 through rom manager. the app with the top hat.
    It had me reboot my system and whole deal but it looks exactly the same, the rom i downloaded is called clockworkmod 2.x.x.x
  4. Tejer

    Tejer Well-Known Member

    That rom you are referring to is actually a recovery, not a rom. So it didn't change anything on your phone :)
  5. connorb89

    connorb89 Active Member

    Damn well I'm still pretty new to this whole deal and am still struggling with well what tto do on my rooted device. besides tethering, which is awesome with a virgin mobile plan.
    But how does Rom manager work, and when do you think I'll be able to move apps.
    Also have you head of Directory Bind?
  6. JacobK254

    JacobK254 Well-Known Member

    Rom manager is used to install recoveries and to download and install roms. I'd be careful using it though, it has a history of breaking Virgin phones.
  7. Tejer

    Tejer Well-Known Member

    True, and there are no roms for our phone so anything you'd download would be a different phone or the Sprint version which would break MMS and maybe more.

    To break down using Rom Manager, here is a fortune cookie quote:

    "Use Rom Manager for your rooted phone!" ~Said no dev ever.
  8. connorb89

    connorb89 Active Member

    So would S3 roms work on the galaxy victory?
    And do you know of any roms that would work on transfering app2sd?
  9. Tejer

    Tejer Well-Known Member

    No, the s3 roms will not work. Even if they do boot, you can bet everything will be broken. Just hang tight until g60madman or another dev releases something, that's really your only option. I haven't gotten any app to SD to work. I'm waiting for a guide to be posted.
    TheBritton and connorb89 like this.
  10. connorb89

    connorb89 Active Member

    so did anyone come up with the ROM that can get app2SD to work?
  11. TheBritton

    TheBritton Resident Galaxy Cat

    Since this thread seems to be focused on the Virgin Mobile Victory, I'm gonna move this over to the Virgin Mobile All Things Root Section. I seemed to have overlooked this when moving things over when the All Things Root section was split between Virgin Mobile and Sprint. I apologize.

    Anyway, Tejer is absolutely right. Please do not try to install roms for the S3 onto your Victory. That will be a big mess! :) To answer connor's question, right now there are no roms that allow moving apps to sd. You can follow all of the action for Virgin Mobile at (Virgin Mobile) Victory 4G LTE - All Things Root - Android Forums which will include any new roms for the phone :D
  12. insanelycool

    insanelycool Well-Known Member Contributor

    I have gotten an app2sd type solution to work for this phone so here I am registering on the forum to share. I also want to thank you guys for the info about ROM development as that was how I found this thread to begin with.

    Starting with the obvious the storage space on this phone is lacking, but with my solution here I have managed to install everything I want onto the phone and still have about 500MB of space left... I should probably clear some cache or factory reset and start from scratch but haven't had time.. anyways, onto the solution!

    The program you will want is Link2SD (directorybind didnt work for me and caused more trouble than it was worth). Here are my tips on Link2SD.

    First of all you will probably need an adapter for your micro SD so that you can put it into your computer (not while its in the phone, but directly).
    You will need to format and make a second partition (don't worry you can backup for files drom the SD and move them back when you are done).

    Full instructions here (How to install and USE Link2SD / Read below for my tips for the galaxy victory 4g LTE).
    First of all I used the ext4 file system and it works great.
    Secondly, you don't need to go crazy on the size of the 2nd partition like I did. I'm only using 1.1GB of 10GB on my 2nd partition right now... I would say 2GB would be more than enough, but if you have the space you could go with more... 3GB seems like overkill though as it links files, so some data goes on internal (thus I have 500MB of free space. If I were to fill up the internal memory with linked apps I'm pretty sure I wouldn't break 2GB... but maybe go with 2.5GB to be safe. or 3.. your choice... just don't do 10GB like I did, its a waste!
    MAKE SURE YOU HAVE A FAST CARD! I have a class 10 32GB SD card and it works great.
    Other than being able to use ext4 about 2-3GB in size, follow the directions to the T and it will work!

    A few more tips... use Either titanium backup or use ROM Toolbox (like I do; I have pro version and not sure if you need it to back up app settings) to backup the data from TouchWiz home (in case the homescreen loads faster than the partition and you lose your homescreen layout)... its annoying but it has happened on rare occasions like if I pull the battery. It doesn't always reset the homescreen but it has happened. It just makes the icons on homescreen get reset because the partition loaded after it, the apps are still there. Read on for my tips that have prevented this from happening to me again (knock on wood).
    MAking Boot faster:
    First of all you can use ROM Toolbox or Autostarts (i like this app and bought it years back; so this is the one I used) to ween down on the apps at startup, this will help boot times go faster so that the mount happens quickly). The other KEY APP to use is free called Rescan media ROOT (this will stop media files from being scanned at startup and they will only scan as needed / usb debugging needs to be on when you first run the app to disable media scanning). Rescan media root helps a lot with startup speed.

    Thats it! enjoy having space on this phone! it's great once you can stop worrying so much about running out of space!

    Can't wait to try out the rom when it's finished too! Although I really am enjoying the touchwiz interface on stock. way better than my old phone. Almost dont need a custom rom, but I know the phone would be faster with a good custom!
    babagua, JacobK254 and dibblebill like this.
  13. insanelycool

    insanelycool Well-Known Member Contributor

    Just a quick update... I now have 1.2GB of free internal space... have actually installed more apps since my 500MB number in the above post. All I did was moved the google play music folder (where it saves and caches music) to the extsdcard, and created a symbolic link from the original internal space in the data/data/com.google.andriod.music/files/music to the original folder which I moved to the extsdcard. Different partition types and all, but it's working flawlessly. In fact these symbolic links should work for other folders that are bloating up, like game data files that you can't otherwise move.
    I'm using the root browser of "ROM Toolbox Pro", just to clarify... in case this isnt working with other root browsers. I know for a fact that "ES File Explorer" wouldn't even let me past the first data folder because it showed as empty even though there are plenty of other folders there.

    I'm going to consolidate all this space saving goodness (with full instructions) into a thread of my own later on, but have some entertaining to do shortly... I will be posting it soon (best laid plans...lol).
  14. Darfman

    Darfman Member

    I used External 2 Internal. With this you can switch the two storage locations, so everything installs to your physical SDCard by default and you have the internal storage under the "extSdCard" spot.

    With root, I simply went to settings (it prompts you to when it first opens) and clicked the green download arrow in the top right corner. It populates more options under the "Choose the configuration" section, and I chose "Asus Transformer" from there. Under "Set Custom Infos" I checked the "Use per default", set "The original internal mounting point" to "/mnt/sdcard", set "The original external mounting point" to "/mnt/extSdCard", and set "The ext. sdcard device access" to "/dev/block/vold/179:33". Then just hit back, and I just clicked on the "External > Internal*" button, checked "At boot **" and clicked "At boot if init.d enable!". I'm not sure if you have to click the last one... And then I rebooted to confirm everything worked.

    If anyone needs pictures or better instructions, feel free to ask.
  15. Franzferdinan

    Franzferdinan Member

    The above is confirmed working for me
  16. samusishere

    samusishere Active Member

    I tried this it says "/dev/block/vold/179:33" is not a valid device block?
  17. Darfman

    Darfman Member

    Dang...Maybe try the following. When in the External 2 Internal setting menu, scroll all the way down to "View the different devices" and click that to load a list of mounts on the device. There is a "bold" text in each entry that is the mount, and then a smaller text below each that is the type. Look for all the ones with the type "fs : vfat". Of those, there should be at least one that is "/dev/block/vold/[sum number]:[another number]". If there is just one formatted like that, use that one, if there are multiple, just try each one until it works.

    Also, you might just be getting that message when you select your default configuration (of the three options at the top of the settings) which I found don't seem to effect how it functions. Or at least, I don't know why it is flashing the message.

    Let me know! Thanks.
  18. Krazy Kirby

    Krazy Kirby Member

    When downloading the app from google play on the device, it almost immediately claims there is insufficient storage, yet larger apps install just fine, any idea as to why this is?
    EDIT: Directory Bind does the same thing when trying to install.
  19. Darfman

    Darfman Member

    I do not have this issue, so our setups must be different in some way. I know these questions will make it look like I'm looking down on you or something, but I promise I am not, just data collecting. Did you set up External 2 Internal the same way I did? Is it set for each boot? Are you running any other filesystem manipulation apps or scripts?

    I have not use Directory Bind, and I'm probably not going to since I got my phone all up and running how I want, so I can't help on that end.
  20. Krazy Kirby

    Krazy Kirby Member

    Can't even install External 2 Internal, keep gettin' the insufficient storage message on every attempt to install either app. SD card has two FAT32 partitions, and I'm not aware of any other filesystem manipulation apps on the device.

    EDIT: seems alotta other apps that require root in with KB filesizes get the same issue
  21. Darfman

    Darfman Member

    o_O!? I have no clue, if you have tried uninstalling other apps for room and other apps work just fine, I have no idea what could be the problem here.
  22. Krazy Kirby

    Krazy Kirby Member

    Okay, after several hours of messing with settings I got it installed and mostly working, but it wont auto start on boot, have to go into the app each time and press External > internal.

Share This Page