Visson ATV-108 f16ref new firmware - 20120807


  1. stane1983

    stane1983 Well-Known Member Developer

    Changelog:
    - google apps updated (Play Store instead of Market, system stuff, servicesframework etc...)
    - youtube is installed by default to userspace area (version 4.0.8)
    - more languages in LatinIME
    - Chinese and Japanese input methods (as requested)
    - Bluetooth (BT dongles, Visson ATV-108 doesn't have BT module integrated)
    - DVB-T drivers and firmware files for some devices, DroidTV app for watching DVB-T can be downloaded from Tools section on my download page
    - 1080 resolution fixed, no more flickering and OSD is positioned right
    - Stock Browser issue solved
    - Ethernet issue solved
    - Flash seems to work much better (full screen on filmehd.net, crashes only if 2 or more flash videos on same webpage - that's what I noticed)
    - kernel fixes
    - Amlogic apps and my Vplay Networking translated to Croatian, Catalan and German thanx to guys from androidforums :)
    - All drivers available for USB cameras in kernel integrated
    - All my previous changes + some other stuff I forgot to mention

    Firmware can be downloaded from V-Play download section under Firmware - rev 2 platform (f16ref) section

    Regards

    Advertisement
    :
    NecroStylery, gamajunior and JerzyEx like this.
  2. j2k

    j2k Member

    Hi,

    I downloaded this firmware, my board is f16ref. Haven't flashed it yet.
    Can I replace the hosts file in the update.zip without having any problems? This will block most of the annoying ads.

    Big thanks to your work. Can't wait to turn my ATV into something better!
  3. stane1983

    stane1983 Well-Known Member Developer

    You should not have problems by replacing hosts file as far as I know... :)
    j2k likes this.
  4. NecroStylery

    NecroStylery New Member

    Hi, I'm new with Android devices and I'm trying to root a Google TV device.

    The link of the Box is: dx.com /p/gv-10-android-4-0-multi-media-player-w-wifi-hdmi-usb-sd-lan-black-4gb-142439?item=7

    I tried to update the firmware to this new one, but I couldn't use SU command.
    Have you some step-to-step tutorial?

    If my questions are ridiculous, please sorry, but I'm learning about it yet.
  5. stane1983

    stane1983 Well-Known Member Developer

    Hi,

    your device is ATV-108... But make sure it's f16ref (m3)..

    Fist, go to V-Play download section and download DeviceChecker to make sure you have f16device. Copy it to usb stick and install it via AppInstaller. If it says f16ref, from my page you download f16ref (rev 2) firmwares, if it says c03ref, you download c03ref (ver 1) firmwares.

    On page firmwares are sorted by date with newest on top. Download ZIP package and extract all files from zip archive to SDCARD. Insert sdcard in device, go to Upgrade application -> Local Upgrade -> select /sdcard/update.zip file and press next -> Reboot device and install upgrade.

    You don't need to have superuser to upgrade your device (my firmwares are built from Amlogic sources, and installed as official Visson ones).

    When you install my fw, if you want to use Superuser, before you have to open Superuser app and click Okay on changelog window. Before that su will not work.

    Note: Make sure to install correct firmware (c03ref/f16ref). If you install wrong firmware on f16ref.... it's little tricky to get it working again...
  6. NecroStylery

    NecroStylery New Member

    Hi,

    thanks for your tutorial. I managed to install.
    Now the system is rooted.

    Thank you.
  7. nammen

    nammen Member

    Hi,
    I have this

    https://plus.google.com/u/0/114673951529684128760/posts/XY3fLjf3kFd

    I have upgraded the box with yours firmware and now the led is green but the screen is blank.

    I have done the upgrade with reset procedure, and I have done two times, but the result is the same, black screen.


    any solutions?

    thanks!

    Nunzio

    p.s. sorry for my english
  8. stane1983

    stane1983 Well-Known Member Developer

    Hi, your device is Refee AML8726M3 device (f16ref), but my fw is not working on that device. I would suggest you to contact your seller to send link to latest firmware for your device. After that, try to install it. If unsuccessful, PM me with the link to fw...
  9. Pdevil70

    Pdevil70 Member

    Hello,

    Very good work.

    I have installed this revision and couldn't run cifs manager properly.
    It's missing some modules like cifs.ko, to cifs manager or mount manager to work properly.

    Link2sd can't recognize the second partition on sd.
    First is fat32 and the second is ext2 now (I have try ext3 and ext4)
    Both partition are primary and the first one is active.

    Is this a problem with 4.0.4 Android?

    Best Regards
  10. stane1983

    stane1983 Well-Known Member Developer


    Hi,

    There are no cifs modules, cifs support is built into kernel image and it's implementation is done that way it doesn't need root access (see V.play networking app).

    about multiple partitions on sdcard, will investigate...
  11. j2k

    j2k Member

    Same problem here.
    Is Refee AML8726M3 device (f16ref) different from the atv-108 rev2?
    Is it possible to 'cook' ROMs for this device?
  12. j2k

    j2k Member

    Same problem here. :mad:
    Is Refee AML8726M3 device (f16ref) different from the atv-108 rev2?
    Is it possible to 'cook' some ROM for this device?

    Actually, I found my device is this one:
    ATV-102
    http://goo.gl/58XGg

    notice it only has CVBS composite output (not YPbPr) to old tv sets (besides HDMI of course)
    and 4gb internal RAM.
    Anyway, link to firmware is unavailable, so I contacted Vission thru email.

    here's the full specs
  13. stane1983

    stane1983 Well-Known Member Developer

    Hi,

    right now I'm confused myself... :) Have to check with Visson, seems ATV-108 rev2 (f16ref) is renamed to ATV-102...

    Will have that info on Monday probably.
  14. Pdevil70

    Pdevil70 Member


    Hello,

    I use cifs manager to play videos from my network, with MX Player.
    This is the only player that uses the hardware acceleration to decode videos through network. I have try almost every one.

    So, my question is, is there any way to mount a network share, like cifs manager does? Or there will be modules for cifs manager, to work properly with ICS and ATV-108?

    Another issue with this firmware, if I put the device to standby, with remote controller, I have to turn off the power, and back again to get it back in action.

    Best regards
  15. stane1983

    stane1983 Well-Known Member Developer

    Errr..... have you actually tried using V.play networking? When share is created in V.play networking, you click on it, content of shared folder will open in FileBrowser and for movie reproduction you can use either stock player or any other player... V.play networking is replacement app for cifs manager.

    On next reboot of device, V.play networking needs to be started first to mount saved network shares.

    Mounted network shares are mounted to /NetShares, symlinked to /mnt/NetShares and can be accessed like any other local file.

    About power on/off issue, aware of the problem, working on the solution.
  16. Pdevil70

    Pdevil70 Member


    Yes, I have try V.Play Networking, but no results. Says "Error mounting share. Please check your configuration."

    I started with "scan...", and selected one of the list, put the login and password, and nothing.
    Did "Add share..." and the same result.
    Had try with ethernet and wi-fi, same result.

    Finally, I flashed the firmware again. Did all over again and the result:
    "Error mounting share. Please check your configuration."

    The IP is correct, the share is correct, login and password too.

    Any ideas?
  17. stane1983

    stane1983 Well-Known Member Developer

    Do you have perhaps spaces in your password? :) If so, try changing your password..... It's a bug which needs to be solved... :)
  18. Pdevil70

    Pdevil70 Member

    I have 2shares through unbuntu:
    One in a ntfs partition and other in ubuntu partition (ext4)
    I can mount the ntfs and can not the ext4.

    I made a 3rd share in a win7 notebook, it worked perfectly.

    Does it have anything about the file system?
  19. j2k

    j2k Member

    So stane, did you check if it's really ATV-102 ou ATV-108?
    My unit is not totally bricked I think

    1) Normal 'boot', both led's dont flash, no TV output.
    2) reset+Boot, led flash and card is read but TV-OUT is scrambled. Haven't checked hdmi output yet but I can distinguish some screen being updated.
    I was using a SDHC 8Gb card. Will try with a 1Gb tonight. I'll post feedback later.

    Btw, where can I get Visson 'official' ATV-108 firmware? Company website is a total letdown for me...:mad:
  20. stane1983

    stane1983 Well-Known Member Developer

    Your SDHC is the problem. Try to use smaller non SDHC card (2 Gb or smaller if possible). Scrambled screen means bootloader is not damaged, but flashing firmware went wrong and bootloader cannot read boot logo which is stored on NAND chip.

    Latest official firmware afaik is ICS.MBX.20120629. Go to Google TV subforum, topic Android 2.3 & 4.0 WiFi Internet HD 1080P HDMI Google TV Box ARM Cortex A9 Firmware and find my post (don't know on which page) with link to firmware, it's posted on same date as firmware was released - 2012-06-29.
  21. j2k

    j2k Member

    Tested yesterday with a 1Gb card. Used SDTool (u-boot-aml-ucl.bin used in SDTool has to be from official firmware right?) then unziped files to card.
    reset+boot and same problem with TV-OUT scrambled. I really got to connect the box toa HDMI screen so I can see what's going on... :(
  22. j2k

    j2k Member

    As I said on the 'main' thread, I successfully applied this firmware using a 256Mb card.
    Here's my 1 evening test results:
    - UI really responsive, mega fast
    - WiFi connects in just seconds
    - CVBS video output quality has improved (well at least to my perception)

    So far, only one letdown: video playback, no matter what the source is, is really poor, with low fps (skips frames, I guess).

    Oh and I'm using TV-OUT, btw.

    Thanks again Stane for this 5* ROM. :D
  23. j2k

    j2k Member

    Got some feedback from Vissiontech and I will further investigate on the CVBS output issue. Something to do with output mode. :smokingsomb:
  24. j2k

    j2k Member

    Stupid guy here (yes, me...) didn't notice was using 1080p setting on a CVBS output! :p
    Setting==>display==>output mode should be 576i or 480i.
    Now this box is 100% awesomeness!:D
  25. fay81

    fay81 Member

    Hi,
    can anyone help me?
    I think, my Visson ATV-102(f16ref) android box is totally bricked.

    I have followed these procedure:

    1. Download your firmware files (RAR archive) and unpack all files to root of your sdcard
    2. Insert your sdcard in your box
    3. Start Upgrade application on your device and choose Local Upgrade
    4. Select file update.zip and on next screen select Reboot And Install Package
    5. After upgrade is completed you will be back to Android Recovery System. You might see some errors such as invalid parameter or error writing mac address. Ignore that, just unplug your device from power and plug it back in to boot Android (first boot takes some time)

    After Step 4 has my device rebooted and hung at A9 screen. I waited 10 minutes and i unplug it from power and plug it back.

    Now following behavior:

    1) Normal 'boot': both led's dont flash, no TV output.
    2) reset & Boot: led dont flash and no TV-OUT.

    Can someone tell me how I can force my device to boot from SD-Card or is the bootloader damaged? :(
Loading...
Similar Threads
  1. Gavilaaar
    Replies:
    4
    Views:
    1,636
  2. amg_1969
    Replies:
    33
    Views:
    6,713
  3. adriann
    Replies:
    196
    Views:
    22,742
  4. Vap1d-
    Replies:
    37
    Views:
    3,720

Share This Page