Visson ATV-108 f16ref new firmware - 20120807

Last Updated:

  1. j2k

    j2k Member

    hi, do you have access to a HDMI input TV? If so, use it so you can follow update process.
    When flashing on boot use the following:
    - with power off insert card with 256mb and all the files from the zip stane has released
    - press reset button don't release it, and while pressed, plug-in power
    - only release reset after led's flash 3 times.
    - wait update process

  2. fay81

    fay81 Member

    yes, i have access to a HDMI input TV. But the problem is, that the LED's are no longer flashing.

    I press reset button and hold it, then i plug-in power but nothing happens neither TV output nor LEDs Flashing :(
  3. j2k

    j2k Member

    please post pics from the box.
    Did you check if it is f16ref or c03ref?
    Firmware - rev 1 platform (c03ref)
    Firmware - rev 2 platform (f16ref)
  4. fay81

    fay81 Member

  5. j2k

    j2k Member

  6. Pdevil70

    Pdevil70 Member

    I am experimenting all kind of video files, and it is common in all of them little pauses during the film. The films don't play smoothly, as in a computer.

    I using MX Player. I have try a lot of them, and I find MX Player very interesting, because of configurations possibilities.

    Can video playback be enhanced?
  7. stane1983

    stane1983 Well-Known Member Developer


    working on that...
  8. miguelazo

    miguelazo New Member

    i have this atv android tv too and my problemns is with netflix andoid app...

    they screen turn off (but not sound) when i streaming some film from netflix..

    about firm:

    Vissiontech MBX 2.0 Board
    Android ver: 4.04
    Kernel: 3.08
    Build: ICS.MBX.20120629

    some version of netflix that its ok ? please
  9. Kantoku

    Kantoku Member

    Hi stane,
    Thanks for the ROM - I installed it on my box (different than the atv-108 but definitely f16ref), and it works great. However, both yours and the original ROM have an issue with the ethernet not working. According to my adb logcat, it would receive DHCP settings correctly, but then disconnect. If I look at the back of the machine where the ethernet lights are, when it disconnects, the lights go off for a bit, then come back on, and the process is repeated forever. However, if I hook it up to my laptop, the lights stay on forever (without giving an IP), so I'm assuming it's not a hardware problem.

    I was wondering if you had any idea what the issue could be? Has anyone else had this issue?
    I also heard that ethernet on ICS with a 2.6 kernel could be troublesome. Is there a version that has a 3.0 kernel?

    Thanks again for the ROM. Can't live without root :)
  10. stane1983

    stane1983 Well-Known Member Developer


    Ethernet seems to be a problem with new Amlogic sources for f16ref board. I tried to fix it but it works only partially. On Visson f16ref works but low performance... at least it works for me...

    Wifi is now my priority, I'm working to fix wifi issues on f16ref and realtek 8192cu based wifi modules.... Wifi module is actually good one, but implementation is not.

    About 3.x kernel, forget about it (at least officially)... m1 and m3 boards stays on 2.6.34 kernel. M6 boards (MX - dual core) will have 3.0.8 kernel. That's confirmed by Amlogic's employee.
  11. Kantoku

    Kantoku Member


    As far as I can tell, the error of interest is:
    Caused by: /proc/net/xt_qtaguid/stats: open failed: ENOENT (No such file or directory)
    A quick google search tells me that its a kernel module that is missing. Any way we can get that module included in the current kernel version, or maybe somehow create dummy files with appropriate content? Just to get the errors to go away. I'm willing to help any way I can.
  12. j2k

    j2k Member

    Yesterday my wifi just refused to connect. Didn't change a thing on the router and now the ATV does not even 'see' my home network. SSIID is not hidden.
    And it's working on channel 14.
    I can see other (private) networks though...:mad:

    Btw, is there any 'safe' way to power off ATV-102 (aka 108)? :confused:
    I use Quick Reboot wich has a power off widget.
  13. j2k

    j2k Member

  14. fay81

    fay81 Member

    i tried with a 1GB SD card, but no success.
    SDTool has not helped, because boot to Recovery mode is not possible!
  15. stane1983

    stane1983 Well-Known Member Developer

    Are you sure you copied all the files to sdcard? Usually when upgrading and you're stuck at boot logo screen, uImage_recovery is missing or cannot be accesed for some reason (sdcard?) by bootloader.
  16. j2k

    j2k Member

    Of course this means that I ditched the standard remote (useless!!!) and bought a wireless mini keyboard.
    That's why I use a software power off procedure.
  17. j2k

    j2k Member


    There seems to be some kind of bug using remote mini keyboard driver. I can only use it if theres another usb port in use. (ext hdd)
    Very strange...
  18. Pdevil70

    Pdevil70 Member

    Yes, I do have this issue too.
    I can't play 1080p files from ethernet, but I can play them from wi-fi.
    Another issue came across, when I am in wi-fi mode, my wireless keyboard stops working.
    Can you help me with this?
  19. j2k

    j2k Member

    Do you have an ext pen/hdd connected? Try switching the usb port where wireless receiver from keyboard is connected with the ext hdd
  20. Pdevil70

    Pdevil70 Member

    Yes I do have a hdd connected. I switched but it is the same.
    I tried every channel in my wireless router and it is the same.
    The wireless keyboard just stop working, when in wi-fi mode.

    Will be improvements in Ethernet connection?

    I do have a cable installation in my home, and I would like to use it.

    By the way, congratulations this is a very nice ROM.
    I think that this hardware is not well implemented, don't you think?
  21. stane1983

    stane1983 Well-Known Member Developer

    !!! For f16ref users only !!!

    Hi to all,

    I need testers for ATV-108 rev2(f16ref) / ATV-102 for new firmware.

    - Wifi driver updated to latest Realtek sources
    - added 3G dongle support
    - Upgrade app replaced with Upgrade (under development; only Local upgrade works)

    For all of you who had wifi issues with f16ref, please report if this firmware solves the issue.

    Firmware can be downloaded from here.



    There are USB issues with latest Android sources, working on that too...
  22. j2k

    j2k Member

    Hi stane,
    Ready to try newest firmware. Should the upgrade be local through upgrade app or using reset and boot?
    Eager to test wifi, wireless keyboard, 3G dongle and DVB-T.
  23. Pdevil70

    Pdevil70 Member

    :( Hello,

    The incompatibility with wi-fi and the wireless keyboard remains.

    I have try several channels for wi-fi, and keyboard always stops working.

    As I have a cable net in my home, will the performance of Ethernet be improved?

    Many thanks,
  24. mzamudio

    mzamudio New Member

    I checked the device and it showed f16ref like you said.

    This is my device:

    Media Box Google Android TV 4.0.4, ARM Cortex A9 1.2GHz, DDR3 1GB Ram, 4GB Flash, HDMI HD TV 1080P Wifi Internet Set-Top Box Media Player Black

    Now, the device is stuck in "", help me please, what can i do to repair it?

Share This Page