1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Vista won't see phone or SD cardSupport


  1. dkaufman1

    dkaufman1 Well-Known Member

    I am having issue with Vista wanting the CD or driver for Android. It won't plug and play nor even see the device as a drive letter for copying files to and from the SD card. Anyone else? Any solutions?

    Advertisement
  2. honugirl

    honugirl Active Member

    ya im having the same problem im going to reformat my sd card and c if that will do anything:eek:
  3. dkaufman1

    dkaufman1 Well-Known Member

    I got some SDHC cards from Woot (4gb - $6) and was very excited and they also cause the same error. (1gb included does too.)
  4. porquepine

    porquepine Well-Known Member


    Well, guess it is a good thing that I just fixed up an IBM T41 laptop and put XP Professional on it. Hopefully that will mean that I will not be screwed. :rolleyes:
  5. jimczyz

    jimczyz Well-Known Member

    Try going into menu/settings/sd card & storage and mount your sd card. See if that helps, I hyave vista on 4 pc's and a laptop i my house and have no problems at all. The phone itself will not show as anything, just the micro sd card as a removable device.
  6. cawwt

    cawwt New Member

    Get rip of that Vista garbage then you will have no more troubles. The G1 should behave as a mass storage device when plugin to a usb port. I have no problem using it in a Mac or Linux Machines. I heard XP is fine. But Vista sucks.
  7. dkaufman1

    dkaufman1 Well-Known Member


    I appreciate your help. When I go into the menu with it connected to the PC the "Unmount" option is grayed out.

    Also when I connect the device, the PC recognizes it as an HTC Android Device and wants the drivers. It does not recognize the drive,card at all.


    To the other flamers - hey I have vista, let's move on.
    donformica likes this.
  8. shivers316

    shivers316 Godmember VIP Member

    I wish I could help. Which version of Vista are you running? I'm running 32 bit Vista Home basic and I'm having no problems.
  9. dkaufman1

    dkaufman1 Well-Known Member

    Same vers as you.
  10. shivers316

    shivers316 Godmember VIP Member

    Having you tried formatting the card through a card reader first and then putting it in the phone?
  11. Cryptic79

    Cryptic79 VIP Member VIP Member

    Works on Server 2003.
  12. dkaufman1

    dkaufman1 Well-Known Member

    Ok I have a T61 (Lenovo) that does not recognize the card in the device. I also have a sleeve and card reader and it does not recognize that either (and tries to look for drivers for the card reader (which works for other cards)

    I have an acer that sees it as expected...I just tried that. (same OS!) I guess I will just use that machine (annoying but better than beating my head against the wall.) I even was able to get the SDHC 4gb cards to work on the Acer. I like that a machine that was a 1/3 of the price works better. Serves me right.
  13. On your phone go to Settings, then Applications, and then Development. Unselect the checkbox for "USB debugging", Connect the phone to your computer and you should receive a notification on the phone that says "USB Connected". Select to Mount and you should be able to see the contents of the SD card on your computer.

    If that doesn't work try these drivers:
    http://dl.google.com/android/android_usb_windows.zip
    faizj likes this.
  14. Mbobeczko

    Mbobeczko Well-Known Member

    Problem: Getting the G1 to mount as mass storage device to Windows VISTA; When windows can not find the driver.

    TRY THIS FIRST

    Solution found here - http://teknobabble.wordpress.com/20...ems-installing-a-usb-media-reader-a-solution/

    To get vista to look where you want to for the driver after you follow the steps at this link.
    Right Click Computer/ Properties/ Device Manager/ find the device with the question mark next to it right click and Update Driver software.
    Browse / and point windows to search in C:\Windows\inf

    ONLY TRY THIS AFTER YOU TRY THE OTHER. (borrowed from the poster above.)

    Additional Info - If for any reason the first link dosent work try this. On your phone go to Settings, then Applications, and then Development. Unselect the checkbox for "USB debugging", Connect the phone to your computer and you should receive a notification on the phone that says "USB Connected". Select to Mount and you should be able to see the contents of the SD card on your computer.

    If that doesn't work try these drivers:
    http://dl.google.com/android/android_usb_windows.zip
  15. noonehereyet

    noonehereyet No One... VIP Member


    I had Vista up until this week had CONSTANT issues including this one... for some reason what worked for me was plugging the usb in to the phone then removing the end connected to the computer and re-connecting it... Then it would run the search for plug and play.... the funny thing is I could still charge it either way so I know the connection was valid.... I switched to Ubuntu 8.4 as yesterday.... recommend you either down grade to XP or another operating system that works at least until the verdict is in on Windows 7
  16. dkaufman1

    dkaufman1 Well-Known Member

    Followed all these steps in order...got the zip file and installed the HTC Dream drivers...but the device is still not listed after refreshing the drives list.
  17. Teknobabble

    Teknobabble New Member

  18. alexisstirrat

    alexisstirrat New Member

    YAY I found it! On another forum I found this solution, and after hours of trying everything, this finally worked:
    I restarted (with the phone unplugged, of course), then started hitting F8 as it rebooted. It took me to a menu screen where I clicked disable device signature requirement (or something similar, that's not it exactly) then it restarted perfectly, and IT WORKED! I am now transferring music files to my phone! YAY GOOD LUCK!!!
    (You do have to hit mount on the phone, still)
  19. KinGuiN

    KinGuiN New Member

    Permanent solution(tested ok, I didn't even need step 2, prolly because this was before Donut was released publicly...):

    To connect an Android phone to a Windows PC, usually there are two steps:
    1. Uninstall current Android USB drivers
    2. Install new correct Android drivers

    You accomplish 1 by downloading USBDeview to your PC here is the URL USBDeview - View all installed/connected USB devices on your system
    Then unzip it and run USBDeview. Right click on each Android driver and delete it

    You accomplish 2 by going here Android 1.6 SDK, Release 1 | Android Developers
    and downloading the whole Android SDK (software development kit) onto your PC. Extract it to a folder so you can look inside and find a sub-folder called usb_driver. Either move it somewhere easy or take careful note of it's exact location.
    Now go to your Android phone. Open Settings. Touch Applicatons. Touch Development. Tap USB debugging to enable it. Then back out to the home page.
    Connect your phone to the PC via the appropriate USB cord. Windows will open its New Hardware Wizard. Check that you will tell Windows where to find the files, and Browse to the location of the usb-driver folder. OK will ungrey and if you click it, the correct drivers will, at last, be loaded.
    Almost finished. Now disconnect the phone, and repeat going to Settings>Applications>Development. Tap the debugger again to disable it. Back out to the Home Screen. Now connect your phone to the PC. It will be recognized, but in order to see and manipulate the SD card files, there's one more step. Pull down the little white bar at the top of the Android Phone screen. You will see a Notification "USB connected". Tap it and you will be given an option to Mount the phone. Touch Mount.
    Now the any File Manager (Windows Explorer, etc.) will see your phone SD card as a separate drive. You can copy, move delete, whatever.
    Quite a process, but once done, all you will have to do is connect the phone to the PC and pull down and Mount it.

    (source)

    Grtz,

    -=KinGuiN=-
  20. fender5184

    fender5184 New Member

    For my Motorola Droid- I used the technobabble approach but used the android winUSB file instead of the usbstor.inf folder. Quick fix worked perfectly:


    1. Go to C:\Windows\System32\DriverStore\FileRepository



    2. Find file folder named android_winusb2.inf_f669... (your ending may vary)


    3. Copy the file named android_winusb2.PNF


    4. Now go to C:\Windows\Inf


    5. Paste the file copied, android_winusb2.PNF.



    After doing this, my Android phone enable me to mount the phone from the notifications panel like it would do on XP without even having to restart. Worked like a charm! Vista will ask for your permission to copy system files, this method does not cause any problems, don't worry! Also, don't "fix" the card if Vista prompts you to, just skip that step. I would imagine that might reformat the card, or something of the sort. Not sure about that.



    Thanks AndroidForums!! I've been looking for a solution for this issue for awhile!


    -Mike- new forum member.
  21. bcuzicn

    bcuzicn New Member

    I have a Apad (don't know the manufacturer) and I am having a terrible time trying to download a driver for my Windows Vista. I've downloaded the SDK application file and tried your solution but I'm at a loss. Is there someone who can help me, please? :confused:
  22. faizj

    faizj New Member

    Dear All,
    i was facing the same issue..PC not recognizing phone/device/card, so couldnt transfer data between PC and Phone..
    PC:Windows vista 64.

    the solution is to SELECT "ALLOW MASS STORAGE ON USB"..this shall enable the preinstalled PC driver software on fone to install itself on PC and finally u'd be able to see that the phone is recognized in the PC..thanks to several of u for the suggestions that led me to finding out how to get rid of the issue..
  23. crz6662

    crz6662 Active Member

    Re-installing drivers got me back up and running. Vista is a pain in my ass.

Share This Page