Visual Example: The PB00IMG.ZIP update method


  1. erisuser1

    erisuser1 Well-Known Member

    My purpose behind this "a picture is worth 1000 words" thread is twofold:

    1) For newbs that experience some trouble(s) getting the inital stages of "getting root" to happen correctly, it is helpful for them to know what things should look like when everything goes the way it should. That makes it much easier to recognize it when something goes wrong.

    2) Make it very clear when to do the "battery pull" if you are interested in only installing the S-OFF bootloader (and nothing else) using Toastcfh's "battery pull trick".

    In the first image below, the Eris has been restarted by simultaneously pressing the Vol-down and End (power) buttons, and a PB00IMG.ZIP file has been placed in the root folder of the SD card:

    [​IMG]

    If the "PB00IMG.ZIP" file was not found on the SD card, the list of files shown above would flash across the screen and disappear very quickly - less than one second. If this is what you experience, there are a couple of possible reasons why this might have occurred:

    1. There is no file named PB00IMG.ZIP in the root folder of the SD card
    2. You put the file there, but misspelled the name
    3. The SD Card needs to be re-formatted **
    4. The SD card is "questionable" - replace with a "beter" card **

    ** I never experienced these problems with the Verizon-supplied SD card, but other folks have reported that this solved a problem where they were sure the file was present in the root folder, but apparently was not recognized.

    The important thing to point out here is that the PB00IMG.ZIP files are large - as much as 100 MB. Merely reading the file to compute a checksum or crypto signature from a flash device takes many tens of seconds: if the file is found by the phone, it will spend some time chewing on it. If you see the above list of files (in green) flash by and nothing happens, then it is absolutely clear that the phone did not "find" the file - for whatever reason.

    In the image above, we see that the phone is reading the file, as indicated by the blue progress bar in the upper right-hand corner of the screen. This process takes a fair amount of time - perhaps as much as a full minute.

    Note that the HTC crypto signature is over the whole zip file (excluding the first 256 bytes); at this point, the phone is simply checking that the .zip file has the correct crypto signature - it is not even unpacking the zip file (yet)

    In the next image, the phone is beginning to unpack the zip file into separate components: the crypto sig check has succeeded, and the phone says nothing exceptional, other than "Checking"

    [​IMG]


    In the next image below, the phone presents a list of images that are in the PB00IMG.ZIP file. The list shown only tells you what the function of the image file is, but does not display the exact file name in the .zip file. (Unpack the PB00IMG.ZIP yourself on your PC if you are curious).

    The phone also asks you if you "Do you want to start update?".

    NOTE: This point in time is extremely critical if you are going to do the battery pull method!

    Note that the second item in the list, (#2) is listed as "BOOTLOADER". What will happen if you choose to perform the update, is that the new bootloader from the PB00IMG.ZIP file will be flashed right away. This sort of makes sense: it is the new bootloader that is responsible for installing all the other new images in the PB00IMG.ZIP file.

    The bootloader is quite small - about 512k bytes - so it flashes onto the phone very quickly. As soon as this finishes (less than one second after you start the update), the phone screen will go dark, indicating that a reboot is in progress.

    IF YOU INTEND TO USE THE BATTERY PULL METHOD, YOU NEED TO BE PREPARED FOR THIS MOMENT, WITH THE COVER ALREADY OFF THE PHONE - YOU'LL HAVE 3-4 SECONDS BEFORE THE PHONE REBOOTS AND BEGINS TO CONTINUE WITH THE REST OF THE ROM FLASHING. YOU CAN PULL THE BATTERY AS SOON AS YOU SEE THE SCREEN GO DARK. (The remaining steps shown below will not occur if you pull the battery.)

    Toastcfh on XDA was the first to suggest this method; it is especially useful if you want to create a backup of your "factory" 1.5 system.

    [​IMG]


    The photo images used for this documentation were taken from a manual upgrade of 1.16.605.1 to 1.17.605.1 (MR1 to MR2 update on Cupcake). Both of those updates use the exact same (S-ON) bootloader, so in the pictures which follow, we won't notice a difference in version numbers or appearance of "S-OFF" at the top of the screen. But if we were doing the "root" PB00IMG.ZIP upgrade, we would see the new version number and also "S-OFF", as the new bootloader would be "live" at this point.

    In the image below, (following the reboot) we see what appears to be a complete repeat of what we saw at the beginning of the process: it appears as if the .zip file is being unpacked all over again, complete with the blue progress bar showing in the upper right hand corner of the screen:

    [​IMG]


    Again, we see the "Checking" message (below). But rest assured, the update process has been launched, and will continue without prompting until the end. Don't let the fact that you are seeing a repeat of these same screens you saw earlier throw you - that is normal. And again, since the file involved is large - 100 MB - it takes a little while for the phone to chug through these steps.

    [​IMG]


    Now the updater lists the (functional) contents of the PB00IMG.ZIP file, and starts the update process without stopping to ask permission. Note that the bootloader is no longer mentioned (in item #2, or anywhere): it was already installed!

    [​IMG]


    When the flash memory is being written, the progress bar in the upper right hand corner of the screen will display in red (as shown below)

    [​IMG]


    If the updater is merely unpacking an image file (within the .zip file), the progress bar will show up in a black color as shown below. (This will be most apparent for large images such as the "system" image)

    [​IMG]


    When the update is complete, the system will pause and ask you if you want to reboot. (In the case of the root PBOOIMG.ZIP update, the new S-OFF bootloader is up and running at this point, so if you wanted to toggle it in to fastboot mode and flash Amon_RA's recovery image, you could do that.

    [​IMG]

    That's what it should look like! Hope this is useful to someone.

    eu1

    Advertisement
    :
  2. LexusBrian400

    LexusBrian400 Well-Known Member

    This could really help new people wanting to root. Immediate vote for Sticky.
  3. jreed2560

    jreed2560 Well-Known Member

    +1 or atleast incorporated with the other rooting stickies with full credit to you.
  4. cloudedice

    cloudedice Member

    I started trying this, but got cold feet when bootloader was listed as 6 instead of 2.

    My list:
    [1] USERDATA
    [2] SYSTEM
    [3] RECOVERY
    [4] RADIO_VZ
    [5] BOOT
    [6] BOOTLOADER

    I'm running 2.1 OTA and saw a couple of threads saying that 2.1 could be rooted using the 1.5 instructions. I thought the battery pull method might also be an option to backup the phone before going through the full root process.

    Anyone know if the battery pull method works with 2.1 OTA?

    ETA: I got brave (or stupid) and tried it. The bootloader loads first and then it immediately reboots. It seems like this works for 2.1 OTA as well. I'll finish the process after lunch.
  5. Rossco_Pee

    Rossco_Pee Well-Known Member

    Very nice write-up sir.
  6. cloudedice

    cloudedice Member

    I was able to use the battery pull method to successfully back up my eris. After pulling the battery I skipped the rest of these instructions and just followed the original from Toastcfh.

    One thing to note on my 2.1 OTA run through, using the phone to run the backup did not work. Instead I had to execute nandroid-mobile.sh -b from the adb shell. BART didn't work from phone or adb shell.
  7. erisuser1

    erisuser1 Well-Known Member

    The photographs in the original post were taken on a phone that was undergoing an upgrade from OTA-1.5(1) (the December '09 1.5 update) to MR2. You are correct that the order of the listing appears different going from a 1.17.605.1 phone to the root-ROM, but that is an innocuous difference... as you found out.

    I've been through this process multiple times on my phone, where I restored completely back to 1.5, re-burning everything including the bootloader (& radio images), and then rolled forward again to a rooted phone - it works in exactly the same sequence. Just be sure to wait until the screen goes dark before you pull the battery. I have never waited much more than 3 or 4 seconds, so I wouldn't encourage people to wait very long after the screen goes dark, although there is no reason to panic over whether you do it in 2 seconds or 5 seconds.

    Note that doing the battery pull trick only changes the bootloader. It does not touch the Radio image, so, a stock 1.5 phone which has been upgraded to a 2.1 (non-HTC) ROM via the battery pull hack will be slightly different than a OTA-2.1 phone which is rooted.

    If these details are important to you, check this XDA thread to see how the different paths to 2.1 - rooted ROMs might vary in regard to Radio (& NVRAM!) images. Since you started with an OTA-2.1 phone, you should already have the latest radio image.



    I'll throw in one more variation, just for giggles, as if things were not complicated enough already: you can actually do a Nandroid backup without ever installing Amon_RA on the phone so long as you have the S-OFF bootloader in place:


    Just boot into fastboot mode on the phone (after you have installed the S-OFF bootloader), and then (from the PC) do a

    fastboot boot recovery-RA-eris-v1.6.2.img

    ( md5sum: e3932991f097993602af3c7a4b61a4f8 recovery-RA-eris-v1.6.2.img
    this only works when you have an S-OFF bootloader )

    Note that doing this allows you root access to the phone via adb to the Amon RA recovery boot, even though the Amon_RA recovery has not been flashed to the recovery partition.

    I'm not sure how useful that really turns out to be, but the ultra-paranoid could conceivably even make a back up their old recovery partition by using the "dump_image" command.

    eu1
  8. erisuser1

    erisuser1 Well-Known Member

    I've only used the Nandroid backup, so I don't know exactly what to expect from BART But to be cautious, boot the phone into (Amon_RA) recovery, and then log in to the phone via adb and do a

    # more /cache/recovery/log

    to see if you see any strange errors. If you see something that gives you some indigestion, post it up here an I'll have a look at it.


    eu1
  9. cloudedice

    cloudedice Member

    I'll take a look later. Now that I've got my phone rooted and Ivan's 1.0 ROM installed I'm going to play around with it for a while and try to get wireless tethering working.
  10. erisuser1

    erisuser1 Well-Known Member

    I used the 2.0.1-pre1 (CM-5.0.6 ds - quckfix) version from
    Downloads - android-wifi-tether - Project Hosting on Google Code
    ( wireless_tether_2_0-pre10.apk )
    on the same ROM, no problems.

    Some of the later revs probably work too - for as little as I have used it, I didn't experience any trouble, so I haven't updated it (yet).

    Good luck
  11. cloudedice

    cloudedice Member

    The problem was in my understanding of how the functionality works. I expected to be able to see a wireless hotspot running in infrastructure mode, but it appears as an ad-hoc wireless network. The devices I was using to test during the day only supported infrastructure mode. After checking my laptop at home, I was able to connect and surf the web. Thanks for your help!

    Also, wireless-tether 2.0.1 stable is available from the Android Market. 2.0.2-pre9 or something is available through the link you provided, but it's not stable enough for me to run. It does have some nice additions including a battery temp indicator.
  12. cloudedice

    cloudedice Member

    Here's the portion of log when running bart.

    Code (Text):
    1. Create BART backup?
    2. Press Trackball to confirm,
    3. any other key to abort.
    4.  
    5. Performing backup : .mount: mounting /dev/block/mmcblk0p2 on /system/sd failed:
    6. No such file or directory
    7. Unable to mount /system/sd ...
    8.  
    9.  
    10.  
    11. Error : Run 'bart' via adb!
    For completeness, here's the nanroid+ext which also failed:
    Code (Text):
    1. Create Nandroid + ext backup?
    2. Press Trackball to confirm,
    3. any other key to abort.
    4.  
    5. Performing backup : .
    6. nandroid-mobile v2.2.1
    7.  
    8. Using G1 keyboard, enter a prefix substring and then <CR>
    9. or just <CR> to accept default: Accepting default.
    10.  
    11. Using - prefix to create a backup folder
    12.  
    13. mounting system and data read-only, sdcard read-write
    14. .............checking free space on sdcard
    15. ..Dumping boot to /sdcard/nandroid/HT9C1HG14265/BDES-20100528-1751/boot.img.....
    16. done
    17. Dump of the recovery partition suppressed.
    18. Dump of the misc partition suppressed.
    19. Dumping system to /sdcard/nandroid/HT9C1HG14265/BDES-20100528-1751/system.img...
    20. ...........................................done
    21. Dumping data to /sdcard/nandroid/HT9C1HG14265/BDES-20100528-1751/data.img.......
    22. ............done
    23. Dump of the cache partition suppressed.
    24. Storing the ext2(Apps, Dalvik-cache) contents in the backup folder.
    25. Warning: --ext2 specified but unable to mount the ext2 partition.
    26.  
    27.  
    28. Error : Run 'nandroid-mobile.sh' via adb!
    Standard nandroid backup works without issue, as does running nandroid-mobile.sh from the adb shell
  13. erisuser1

    erisuser1 Well-Known Member

    cloudedice,


    Both of those errors appear to be because of a lack of an ext[2|3] partition on your SD card.

    That's OK, though - just don't do a backup/restore that expects one to be there! For Nandroid, just the regular backup/restore.

    Note that everything else in the Nandroid backup succeeded - (boot.img, system.img, and data.img). If you don't have an ext partition on your SD card, then you are not using apps2sd (even if the ROM supports it), and the "ext" functionality isn't needed.

    I haven't used BART, so I don't know if it always wants an ext[2|3] partition or not, but the error that is being is certainly because there isn't one present.

    eu1
  14. thenestor

    thenestor Well-Known Member

    This guide was very helpful. Thank you for doing this.
  15. thenestor

    thenestor Well-Known Member

    I'm not in a position to do this right now, but I was thinking it would be helpful if someone could post screen shots of the other two parts of rooting: a) Installing Recovery and b) Flashing a ROM. And I still think this thread should be sticky, or at least mentioned in the other rooting stickies.
  16. JrzDroid

    JrzDroid Well-Known Member

    :DST!CKY STiCKY:)
  17. thenestor

    thenestor Well-Known Member

    Seriously, this needs to be a sticky, or at least linked from the GUIDE sticky. I'll PM a mod about it.
  18. Flames92

    Flames92 Active Member

    Aww where was this like a few days ago when I needed it xD +1!!
  19. cableguynoe

    cableguynoe Well-Known Member

    been around since early May:p
  20. daholein1

    daholein1 Member

    (Regarding post by erisuser1, Root for Dummies)
    Hey thanks so much for helping me with rooting my device! (root for dummies) I found your step by step instructions awesome! Been having fun. Can you help me with the install of the XTRrom 3.03? Have heared alot of good things about this rom. What do you think?
  21. bkleinkn

    bkleinkn Active Member

    Right after image #2 I get an error saying "Main version is older! Update fail!"

    Any idea why?
  22. erisuser1

    erisuser1 Well-Known Member

    Lots of ideas. But there would be far fewer possibilities we would need to run through if you described what you are trying to accomplish, and what state your phone is in to begin with.

    For instance: if you are trying to root, there are far easier methods than using this one - look at the Sticky posts "Universal Root for Dummies" or "Universal 1 Click Eris App Apk". Also, while those methods make this method irrelevant for rooting purposes, I'll note that you will get the error message you reported if you try to do this:

    Leak-V1, Leak-V2, or Leak-V3 bootloader (1.49.0000) -> Root bootloader (1.49.2000) OR
    Leak-V1, Leak-V2, or Leak-V3 bootloader (1.49.0000) -> any 1.5 bootloader (1.45, 1.46, 1.47)

    whereas the following two scenarios will work:

    1.5 bootloaders (1.45, 1.46, 1.47) -> 1.49.0000 OR 1.49.2000
    Root Bootloader (1.49.2000) -> ANY


    Over the past couple of days, I have advised people that were trying to restore their phones back to factory condition that they can use these instructions if they are having difficulties using the "RUU" to reinstall back to factory - the instructions for doing so are essentially identical to those given here, except that the proper ROM to start with is the Leak-V3 ROM, rather than the root ROM.


    So - what are you trying to accomplish, and what bootloader and OS is presently on your phone?


    eu1
  23. bkleinkn

    bkleinkn Active Member


    I have the Droid Eris and I want to be able to run Cyanogensmod.

    Here's what I know about the phone:

    -It's still the way I got it from Verizon
  24. scary alien

    scary alien not really so scary Moderator

    edit: wow, can't believe that I missed the posts earlier about "main version is older"...I didn't see those and would not have just merrily suggested options for rooting. Sorry 'bout that.

    You should be good-to-go. Here's your recipe for rooting:

    1) Download / acquire your ROM (your choice):

    {rom} CYANOGEN ROM 6.0.O DS RC 1 test - xda-developers

    - or -

    { cyanogen tazz v8 themed/unthemed/8/14/10/camera \gps fixed\CM6/Froyo Edition - xda-developers

    - or -

    [ROM]-[5/25/2010] CyanogenERIS v1.1 + Senseless[JIT/Overclock/Vanilla!!!] - xda-developers

    2) Root using either http://androidforums.com/all-things-root-eris/127861-universal-eris-root-dummies.html (eu1's thread) or http://androidforums.com/all-things...is-app-apk-no-pcs-no-scripts-needed-easy.html (jcase's thread); either will work wonderfully.

    As erisuser1 was pointing-out in his previous posts, the method you were trying to use is the old, original, "traditional" root method (that I and a lot of folks used). The ones above are pretty simple and work on any Eris phone, regardless of HBOOT version or Android version.

    3) Flash your selected ROM per the instructions in your selected root method

    Cheers!
  25. andrizoid

    andrizoid Well-Known Member

    ewwww. your recommended CyanogenEris?
Loading...

Share This Page