VLC Stream & Convert


  1. yuzz

    yuzz New Member

    Looks like a very cool app! I even got it working for a while, but after the last update the only things I see are the messages "Buffering" and "General Error" :(
  2. traveldevel

    traveldevel Member

    @painless:
    When you do http streaming TCP packets will be sent back from VLC to your device from the port that you specified in the app, e.g. 8081.
    In case of rtsp streaming UDP packets are sent to the device but not from the rtsp port that you have given in the app (554, 5554 etc.) but from random ports like 53505 and 53506 (for audio and video).

    @saecrow, yuzz:
    Regarding buffering errors: I'm refactoring some of the code now. If it has been working for you it will work again soon.
  3. painless

    painless Member

    hi traveldevel,

    that would explain why tunneling rtsp doesn't work. Is there any way to know what those random ports are? Is there a specific range I can just portforward like ports 53500-53600?
  4. ffigs

    ffigs New Member

    Thanks for everyone's help thus far.

    I can successfully stream over wifi, but over 3g and 4g the full stream (both audio and video) cuts out after 10-20 secs. Just to clarify, everything works perfectly for the initial seconds, then, in the notifications bar, I get the message VLC disconnected, and the stream completely stops.

    Port of the vlc server is forwarded on the router, and an exception in firewall has been made for vlc.

    Any suggestions would be greatly appreciated
  5. DroidGnome

    DroidGnome Well-Known Member

    I'm not sure what has happened, but after updating to the new EVO update, streaming over 3G no longer works (Even with the trick I posted above). It works fine over WiFI and firewall is turned off.. so no clue if something changed in the app or in Android itself that prevents it now.

    Anyone still have it working on an HTC Evo after the most recent update?
  6. valsacar

    valsacar New Member

    Anyone found a way to get it to allow multiple connections and play multiple different files at once? I tried with two phones and it went crazy and I had to restart VLC on the computer... would be great if it's possible (which I think it is).
  7. valsacar

    valsacar New Member

    Ok... this is odd, it worked just fine a few minutes ago but now when on 3G it just says buffering failed... but on wiki it's fine.
  8. traveldevel

    traveldevel Member

    @painless
    I haven't found a parameter in VLC to set these ports and the range is quite huge. There's one setting for the destination ports but it doesn't work when VLC auto creates the sdp file. You can run Wireshark on your computer to monitor the traffic and see how the ports change everytime.

    @DroidGnome
    There's a test stream but it has nothing to do with my app and the stream comes from a Darwin Streaming Server. Link #1 and #3 (port 554) should work on your device: http://spbgo.com/stest/
    Also note that in the latest release your rtsp port may have changed to 5554 because I had so many complaints. However, for streaming over 3G you probably have to use 554.
  9. valsacar

    valsacar New Member

    I have no idea what is going on now... all of the sudden it won't even TRY to bind the rtsp port (be it 554 or 5554)...
  10. Froghut

    Froghut New Member

    Hi,

    I have a problem trying to stream video to my phone wia rtsp. When I try to start a stream the vlc log shows the following:

    main error: socket bind error (No error) main error: cannot create socket(s) for HTTP host
    stream_out_rtp error: cannot export SDP as RTSP


    I don't get any audio or video - audio streaming via http works.



    I already googled it but could not find anything helpful ;/
  11. DroidGnome

    DroidGnome Well-Known Member

    Yes that was the problem... Might I suggest that future updates do NOT change user settings. It's fine to change initial settings, but it seems odd to me to change something a user had working because someone ELSE didn't.

    Either way, restoring the ports to what I set up originally works fine.
  12. reycat

    reycat Member

    Does anybody know how to setup VLC so that it starts by itself when I boot up my Mac Mini with the web interace enabled? (and Mac OS X interface disabled, if posible) :)

    I've already bought the pro version, after just using the free one for about an hour (I think it's awesome) but I don't know a word about command lines in Mac Os X :)

    myuser$ /Applications/VLC.app/Contents/MacOS/VLC --extraintf=http --http-host=0.0.0.0:8080 --http-src=http/
    [0x10021a1f8] main interface: creating httpd
    [0x10021a1f8] oldhttp interface error: cannot find any file in directory http
    [0x10021a1f8] main interface error: no suitable interface module
    [0x10021b558] main interface error: no suitable interface module
    [0x1002035c8] main libvlc error: interface "globalhotkeys,none" initialization failed
    [0x1002035c8] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
  13. traveldevel

    traveldevel Member

    You're right. Sorry for that. The app should have shown you a notification message on startup that the port will be changed. Also I checked for a special flag from an earlier version not to affect those users who manually changed their port.
  14. OnSterrDroids

    OnSterrDroids New Member

    I think VLC S&C is a great app and have been able to use it successfully both via WiFi and 3g. but when I am browsing through my folder structure, it doesn't seem to show anything within the folder when there's a large amount of folders and files within that folder (ie. 100+ folders).

    Has VLC set limits to what it will open in a folder structure?
  15. traveldevel

    traveldevel Member

    VLC has no limits :) (not sure)

    But I will put 500 or 1000 files in a directory and test again. Maybe it's a timeout issue when transfering the file list.
    So far I had no problems with browsing over WiFi but over 3G sometimes I get socket timeouts. I'm working on the file browsing right now anyway, maybe it will work for you in the next release. But for people with 10000 files per directory I cannot guarantee.
    OnSterrDroids likes this.
  16. w1p30ut

    w1p30ut New Member

    hi, installed latest update from market and vlc stream does not works anymore, through rtsp I have only audio but no video
    My device is a HTC Desire, does anyone has the same problem?

    thanks
  17. traveldevel

    traveldevel Member

    Sorry. Devices seem to behave differently. I'm developing on a Nexus One only.
    But video shall work again in the latest 1.1.0 Pro.
  18. bradwatson

    bradwatson New Member

    I just downloaded the free version of the app and love it so far but would like to know how to get fullscreen video on my Droid X. I have tried changing all the playback sizes, but no matter what I choose the video will either be small or stretched across the screen in width but only take up about 1/3 of the screen in height. If I can get fullscreen working, I'll definitely be purchasing the full version of the app. Thanks for any help!
  19. robb823

    robb823 New Member

    In order for that to work you're going to want to setup 2 different ports to forward to the pc running VLC, one for each phone. Next, you'll want to allow VLC to run multiple instances. Once thats done you should be good to go.

    Best o' luck!

    Rob
  20. Mr.Slave

    Mr.Slave Well-Known Member

    I have just gotten this setup on my Incredible and netbook running win7. All I want to do is use the app as a remote control to select files, play, and pause. I can browse all folders down to My Videos but then I open it and its empty. Same goes with My Music folder once I open it its empty. Do I need the pro version for this operation?
  21. traveldevel

    traveldevel Member

    The free version will list all files that VLC can open, except playlist files which is a Pro feature. So there may be another reason. Can you see media files in other folders on your drive?
  22. Lucidmike

    Lucidmike Well-Known Member

    Traveldevel,

    rtsp over wifi works. Unfortunately, it does not work in 3G. I noticed many people have said they are having the same problems, but it used to work with the old version.

    I an having the "buffering failed" problem. I just purchased the pro version, unfortunately that has not helped. I have tried 1.1.4, 1.1.3, and now I'm trying 1.1.2 of vlc.

    I've downloaded the vlc_stream_dual_v110_2.bat file, and edited it so that it points to the vlc.exe's location, so the batch file works.

    I've opened up ports 8080, 8081, and 5554 on my firewall.

    I've correctly set up the connection settings on my android, Samsung Galaxy so it can connect via wifi and 3g, at least to browse files and initiate the play. I know to restart the android app when i switch back and fourth from wifi and 3g. That part I figured out.

    So the wifi connects no problem, and streams over rtsp. Just wen I put it to 3g, everything looks like it is about to start the video, then it says "buffering failed". If I look at my network meter, I can see that network streaming is going on, even though the video is not playing on he android. my computer will continue to report that traffic is leaving my computer, and my android reports it is receiving 3g Data, until I do "Stop & Exit".
    Please help!

    Thanks
    ucsdmike@gmail.com
  23. traveldevel

    traveldevel Member

    Getting a "buffering failed" over 3G is a part success! ;)
    At least it means that you set up your router correctly.
    Otherwise you would get a "Cannot open [host]:[port]" message.

    But maybe you can not use port 5554 with your mobile network provider because when I tried streaming over 3G for the first time I had the same problem until I found out that I can only use port 554.

    I've just written a help page:
    Streaming over 3G | traveldevel.com
  24. lifeskills

    lifeskills New Member

    I finally got the streaming over 3g, does anyone know how to stream from an outside wireless network? Like at a friends house or at work? When I am connected to any wireless network and using my external ip, I get a buffer message, and it the play bar moves, but no picture.

    any ideas?

    thanks in advance

    Evo
  25. cgcrute

    cgcrute Member

    It's working fine for me but I can't get the audio to sync on either of my androids, I've tried sync on audio, desync -50, frame rate original, sample 44100 as suggested but it still doesn't work.

    Nexus One running Cyanogen 6 (Froyo)
    Elonex eTouch 10" tablet

    Any suggestions?

    **UPDATE: Did a clean install of VLC on the PC and all is happy!!!
Loading...

Share This Page