1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Vodafone Smart Chat aka ZTE - P752D


  1. j3zz

    j3zz Member

    Hi guys, since 4 days in my spare time I'm googling for way to root this phone. So far I've tried with :

    - Unlock Root
    - Universal Androot
    - ZhuoDaShi
    - SuperOneClick

    I've scanned phone with X-ray app - it says that phone is secured from all exploits.

    Maybe anyone here can help me ? :rolleyes:

    Phone is running under GB 2.3.6

    Advertisement
    :
  2. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    did you try the zte backdoor exploit?
  3. j3zz

    j3zz Member

  4. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    can you tell me what cpu this device has?

    perhaps more info on what hardware is in it?
  5. j3zz

    j3zz Member

    This is part of log created by srsroot :

    [HIGH]23:14:05 - Starting ADB Server..
    23:14:13 - Manufacturer: ZTE
    23:14:15 - Model: Vodafone Smart Chat
    23:14:16 - Android Version: 2.3.6
    23:14:18 - Build ID: VodafoneSmartChat-MSM7225A-V02c-Sep272012-Vodafone-IE
    23:14:19 - Board ID: turies
    23:14:20 - Chipset Platform: msm7k
    23:14:20 - Getting OffSets.. : 0x8003 0x8005 (False) [/HIGH]As far as I know It is Qualcomm MSM7225A 800Mhz processor.

    Let me know what exactly u need to know or maybe there is some good apk which can show detailed specs of my phone so I can post them here ?

    P.S. Yes, I'm noob but fast learning ;) I got some basic experience when I was playing with my old Diamond Touch. At least with CWM and mods. Rooting is something new for me but I'm not going to give up with this phone too quickly ;)
  6. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    apologies i thought i had replied to you. anyways it seems you are in the "dead zone" 2.3.5-2.3.7 was a time when there wasnt a lot of new exploits that caused android wide panic. i dont think i am going to be of much help for you honestly. my last suggestion would be t o try things like framaroot app and see if that works or maybe some more of teh lesser known root exploits :/
  7. j3zz

    j3zz Member

    No problem mate I have patience :) Thanks for reply anyway. I'm checking this forum everyday.

    App that You mention wont even start on my device - "seems like your phone is not vulnerable to exploit included in Framaroot" .
    I think I found some guy willing to help me but there is another problem.
    I need to dump boot.img from my phone. As far as I found, there is no possibility to get it from unrooted device ?
    I've tried do this manually by using busybox but all I can do is to dump /system .

    Any ideas what else I can do ?
  8. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    In order to dump the binary partitions like boot.img youll need to use dd, however, you can only use dd when you have root.
  9. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    if you wish to try a new exploit join our irc channel and i can have ya test it out. it can be found in teh sticky on this subforum :)
    j3zz likes this.
  10. j3zz

    j3zz Member

    Ok, thx, I will when I found some spare time. Can u tell me when I'll be able to catch u in GMT time ? I'm in GMT 0 time zone.
  11. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    oh dear ill just pm you the stuff then
  12. SecretSea

    SecretSea New Member

    Good morning,

    Can someone help unlock the operator and get root on vodafone smart chat (vodafone Portugal)?

    Thanks in advance,
    SecretSea
  13. j3zz

    j3zz Member

  14. devz0r

    devz0r New Member

    Hi,

    new forum member here :D, hoping to get some help.
    The story:
    I got exactly the same phone as j3zz has. I tried the tutorial that he suggested. Everything went smoothly.
    I wanted to get CWM manager on the phone but it said it is incompatible. Installed it anyway but couldn't really use it. I couldn't make a backup with it and as far as I can tell none of the options worked as they should.
    So didn't really cared about it, I was happy with ADB. I made a stupid mistake. I didn't made any backups. (except pulling /system/app) and while playing with ADB shell and deleting some useless apps from the phone, the dumbest idea came into my mind: I wanted to delete all google apps ... and I did.
    Seemed to be ok at first, but the search button stopped working. Now I wanted google back ... how funny is that? I thought pushing back GoogleQuickSearchBox.apk and GoogleServicesFramework.apk would be enough.
    Restarted phone and it stuck in a loop at the vodafone logo. Ok no worries, I pulled the battery out, put it back in, powered on, system started and now I am stuck at the "Touch the android to begin" screen.
    I searched the net for bypassing it, found the four corner stuff, but that isn't working or I missed something (touchpad is working because the android is highlighted, also I can select language, change volume and enter numbers to make an emergency call). Booted into 3e recovery mode, made a factory reset but that's it, nothing changed. I can't get ADB to work because phone stays in mass storage mode, I can't do a reflash because I don't have the stock rom, I really don't know how to boot it in fastload mode (is this FTM?) and I can't update from sdcard because of signature failure. That's it.

    I played with QPST and I made a full memory dump (?) with the download software. I don't know what to do with it, probably it's useless. I also tried EFS explorer but nvm/zte/efs folders are locked and I'm not really sure if accessing them would help in any way.

    I can't get to "USB debugging" menu so I guess ADB is ruled out. I read somewhere that it should work in the 3e recovery but it doesn't. As I already said I don't know how to enter in fastload mode (is this FTM?)
    Is there a way to modify some nv item and get ADB working again?
    Is the android safe mode good for something?
    Could you j3zz make a backup and upload it?:D Maybe I could restore it from sdcard?

    So what can I do/try?
    Any suggestion and help is appreciated. :D
    Thanks.
    (Sorry for the long story, the mistakes/language and the stupid questions/assumptions.)
  15. sandres_630

    sandres_630 New Member

    Hi, when you flash the recovery.img from other device, how did you restore the firmware? I had a problem, I root the phone and by mistake I erase sometihng in the firmware folder, do you have any Idea how can I solve this? I read that for other devices we can push the recovery.img with Odin, how can I do it for this device?
  16. luisenriquer

    luisenriquer Member

    Have somebody here the recovery.img?
    (ZTE P752D / Vodafone Smart Chat)
  17. j3zz

    j3zz Member

    A little necrodigging but might be useful for those who ****** up their recovery.img :)

    Thanks to some dude from XDA for clean ORIGINAL recovery.img for Vodafone smart Chat.

    Now it's time for "how to" :

    1. Download recovery.img Download recovery.img from Sendspace.com - send big files the easy way
    2. Install any Terminal Emulator from market
    3. copy recovery.img to root of your SDcard
    4. make sure that u have installed superuser on your phone
    5. go to terminal emulator than type :
    Code:
    su
    flash_image recovery /sdcard/recovery.img
    DONE !

    Now you can do factory reset or enter recovery mode again :)
  18. mlody_and

    mlody_and New Member

    Hi,
    I'm trying unlock the smartphone to use in other networks but first looking for clockwork recovery for this smartphone, maybe somebody could help me, please....
  19. j3zz

    j3zz Member

    As far as I know there is no custom ROM for this device. About year ago some Italian guy from XDA was talking about this but never saw one. You should check Smart Chat topic on XDA.
Loading...

Share This Page