Voice echo. Anyone else getting this?Support


  1. uktivo

    uktivo Well-Known Member

    I believe NR is only available during a call.. (mad if you ask me.. should be able to toggle it on or off). In a call, press menu and you will have the option there to turn on nr..
  2. pingpongpete1

    pingpongpete1 New Member

    Another voice echo sufferer here.
    I now have an untidy 20x40mm hole in the case - at least it was only a cheap eBay one - but judging by the reaction of callers, it's actually made the echo worse! It was worth a try anyway. Now the decision about whether it should be returned for service or just put up with not using a case. After internet problems which were probably Orange's fault, and two replacement phones being sent (very promptly) I still think this is a lovely phone.
  3. gcare

    gcare New Member

    Actually I have changed from a cheap TPU one to "Genuine Samsung i9100 Galaxy S 2 II Black Cool Vent/Mesh Case/Cover/Skin" from amazon.co.uk (sorry, can't post links...) which is quite open on the top and on the bottom (and actually looks very-very nice). Unfortunately the problem is less than before but still present :mad:
  4. biffsmash

    biffsmash Well-Known Member

    I have a cheap case from ebay which is pretty thick, and I don't get the echo issues, although I didn't with the first one I had either, so could be software or hardware? but definitely not the case or all SGS 's.

    What firmware and carriers are you all using?

    I've been on UK unbranded KE7 and KF3, Polish KG5 and now KG7. Orange and O2.

    Hope you all sort it.
  5. Aneema

    Aneema Member

    Got my Galaxy S II last week, have a case of some kind on it and was getting the same echo problems.

    As everyone has already figured out, it is to do with the mic on the top of the phone. There are a couple of simple solutions that will have it working perfectly without having to send it away or switch off NR with every call.

    You can either a) use your finger to cover the top mic on the phone. Simple and cuts out the echo 100% or do as I did, b) place a couple of small pieces of tape over the top mic, that also fixes it.

    My S II now has zero echo, has it's protective case on without holes hacked in it and nobody is getting the echo anymore. Best part, I can't even see the tape as it's covered by the case.

    Might not be the most high tech problem solve, but for a phone that is otherwise sensational, it's great.
    mybadongt likes this.
  6. whizzkid

    whizzkid Member

    Might try that. The echo is realy annoying and to have to turn NR off everytime you use the phone is a complete nonsense. Come on Samsung pull your finger out.

    whizzkid
  7. whizzkid

    whizzkid Member

    Sticking my finger over the top mic (I assume we mean the tiny pinhole mic to the right of the 3.5mm headphone jack) doesn't make any difference. Might try the tape option.

    whizzkid
  8. Aneema

    Aneema Member

    Alright, I must apologise. My simple fixes that did seem to work, don't.

    After further experimentation I am stuck in the exact same boat as everyone else. If I have the protective case on, there is an echo for the person on the other end. If I remove the case, the echo is gone and the call quality is exceptional. Alternatively, I can leave the case on and turn the noise reduction off and the echo vanishes.

    So, just like everyone else, I'm not wanting to know how to turn NR off permanently or having to go without the case.
  9. wookie_666

    wookie_666 Member

    OK this is my fix. Mught work for others.

    Take the case off and make a call. Cover the lower mic with you finger and see if there's an echo on the other end. Dobthe same with the top. Mic and the USB charging hole. Mine worked out when I covered either of these it would echo. So on my otterbox commuter case a actually took the two tabs off the USB hole and top mic hole ans enlarged the lower mic hole. This seems to have gotten rid of it almost completely. With the casemate tough case I cur the top and bottom portions of the silicone and this fixed the issue also. I can use a leather flip case and the case mate barely there case with no issues. Hope this helps.
  10. whizzkid

    whizzkid Member

    Taking the case off makes no difference with my S2. Case on or off - echo. The only proper solution for me would be to be able to turn NR off permanently.

    whizzkid
  11. wookie_666

    wookie_666 Member

    Really. That's a new one. Mines always only with cerrain cases like the otterbox commuter and the case mate tough. I have a mercuryav leather flip. and a casemate barely there which are flawless. Now after my Modding ofmy commuter the echo is nowhere to be found.
  12. whizzkid

    whizzkid Member

    Even rang Samsung and they were far from helpful. Looks like I will have to manually turn off NR every time i use the phone. Shouldn't have to be doing this.

    whizzkid
  13. masquerade81

    masquerade81 New Member

    I realized the same problem in my second day of usage. To sum up here is the outline of my problem:

    - Problem:
    There is a echo on the other side of the line. I cant hear it, but the other person I speak hears her voice within 1-2 seconds of delay
    - Conditions:
    It echoes when there is protective case, stops echoing when I take it off. It also doesnt happen on hands free mode.
    - Debugging1:
    Since there is nothing special about my protective case, I tried to elaborate the reasons. First I thought that the case is covering the noise cancelling mic, but it doesnt. On contrary, it makes it impossible to cover that area with your hand! So, without using the cover, I tried covering that mic (I dont know it is noise cancelling mic or is it even mic, but it is at the rear side of the phone near to the bottom) with my hand and uncovering it. Then I realized, when not using the protective case I was indeliberately covering that mic(?) with the fleshy part of my thumb.
    - Debugging2:
    After trying almost anything mentioned in this thread, I tried master reset the phone. But before I backed up everything.

    After Master reset, the echo was gone. So I restored the backup and echo came back with my backup :)
    Then I only made a backup of my contacts to sd, made a master reset and imported my contacts back from sd, and now it seems there is no echo now.

    - Conclusion:
    I believe the problem is not related with hardware. It is software related. At least in my case.
    Before realizing the problem I was updated my firmware to KG1, using android 2.3.3, and rooted the system. Master reset doesnt change any of these, it simply wipes of any apps you installed and restores the apps deleted with root privileges. So it must be related either related with a deleted default app, or an installed app.

    I cant recall the whole list of apps I downloaded (I downloaded too much.. really) And I dont want to restore-reset-import contacts again without knowing whether this solution is specific to me or not. But if you guys try to backup/master reset and let us know about the result, we may continue to investigate the real problem.

    EDIT:
    The phone seems to be fixed until the next reboot. When you restart the OS, the echo sure came back. Master resetted again, the echo is gone. Restarted again, echo is back. Phone is in the service now. Hope they change or fix it.
  14. Dublo

    Dublo New Member

    I also had this problem but after reading your post solved it in 2min.

    I realized the phone covers have specific openings and holes to allow the phone to collect data and info from the environment, microphones, cameras, light sensor flash and so on. After inspecting my cover I realized the one hole is blocked, manufacture of the cover defect. I unblocked the hole with a sharp object and my problem was solved. I think the hole is suppose to be for the one microphone its located next to the USB port on the lower side of the phone.

    My advice is to check that all the sensors are open and not closed or blocked by something

    I hope it helped ;)
  15. AdeleBeesley

    AdeleBeesley New Member

    Hi

    I found an interesting website whilst trying to look for an answer to this frustrating issue (its about fixing low call volume although thats not an issue i've had)

    It lets your phone enter a service mode after entering a code and there are audio options and NR (presumably noise reduction?) settings but alot of it doesnt make sense to me and i don't want to mess about with things i don't understand!

    Wondering if anyone who's more techy might be able to work it out for turning off noise reduction permanently !

    i cant post links but if you google fix for low microphone volume on samsung galaxy s II should bring it up.

    Failing that, lets hope samsung send out a software fix for turning off noise reduction!
  16. supersonicbug

    supersonicbug Member

    I found from other sites that the problem lies with the hardware where the UI Board (Part No:GH-5910949A) is faulty. I went over to Samsung today to have the part replace and it took them 30 mins to change the part. After the replacement, everything is superb. No more echo with thick or thin casing. The problem is fixed for sure.
    mybadongt likes this.
  17. Aneema

    Aneema Member

    Where did you have this done? Did you have to ring ahead and have them order in the part? Were they familiar with the issue prior to your turning up?
  18. supersonicbug

    supersonicbug Member

    Problem lies with the hardware where the UI Board (Part No:GH-5910949A) is faulty. Get Samsung to replace it.
  19. supersonicbug

    supersonicbug Member

    Aneema,
    I just walk in to Samsung service center and tell them I want a permanent fix to this issue and not containment by manually disable the Noise Reduction feature. I did not ring prior to the visit. The customer service seems to be proposing the containment but I insist a permanent fix and she approached their technician and the technician seems to know what needs to be done.
  20. supersonicbug

    supersonicbug Member

    mybadongt likes this.
  21. whizzkid

    whizzkid Member

    Sionce I upgraded firmware to 2.3.4 last Saturday my echo problem has gone away. Result!

    whizzkid
  22. Aneema

    Aneema Member

    Just upgraded mine to 2.3.4 but the echo remains when the case is on, soon as I take the case off, it's perfect.
  23. whizzkid

    whizzkid Member

    Strange? My echo was constant, case on or off. The 2.3.4 upgrade has completley solved it. No echo at all even with a case on.

    whizzkid
  24. Aneema

    Aneema Member

    I've never had the echo problem without the case, only ever when it's on. I got quite excited when I saw the upgrade fixed it for you, unfortunately it still remains for me. I'd be interested to know what other peoples experiences are like though
  25. supersonicbug

    supersonicbug Member

    Aneema,
    I believe Samsung seems to know that it is the hardware problem. Go and have it change and you can use all kinds of casing without any echo. Get it done soon before warranty expires. Beside, you have nothing to lose as it takes only 30 mins to have the part replaced.
Loading...

Share This Page