Voice echo. Anyone else getting this?Support

Last Updated:

  1. wailim1972

    wailim1972 New Member


    I have this problem too. It is so bad I feel I cannot use the phone any longer. 7 out of 10 calls I make the other person complains and eventually hangs up! I read with interest many peoples issues in the "echo" area including the debate around the type of case etc.

    My phones versions are:

    2.3.3 / I9100XXKE7 / / GINGERBREAD.XWKF3

    I now believe there are multiple causes to this issue and that I know some of them but not all of them. A definitive answer from Samsung would be most helpful and appreciated. Otherwise I am going to send this phone back and seek a non Samsung brand!

    What I discovered this Morning with the help of some work colleagues is that 4 out of 4 Galaxy S II's tested appear to have an undesirable low volume speaker phone ALL THE TIME!

    To check if your phone is affected by this piece of the puzzle do this simple test:

    1) Dial your phone from a landline or wait for a call to come in.. or indeed make a call to someone.
    2) Ensure the phone is in normal mode (not speaker phone mode) and adjust the in-call volume to max (Any setting from 2 up seems to cause the issue but lets go for the max setting)
    3) Put the speaker (not the normal ear piece now, the one from where music or speaker phone comes)... put this close to your ear as possible.
    4) Notice that you can hear the other person talking, albeit at a low level.

    So... this speaker is very close to the lower MIC and must be the source of feedback into the mic, depending on the transmission characteristics of your protective case or indeed the way you hold the phone (remember the saga over the iPhone4 antenna???).

    While all phones tested appear to have this speaker phone trait, not all tested have the echo! So there must be a software or hardware noise cancellation issue contributing (or not alleviating) the issue.

    For me, if I cup the lower part of my phone (as if to protect the mic from wind) this instantly produces the echo as my hand assists the feedback loop. If I then hold the phone up higher and keep my hand away from the mic/speaker area the echo vanishes. SIGH

    It may be that noise cancellation is working on some phones and not on others.

    But the big question on my mind is why oh why would you rely on noise cancellation software to cancel out a feedback loop that should not be there in the first place. i.e. why is the speaker phone active (at a low level) all of the time.

    And.... what is the solution SAMSUNG?

    I have posted my software version numbers above. I will get the versions of my friends / colleagues and post this as it may reveal clues ^ o &

  2. wailim1972

    wailim1972 New Member

    an update....

    It appears the sound may not coming from the speaker. It seems to be "conduted" through the phone chassis... so for example when performing the above test, put your ear close to the center of the phone battery cover; it sounds just like a speaker!

    So the question is not so much why is the speaker on all the time... its why the sound is transmitted through the phone in this manner. This means a number of factors could be influencing how badly you suffer from the 'echo':

    - The batch number or supplier used for the ear piece? Perhaps Samsung have several suppliers or experience differences between batches which lead to better or worse feedback through the phone chassis.

    - The software versions & particularly the noise cancellation settings / algorithm running on the phone

    - The protective case. Presumably hard cases make the problem worse on affected phones

    - The way the phone is held


    - Baffled!
  3. zhidrunas

    zhidrunas New Member

    Well, it appears, that mine s2 echo is made by the silicon casing, that im using. Without it there is no or very little echo on max volume. Still, it is nowhere near perfect, just a good phone.
  4. Dimkav

    Dimkav New Member

    Hi all,

    I had the same echo issue some time ago. I was looking in every forum to found an answer without success... I finally decided to go to Samsung support in case I could solved it there. Even if it was VERY VERY difficult to prove my self right , because as you can understand the phone alone works without any problems, the echo issue arise only when you attach a case and in my... case... whatever case I used I had the echo issue ( I bought 3 cases :) ). So I finally had to bring a friends phone that worked with all my cases without any problems. So they decided to take a closer look. Finally , after a week they have found that there was an echo issue and replaced a part (which as they told me it was all the front screen compartment that held the microphones too) I ll try to find and post the part number in case somebody needs a reference to it. At the bottom line it seems it is actually a hardware issue , I had updated to 2.3.4 before I went to Samsung and that didnt solved my problem. I am just posting so that you can take any necessary actions to fully enjoy your phone because in my opinion the Galaxy S2 ..rocks...
  5. tombraider000

    tombraider000 New Member

    Okay mine does it with or without case and i dont even know where the noise reduction thingy is.if i get to making a call and press the bottom left hand side my only options are add to contacts, speed dial setting, send msg, add 2 sec pause or add wait. no call reduction thing :(
  6. tang3nt

    tang3nt New Member

    I'm suffering the same echo problem on my SGSII, only with a case attached though. Without a case it's fine. As with others' experiences, switching off NR in-call also makes the problem go away. Frankly, I'm reluctant to send the phone off somewhere to be repaired for such a small issue. I've been down this road before with other products/hardware. If the fault is not completely obvious, you can be sending things in for repair 3 or 4 times before eventually it ends up in the hands of someone with a brain who is actually prepared to put the time in and figure out exactly what the problem is.

    However, if someone can provide a specific part no. or a description of exactly what the tech changed, i might be prepared to embark on the process of getting it fixed. Also, i found some samsung service centres on the locator on their site (i'm in the UK). They seem to suggest you can just show up at these places with your phone to get it fixed - is this true?
  7. stevenvdd

    stevenvdd New Member

    I also have the same problem
  8. stevenvdd

    stevenvdd New Member

    How did he do it ?
  9. shadowah

    shadowah New Member

    Hi, just stuck a piece of heavy tape over top mike, fixed it in seconds !!! hope it has fixed it Cheers .... Shadowah
    lalalalala likes this.
  10. lalalalala

    lalalalala New Member

    thanks a lot shadowah !

    its working like a charm.

    finally no annoying echo :)
  11. ajh94

    ajh94 Well-Known Member

    YES! I have exactly the same problem! But only when my CaseMate Gelli is on the phone!
    s4android likes this.
  12. greggebhardt

    greggebhardt Well-Known Member

    That means that it is a CASE problem and not a Samsung Problem!

    Order the Barely There case from CaseMate and it will not echo.
    s4android likes this.
  13. Mike Hawk

    Mike Hawk Member

    [FONT=verdana,sans-serif]I haven't had any echo probs... i'm using the Otterbox case which has rubber on the inside and hard plastic on the outside. There is a big space where the headphone jack/NR mic is so maybe that's the reason mine is ok?

    Android Version 2.3.4
    Baseband version I9100UHKG4
    Kernel version
    build number - GINGERBREA.UHKG7
    [FONT=verdana,sans-serif]HECHO EN CHINA/MADE IN CHINA[/FONT]
  14. joey28

    joey28 New Member

    hi, what is a samsung service centre? what country are you in, people that have used this? i have sent my s2 back to vodafone today for repair after calling them to complain about the voice echoes- hopefully they will get it repaired and i don't have to continue to find a way to solve the problem on my own. phone is less than 4 weeks old so pretty annoyed about this ....... :|
  15. tang3nt

    tang3nt New Member

    This ^^

    What are these service centres? I'm in the UK - can i just walk in off the street and ask them to take a look at my phone? Not interested in posting it off somewhere for 6 weeks, just for some engineer to take one look at it and say it's fine. But, if i could take it in so they can take a look whilst i wait, that i might do.
  16. lalalalala

    lalalalala New Member

    probably another solution for the echo problem!

    a guy told us that he solved the problem by putting a sticky tape on the speaker from inside the phone.

    you can take a look on the pictures here:

    the red arrows are the places where he puts the tape :)
  17. Voltar

    Voltar New Member

  18. vitsaminsk

    vitsaminsk Member

  19. Voltar

    Voltar New Member

    You've pretty much covered it there vitsaminsk, but I don't get the option to disable NR when I press the menu key. If I'm in a call I only get the option to save to contacts or memo. I'm on 2.3.5 stock if this makes any difference.
  20. vitsaminsk

    vitsaminsk Member

    Voltar, yes I heard something that on some firmware there is no such option. U can flash new firmware (more details on find on forum xda-developers [ROM+Guide]Official i9100 Firmwares KG, KH, KI1/2/3/4/8, KJ1/2/3, KK2/5 Download - xda-developers).
    I have 2.3.6 (KK5) & NR & disable option exist in same menu with memo & contacts during call.
    Its a pity that I cant show u screenshot from my phone. But If u like I will sent it to u.
    For additional information (how to flash yr phone or other) do not hesitate to contact me.
  21. Voltar

    Voltar New Member

    Thanks vitsaminsk. It's OK, don't need a screenshot. For a while there I thought I may be going blind. I might just wait until the official 2.3.6 (for my region ) is available before flashing with another. Thanks again.
  22. vitsaminsk

    vitsaminsk Member

    Yes u are right, soon u will get new official 2.3.6 via kies, the problem probably will be fixed for yr region, hopefully :).
    By the way this option (NR off) was on my previous firmware versions (from 2.3.3) too.
  23. samos1111

    samos1111 Member

    Same problem with echo of the other caller's voice on his side. Hugely amplified by the gel case, but audible also without (much lower volume).

    Could you pls more precisely describe proper placement of the speaker and the cushion? Is the cushion supposed to touch the case or not?
    I've opened the case - simple with the repair manual someone linked, only a small screwdriver and a guitar pick needed, no labels damaged. I see a small black thin circular "cushion", with obvious imprint of the back pressing against it. It did not seem placed improperly and I wasn't sure I could get it off without damaging it.
    I've placed two layers of thin white soft medical tape on the case side. Echo of the the caller's voice on his side with case GONE COMPLETELY. But now my voice echoes a bit on the other side. I assume a proper solution would not involve tape.

    I'm using stock 2.3.4. Btw it seems to turn off NR on its own in certain circumstances ("wideband calls" ?). I think NR off is not a solution, it is supposed to reduce noise ;)
  24. vitsaminsk

    vitsaminsk Member

    Samsung GS2 is a good phone, but so many problems reported that I will consider to purchase some HTC phone.
  25. caplja

    caplja Active Member

    Any solutions to this ?

    I bought this case and having problems only when phone is in right position as it should be. For example, when I put it reverse :


    problems are gone :/ I tried to tape upper hole near the 3.5mm hole for phones but didn't help.

    ps. I have rooted phone with CheckRom and DarkNight kernel on it.

    thanks in advance

Share This Page