Voicemail Notification HTC 2.3 update problemSupport


Last Updated: 2012-11-30 04:30:34
  1. kermie

    kermie Member

    I just updated my HTC EVO Software to 2.3. Before I did this, I used to occasionally get a "pending voicemail" notification that you cannot clear. I had to turn my phone off and then on and that would clear it. Now, I get a similar issue. I get "New Voicemail" "Dial XXX-XXX-XXXX" (My phone #) and it will not clear. I have turned off the phone, taken the battery out, went into my voicemail program and turned off the notifications and also cleared all of my voicemail data and stopped the program. Nothing that I have done will work. I'm hoping someone knows of something that will fix this error. I really do not want to have to take this to Sprint. Thanks in advance . . .

    Advertisement
  2. wrxevopilot

    wrxevopilot New Member

    same exact issue here... shows I have 3 voicemails... NO I DONT... tried the same things you did. annoying... any help out there?
  3. wrxevopilot

    wrxevopilot New Member

    kermie... found this post and it works:
    "After downloading Gingerbread, I had a voicemail notification that wouldn't go away even though I have no new voicemails. I've read that others have had this problem...well, I got rid of it on mine. Simply go into settings, call, settings, and clear voicemail notifications. Its gone! Just figured I'd help out anyone with the same problem."
    sanibel, klaragon73 and monkeyfly like this.
  4. kermie

    kermie Member

    Wrxevopilot=Genius! Thank you! Now I can go back to liking my EVO again.
  5. monkeyfly

    monkeyfly New Member

    THANK YOU THANK YOU THANK YOU!! i dealt with this issue for 2 agonizing days and thought i'd have to deal with it forever. no other forums knew how to solve. THANK YOU!!!
  6. kznupe

    kznupe New Member

    Did that, cleared the notification, but if you turn your phone off and back on again, the notification returns.
  7. Haroof

    Haroof New Member

    The clear voicemail notification in settings is just a temporary fix for this problem.

    The notification will eventually return.

    If anyone find a permanent fix to this, please share it with the rest of us having this annoying problem.

    Thanks.
  8. Central4

    Central4 New Member

    Were any of you using Google Voice?
  9. melissai_

    melissai_ Well-Known Member

    there is no clear notification in my call settings :( ugh
  10. wrxevopilot

    wrxevopilot New Member

    Arghhh!! The fix I listed in my previous post is only temporary... the notification eventually does come back... found this solution in another post but havent tried it yet:

    *** Make sure you clear the Voice-mail notification Icon First before proceeding**** Simply go into settings, call, settings, and clear voicemail notifications. ****If you have access to you EPST menu (Most EVO users should be able to enter on dial pad ##3282# to get into this aka (Equipment Performance Support Tools) you can go into edit but you will then need your phones password which a sprint tech can give you (this is unique to each phone). Next you will go to data profile, in the section you just click the menu button and go to restore. It will power off your EVO restart and reprovision your Phone to the network. Once it restarts it will do a hands free activation, PRL update and it will check for new firmware. Once this is all done you phone should be all set.*** Note this does not change any software on the phone just the link to your provider so your phone should work as normal meaning all apps should be uninfected!

    Let us know if this works...
  11. spookybigalex

    spookybigalex New Member

    Hi everyone. My name is alex and i updated my evo to gingerbread as soon as the OTA was available. I am not rooted. To my disappointment i have a voicemail icon that will not go away. I called sprint and after 2 hours on the phone with 2 technicians they couldn't figure out how to remove the voicemail icon. We tried a hard reset erasing the whole phone and also resetting the PRL. They gave me credit and told me to wait it out. After reading this forum i tried the clear voicemail notification option in the call settings and thats a temporary fix and the other suggestion where you type in ##3282# and then the EPST password does not resolve the issue. Its really annoying. I hope my information helps, and if anyone figures out a permanent solution please share.
  12. vailpass

    vailpass Well-Known Member

    Tried all of the above, hard reset using ##786#, nothing workd. Still getting bogus voice mail alerts.
  13. mtfdben58

    mtfdben58 Member

    Worked for me toooooo!!!!!!:) Thank You this was driving me nuts. :confused:


    Yep as they said above It's Back.
  14. Enkil27

    Enkil27 New Member

    FML... This keeps coming back and I hate my Evo now, I want to throw it at a wall sofa king annoying!!!!
  15. existingaskevin

    existingaskevin New Member

    Persons affected by this issue:

    Are you using a third party SMS application such as Handcent?
  16. Enkil27

    Enkil27 New Member

    No I am using the standard phone tools for text and voicemail. It keeps coming back some times almost instant sometimes hours later. It does seem to happen at the same time I get a text message as well. Rarely it happens even with out a text coming through too.
  17. existingaskevin

    existingaskevin New Member

    Hmmm. I know for a fact Sprint is aware of the issue and working a fix with HTC. It appears there is a glitch in the messaging process that is causing the issue. Temporary fix is to clear VM indicator within phone settings. Doing a ##3282# > MSL > DATA PROFILE > MENU > RESTORE will not clear the issue. Stop wasting your time. Sprint is seemingly attempting to roll out a fix to phones in batches in the order they were updated to Gingerbread.
  18. atistang

    atistang Well-Known Member

    i had this same problem and it just ended up fixing itself after about 5-6 days
  19. Did you guys try Menu - settings - applications - manage applications - ALL - Voicemail - Clear Data - Force Stop - then reboot the phone (power off then power on)?
  20. ltgilliam

    ltgilliam New Member

    Tried it so far so good. Thanks Halfbaked
  21. Enkil27

    Enkil27 New Member


    Tried this numerous times as well as every solution on this page except the #number thing. Still no luck...
  22. existingaskevin

    existingaskevin New Member

    Enkil, how long ago did you update to Gingerbread? I go into work on Wednesday. I'll see what the status on the fix for this issue is.
  23. cmegginson

    cmegginson New Member

  24. Enkil27

    Enkil27 New Member

    Well I got the update on 6/6ish but I don't know anything about gingerbread... Unless that is the update. The new vm notification still happens just no where near as often, probably 5 - 10 times a day now instead of every text message.
  25. kermie

    kermie Member

    Got the update today after it would not work for me yesterday. I hope it fixes the issues! We'll see!

Share This Page