1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

VPN IssueSupport


  1. KevinM

    KevinM Member

    Since last evening I have been unable to connect the VPN to my work server. I am able to connect with my home computer with the same settings. The droid gives the message "Server hung up. It is possible that you are behind a firewall that prevents you from connecting to the server. Do you want to try again.?"

    When I look at the server event logs it shows the attempts and the suggestion is that it is port related. (IE more ports opened). Yet I can conect from other computers and all the ports listed as necessary are open.

    I called support at Verizon and they of course began by saying that the vpn is not supported and that it wasn't a problem with their system. They only offered a hard reset.

    I do have the 2.2 update - what suggestions do folks have?:confused:

    Advertisement
    :
  2. KevinM

    KevinM Member

    ok - a brief update. I am able to connect the vpn when using the wireless network. If I try to use the verizon network I get a message that the server hung up. I have tried connecting on another droid and get the same problem.

    Verizon is no help. I get the "VPN is not a supported feature". They want to do a hard reset and wipe the phone. This makes no sense given that I can connect - only not over their network.
  3. KevinM

    KevinM Member

    After one week I am still having trouble with the ability to VPN over Verizon. I am not able to connect over the 3G network about 90% of the time.

    I am consistently able to connect the vpn via the wireless connection when I am in a WI=FI hotspot.

    I used Network Discovery which I downloaded from the market to test open ports and have found no difference between the 3G and WIFI. I don't know how to test the GRE protocol (verses open ports).

    I am using the 1 VPN (trial but will buy) and that makes trying to connect a little quicker and easier.

    When I am unable to connect I am still getting: "Server hung up. It is possible that you are beind a firewall that prevents you from connecting to the server. Do you want to try again?"
  4. gingerman74

    gingerman74 New Member

    Kevin,
    I can confirm this as well. Me and a buddy here at work both have Verizon and neither of us could connect to our corp vpn via the Verizon wireless network since around the first of the month. Doesn't this coincide with the update to 2.2? Once we connected to a WI-FI connection we were able to connect to the VPN connection right away.
    Looks like Verizon is the culprit here.
  5. jbenisek

    jbenisek Member

    I have support alot of phone, starting last week all my Android phones stopped VPN'ing with Server Hung up error,

    HTC Incredable 2.2
    Droids 2.2 and 2.1

    I connect maybe 1 out of 20 tries. However, I'll connect over broadband with my Laptop be vpn'ed with same PPTP protocal and no problem 100% connect rate.

    I'm on with Motorola now but it's not looking hopeful, they say thy've had problems with Droids and a patch will come out later, but they don't seem to apply that problem to the VPN.

    I'm on Verizon too, I worry they blocked VPN access 29.99 data plans. To force 44.99 plan without telling anyone!
  6. jbenisek

    jbenisek Member

    Told I had to contact verizon nothing they could do.

    bs...



  7. cdaveygo

    cdaveygo New Member

    I am on a Droid running 2.2 and I have the 44.99 corporate data plan so I don't think the actual data issue is the problem. It is just VZW Blocking the connectivity which will ultimately kill the droids faster than an iPhone will.
  8. westendx

    westendx Member

    I've been looking into the VPN issue and I've discovererd something. When I got my Droid X, last weekend with the 2.2 update, I paid for the 3G Hostspot. When I got home I tried to setup the VPN and could not get the 3G connection to connect, same error as others report. However, I could get the VPN connection to connect over wi-fi. No good for me because my company locks out smart phones so I couldn't setup the Active Synce for Exchange.

    Anyway I do most of my work tethered from my laptop so I fired up the hotspot and had to attempt to connect a couple times. First time I got the 619 error as reported by others, the second time it connected. Oddly enough this is a similar issue to what I had when tethering with my BB. That used to work fine but a couple of months ago started causing issues.

    So then I rooted my phone and installed Wireless-Tether. I could connect to VPN using that but it drops repeatedly. Which is probably partially related to the app.

    Well I then dropped the 3G Hotspot plan and guess what? No VPN access at all. Not from the phone or via a tethered laptop.

    Today I thought I'd put the 3G Hotpsot plan on again to see if it did indeed have an effect. Well holy conspiracy Batman VPN is working again. It still drops but not as often.

    I spent over an hour with tier 2 Verizon support and they denied any knowledge if the issue. In fact they claimed that I'd need the 44.99 plan to get my VPN working. BS. But after working with my friends in our IT dept it certainly looks like Verizon is up to something.

    If Verizon was simply blocking GRE then the VPN connection would never work. The fact that it works sometimes, and better with additional subscription, seems to point so some buggy filtering at Verizon's end.

    I'd begrudgingly payup for a data plan that gave VPN access. I'd just like Verizon to come clean and fess up.

    Best regards,
    Pete.
  9. cyberaxe

    cyberaxe New Member

    Solution to
  10. westendx

    westendx Member

    Hi,

    I spent a couple hours in the Verizon store over the weekend with them trying to figure out why I could not connect to my company VPN when using the 3G Hotspot. I eventually dug up this thread and had the tech guy give me an unrestricted IP. The VPN immediately connected, no more 619 errors. I've been using VPN over my 3G hotspot now for a couple of days and the connection stays up most of the day. That is it drops more more than it does when connected over a LAN.

    Surprisingly this also fixed connecting to our PPTP VPN from the phone over 3G. And Touchdown now syncs with my Exchange server. However, the phone VPN connection still has issues with losing all IP connectivity at some random time after connecting. That could be 5 seconds or 5 hours.

    I'm not sure where the problem is with the phone VPN though. This morning I started getting the dreaded firewall issue again. I'm going to have Verizon check that they did not change my phone back to restricted.

    Thanks for this information.
  11. jbenisek

    jbenisek Member

    :mad: I had to stop the lady a few times and say "I'm going to stop you right there mam, you are not listening to me".

    Once they stopped reading the script and check their own tech support forums and the complaints she got her act together and had something on chat messanger she was talking to that know with-in seconds what the problem and solution were.

    Don't let them push you around and control your call.

    I filled out a FCC complaint over this and really suggest everyone else does too.

    This worked a few months ago then stopped for everyone they say they havn't changed my account, given it's a federal crime to change it without my permission, however I know they did. I have 2 business and a personal account all changed and blocked!!!
  12. westendx

    westendx Member

    Changing to an unrestricted IP only solved my VPN issue when using my laptop via the mobile hotspot. It does allow the phone to connect to the VPN over 3G but the connection becomes useless immediately. My IT contact checked the logs and our VPN server comlains that the connection was dropped because the GRE protocol appeared to be blocked. I also get this error at our VPN server when using the phones VPN over wifi too.

    When using the VPN over the phone over wifi or 3G the VPN connection does connect. Touchdown can establish an Active Sync connection to our Exchange server. But all IP connectivity drops within seconds, or a couple minutes.

    Because I get the same GRE problem using the VPN over wifi I think that there's a possiblity that the VPN client on the phone might have something to do with the issue. The reason I say that is when using my laptop over the hotspot I'm sending the same VPN traffic as the phone's VPN client would over 3G or wifi. Yet my laptop has no issues maintaining a connection.

    Why would the Verizon network block the VPN traffic from the phones VPN client and not my Laptop's VPN client sent over the hotspot?

    Why would the wifi VPN connection also have the same issue while my laptop connected to the same wifi does not?

    While getting the unrestricrted IP is an absolute must I think there is more to this issue. And it's probably due to software running on the Droid, either the Linux firewall or the VPN client itself.

    Best regards,
    Pete.
  13. cyberaxe

    cyberaxe New Member

    All I've seen is the other way around. Most reports I've seen say the Wifi VPN solution of your local WIFI works 100% but the same vpn over Verizon Broadband doesn't work. "Server Hung up error"

    this has also been tested on Ipad's so I don't think it is directly related to android phones, it's an issue on phones from Sony to HTC to moloral, Tmobile and other carriers have had this problem in the past but none currently except verizon.

    We've tested this and it's solved our issue on 10 phones all over verizon. We use PDANET and the In-phone VPN client.

    GRE being block sounds like Verizon only fixed it for a second then changed it back. We've heard this might have happend to others. Make sure you did a *228 option 1 and a full phone reboot.

    Also please test this in different call area's to make sure it's not local drops of bad 3G performance.

    Then using wifi and your laptop please let us know if you are using Verizon Tethering or the PDAnet tethering? this could be why the laptop works and the phone doesn't.

    Verizon Tether gives the tethered device a different IP block than the phone would have gotten. Which is why you can vpn directly I believe this applies to PCIMIA-USB mobile broadband cards they get a different block of IP's assigned then the phone would doing PDAnet tethering.

    Please let us know the results. Thank You,
  14. cyberaxe

    cyberaxe New Member

  15. westendx

    westendx Member

    Ok I did the *228 1 and reboot.

    Interesting finding, which I suspect is why I thought the connection is hanging up at random times.

    While using the VPN on the phone through 3G or wifi I set up a terminal with a constant ping to both yahoo and our Exchange server. They pinged constantly until I decided to use either Touchdown or The browser. As soon as I pointed the browser at yahoo most of the page would load then then connection would stall. At that point the pings also failed and nothing else could be pinged until the VPN was dropped.

    Now sometimes the connection will stay up long enough for Touchdown to sync or to navigate through several pages. Most the time it dies before I can do anything usefull. But the connection seems to be fine until I actually run a program that sends data through the VPN.

    I've asked my IT guru to check the logs to see if I'm getting the same GRE messages.

    Best regards,
    Pete.
  16. westendx

    westendx Member

    I just tried the same test using PDANET. When the phone is not connected to the VPN before starting PDANET the connection works fine. When I start the VPN connection over wifi or 3G then start PDANET I can ping or tracert to sites for as long as I like. But as soon as I start an IE and point to yahoo the page partially loads and the connection stalls.

    The phone reports the VPN connection as connected.

    The only way to recover is to stop PDANET, disconnect the VPN and restart PDANET.

    So either there is a problem at our side or a problem in the phone because I get the same issue regardless of whether I'm transmitting data over Verizon's network or wifi.

    I do not get the same problem surfing or working through VPN over the 3G hotspot. Out IT dept says they can't see any difference in the connection when using the laptop to VPN or using the phone. So the finger points back at the VPN client on the phone.

    Here's what the IT guy shows in the log file when only using the phones VPN client.

    This really should just work. I've already spent countless hours running test after test.

    Best regards,
  17. westendx

    westendx Member

    Well today I can start a VPN connection form my laptop over the 3G Hotspot. I have two VPN destinations that I use, one in CA and one in MD. If I connect to the CA MTV then all is fine for a few minutes then the connection drops. If I connect to the MD one then the connection stays open but I cannot pinig anything.

    If I stop using the 3G Hotspot and start using the available free wifi then both connections are fine. Also tethering through my Verizon BB works fine too.

    This just started happening today. I've been fine all week. I even did another *228 but to no avail.

    I've forwarded on the information to my Verizon contact. But I'm not holding my breath here.

    Best regards,
    Pete.
  18. westendx

    westendx Member

    I started working with my IT staff checking the firewall at both ends. We saw no notifications at the server side when the VPN stopped responding so we know that our server side firewall is not causing the dropped VPN. There was also nothing showing any firewall issue with the VPN on my laptop. The only odd thing was a network storm of IPV6 packets.

    After a quick investigation it turns out that the SEP NTP does not support IPV6 so it blocks all IPV6 packets. Now Win 7 Homegroup only uses IPV6 so it looks like that is the source of all the IPV6 traffic. A little more research uncovered problems with SEP NTP causing stability issues with wireless comms when blocking all the IPV6 traffic. While the thread was not related to the 3G Hotspot it was wireless related so I thought that I'd give it a try and uninstall the SEP NTP.

    Low and behold the VPN is now stable. Well until the 3G signal drops or the Hotspot reboots the phone. It may be coincidence so I'll keep track of any further reoccurrences of the issue.

    Here's the thread I read on the SEP NTP and IPV6 wireless issue.

    Wireless Restarts Cracked

    Seeing that the 3G Hotspot is essentially acting as a wireless router I thought this post might have some relevance.

    Best regards,
    Pete.
  19. RPWeaver

    RPWeaver New Member

    Unfortunately, I just got my unlimited data service with no previously working service history. I called Verizon business service today after a chat session with technical support. The woman I talked to, after leaving to talk to her supervisor, said I had to upgrade to unlimited business data account for $44.99/mo to get the VPNs unblocked, a $15 /mo increase just for VPN. I couldn
  20. jbenisek

    jbenisek Member

    Looks like this fixed my issue. I also got some more info for you: Thanks to Trey.

    The
  21. prpsarathy

    prpsarathy New Member

    Hi,

    I am missing something as my ipad connects where as the desire hd does not connect.
  22. khay0911

    khay0911 New Member

    Just for further information, my company purchased 6 Moto Xoom tablets and have been trying to connect to our corporate VPN using them for over a month now. When connecting to the VPN from the Settings page, it shows that it is connected, but when I try to pull up our intranet site, it times out or part of the page loads, or I get the Server Hung message. It seems the Xoom with Android 3.0 has the same issue as every other Android phone. I am contacting my Verizon rep right now to see if we can get removed from the Restricted IP list. I'll let you know how helpful they are.
  23. st0623

    st0623 Member

    Same issue with my Samsung Droid Charge on the 4G network. Verizon is saying they can't make this change to my phone, since it is not supported.
  24. st0623

    st0623 Member

    Verizon and Samsung have escallated this to Google's Android division and they are looking at why MPPE isn't working right on Android. This isn't just a Droid Charge issue, but an Android phone issue. Stay tuned...
Loading...

Share This Page