1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

(VZW) Nexus 4.0.4 Update - wont installSupport


  1. BlackHawk1776

    BlackHawk1776 Member

    So I've had no trouble getting the IMM76K downloaded more than a dozen times (I haven't actually counted.) I got it downloaded the first day; and every time it always goes the same. Download it, verifies it, then asks me to install it. I tell it yes, it reboots after about 10 seconds. Then instead of any kind of installation, the phone boots back into 4.0.2 and asks me to accept the Google terms for location services.

    I've tried downloading the update Seventeen ways from Sunday but I don't think that has anything to do with it. So my next thought is to backup the phone, wipe it and try the install when it's all fresh.

    My phone is 100% stock, the bootloader is still locked and nothing custom at this point. Though I feel like if I'm going through all the trouble to wipe it and install this update I may as well unlock it and install a custom ROM.

    So any good ideas as to why it wont install before I start playing with one of my most important tools for work?

    Also, anyone else have a similar issue? I can't be the ONLY ONE who's had this exact issue!

    Advertisement
    :
  2. umataro42

    umataro42 Well-Known Member

    Are you seeing the Android lying on its back with a red triangle above an open panel? Because it seems like a couple people on here (myself included) are getting that problem when it tries to install the update.
  3. BlackHawk1776

    BlackHawk1776 Member

    No, I don't even get that displeasure - it goes straight to the normal boot animation. (Which is nice, but it's better when it's 4.04 after it's done booting!)
  4. trophynuts

    trophynuts Well-Known Member

    try doing a factory reset and then grabbing the update.
  5. sommd

    sommd New Member

    i received my update this morning 4.04 i515.09 v fc04 i515.fc05 no problems i'll check it out today
  6. Zaborowski

    Zaborowski New Member

    I am also having trouble updating to 4.0.4...But my situation is a little different.

    I am rooted with and have an unlocked boot loader. No MODS or anything special. I have actually rooted my girlfriends Galaxy Nexus the exact same way that I have rooted mine and some how hers updated fine on the first try. I guess the only difference is that I have "Nova Launcher" and she does not.

    I have been trying to update my phone 2 ways now.

    First, i actually get a pop up prompting me that there is a new update. It asks me if I want to (Install later/Not Now/Install Now). Of course I choose the NOW!! So, it downloads, reboots, Google pops up with an unlocked lock, and then I find myself at a screen with my little android is standing up with some Blue squiggly stuff in his stomach and then about 1/4 the way through the install, he lies down on his back with a red exclamation mark...:(

    Secondly, I have tried forcing the update by clearing the data through Google Framework. The process goes well at first; In the Google Framework I clear the data, force stop, shut down, battery pull (I have also tried not pulling the battery), then going to Settings\About Phone\System Update. At this point it's already downloading when I get here (I have tried on Wifi and on 4G as well). Once downloaded, it prompts me to restart. Once again, my little android is standing up with some Blue squiggly stuff in his stomach and then about 1/4 the way through the install, he lies down with a red exclamation mark...:(

    Any advice or guidance would be much appreciated
  7. Benjamin Crist

    Benjamin Crist Active Member

    I'm having the same issue as Zaborowski.

    My phone is rooted, bootloader unlocked, and everything else, including launcher, is stock.
  8. Stigy

    Stigy Some say... VIP Member

    Hmmm I remember this being an issue with the GSM variant and not having a recovery installed for some reason.

    For those facing the problem, please try these steps:
    1. Let’s turn off our Galaxy Nexus then boot into Fastboot mode by holding down Volume Down, Volume Up, and Power button together for about 10 seconds.
    2. Choose “Recovery mode” using the Volume Down button. Then hit the Power button to enter recovery.

    If something is borked with your recovery you will find out here. I will look for the post that explains how to flash it, but this may be a lead in the right direction.
    BlackHawk1776 and iowabowtech like this.
  9. iowabowtech

    iowabowtech root@android:/ # Moderator

    Yeah I saw something about that on xda. Supposedly the stock recovery image was borked or something. Also, it'd be nice to verify that the people above don't boot into cwm...that'd explain it too.

    Edit:
    HERE is the one I was thinking about Stigy. May be different from what you were referring to, not sure.
    umataro42 likes this.
  10. Stigy

    Stigy Some say... VIP Member

    Yup that would be it, thanks. Verizon Nexus users shouldn't flash that though as that is the GSM recovery, I believe.
  11. iowabowtech

    iowabowtech root@android:/ # Moderator

  12. Benjamin Crist

    Benjamin Crist Active Member

    I'm pretty sure it has to do with ClockWork Recovery, but I haven't played with that since I got my phone months ago, so not sure if the issue is due to setting up clockwork recovery to be the default recovery - I'm guessing that is it.
  13. umataro42

    umataro42 Well-Known Member

    Thanks for the link, since it does look like my problem is with the recovery, even though I never switched from stock recovery. Hopefully this will fix it.

    If anyone else downloads the app to try this, it wasn't recognizing root. I e-mailed Scary Alien and he said it was doing the same on his phone and would look into it after work.
    BlackHawk1776 likes this.
  14. umataro42

    umataro42 Well-Known Member

    Scary Alien was kind enough to send me an updated apk, and I was able to use Flash a Stock Recovery, but the update still won't install.

    I also tried flashing Clockwork Mod Recovery, and got the same error (but at least I didn't see the red triangle until the very end).

    In case it helps to figure out what's wrong, here is the error message in its entirety. I also posted this on XDA-forums and someone said the problem is the system/bin/gzip, the original file being replaced by a new one from busybox.

    assert failed: apply_patch_check("system/bin/gizp", "51086995a674ab78fd63b49aa7207df466624897", "5ba3b3ecd509cf6cee37b2f27110310a1f55045")
    E: Error in /cache/12f767e7a5d0.incremental.zip
    (status 7)
    Installation aborted
  15. BlackHawk1776

    BlackHawk1776 Member

    I assume when attempting to boot into recovery mode it should have done something other than booting normally? I was able to get the menu, selected recovery mode, hit the power button to select it, then the phone appeared to reboot (Google logo came up again) then proceeded to boot into ICS 4.0.2.

    So it sounds like my stock recovery image is borked, that probably explains why I couldn't do a factory reset on my phone a while back when I tried.

    My phone is 100% stock, not rooted, not unlocked.

    So what's the best way to attack this issue on a 100% stock phone?

    I'm still surprised that no one else in the world is having the same issue as me; it really makes a person feel special...ed.
  16. Benjamin Crist

    Benjamin Crist Active Member

    I figured it out....

    When I got my GNexus phone, I rooted it and made Clockwork my default recovery.

    So last night I looked in the cache folder and found the OTA update and moved it to the sd card folder and renamed it to update.zip and used clockwork to apply it. However, it failed and gave me an error about not finding a file: VZWBackupAssistant.apk

    So I used root explorer to rename the file (I didn't delete it, I simply renamed it) back to VZWBackupAssistant.apk and everything worked fine.
  17. iowabowtech

    iowabowtech root@android:/ # Moderator

    So when you select recovery, you don't see the android dude laying down? For the stock recovery, you need to press and hold the power button, then press volume up to access the recovery menu options but if you're not even getting to that point before the reboot then there's something else going on.

    Also, have you been unlocked/rooted in the past or stock since day 1?
  18. Stigy

    Stigy Some say... VIP Member

    If he doesn't see anything after selecting Recovery there is no recovery installed on the device.

    I will wait until he responds about the unlocked/rooted question and then we can proceed from there. Depends on whether he deleted the reboot-from-recovery.p file or not.
  19. jeff442

    jeff442 Member

    Sorry, you're not special! The only "modifications" I've made to my phone is using Nova Launcher. Mine is stock, not rooted, not unlocked. This is what I posted in the main 4.04 thread:

    I forced the update again today, it showed downloading "IMM76K" which was about 39 mb. It finished downloading and then set the phone would have to reboot for the install to complete. Once again, I check the android version after reboot and it says "4.02". What the hell?
  20. iowabowtech

    iowabowtech root@android:/ # Moderator

    If you guys are having that much trouble, I would do one of two things:

    1.) Return it
    2.) Fastboot flash stock 4.0.4

    There may be a silver bullet somewhere but being stock, the options are limited. ESPECIALLY when you can't even access recovery.
  21. umataro42

    umataro42 Well-Known Member

    There's a couple more options.
    3) Just stick with 4.0.2 - I know this is mostly unthinkable, but I haven't had most of the problems with my phone I've seen others report, so its a better option for me than returning it for a different GNex that might have those problems.

    4) I've also been looking / asking for help on XDA and there's a few suggestions there.

    This FAQ mentions an option of removing the patch check and installation from the installer-script in the ota zip, but I'm not sure I want to try that.
    [FAQ]Installing Verizon 4.0.4 OTA, Rooting, Etc. - xda-developers

    Here's a link for the more recent article with other people having this problem, but basically its because when the check is run, there's a file that doesn't match with stock. In my case its because when I installed Busybox, it replaced some of the system/bin files with the Busybox version.
  22. iowabowtech

    iowabowtech root@android:/ # Moderator

    The patch check thing is a nice trick but IMO if you're going to have fastboot installed anyway (required for that method also), then might as well just fastboot flash the partitions and you're done. That method would come in handy though for leaks where the source may not be available. But now that Google has made the 4.0.4 files public, there's really no need for workarounds.
  23. BlackHawk1776

    BlackHawk1776 Member

    When I hold the buttons I do get the green android laying down with the red arrow pointing to the power button with the given options list.
    As soon as I hit the power button to select recovery mode it reboots. (Within a moment I see the Google logo then Boot Animation)

    My phone has never been unlocked or rooted, ever.

    So it sounds as if some of the various items that were supposed to come pre-packaged didn't make it onto this phone (or got damaged somehow) thus it wont boot into anything but the 'normal' mode. Seems like some files needed for the alternative boot method would be the missing link.

    For the most part 4.0.2 does work rather well; not having 4.0.4 though the grass always looks (or sounds) greener. The talk of improved radios sounds like something I wouldn't mind having (my reception isn't super great when sitting at my desk at home - a slight improvement there would always be nice.) My phone only does the 'random reboot' maybe once a month if that so I'm not terribly worried about that. Since an in depth change log is impossible to come by it's hard to know what would be better - also the theory that if all of the changes had to be visible we might as well be on Android 1 still.

    Returning it to the store / ordering up a replacement is an option but it seems silly to replace hardware that works fine for a software problem.

    So if fixing this in stock form is a real pain, then how tough is it to go the root / unlocked bootloader / custom rom route or some alternative method of installing stock 4.0.4? I don't have any special desire for anything other than snappy performance, the best battery life possible (I go through 2-3 batteries a day) and the ability to use my work apps.
  24. iowabowtech

    iowabowtech root@android:/ # Moderator

    I don't blame you, that's the route I would take too, I just didn't want to push you into it. Who knows what you're going to get with a refurb is what I always say.

    So basically, you first need to decide how far you want to take it. Do you want to unlock the bootloader, then root and install custom roms from here on out or do you want to unlock the bootloader temporarily, flash the new stock 4.0.4 files and then relock the bootloader as if nothing ever happened? Those are basically your options. There is great flexibility with this phone since it can easily be unlocked/relocked.
  25. BlackHawk1776

    BlackHawk1776 Member

    Right now I'm thinking of going with the stock 4.0.4 - going to custom roms would mean I'd have to play with / research each rom and see if it did anything interesting for me.

    As I recall unlocking then locking the boot loader on the next is pretty easy, right? IS there any particular reason to re-lock the bootloader? Does leaving it unlocked stop OTA updates from installing properly?

    So the process to do this is to first backup the 'sdcard,' unlock the boot loader, restore the stock recovery and lastly install 4.0.4?
Loading...

Share This Page