Wacky Charging Behavior


Last Updated:

  1. baciv

    baciv Active Member This Topic's Starter

    Joined:
    Jul 2, 2010
    Messages:
    44
    Likes Received:
    3
    I'm trying to track down the source of some odd battery behavior.
    Rebooting my Inc changes the reported charge 10-20%, i.e. if the reported charge is 75%, upon reboot it is reported as 61%, or even if the charge is 15%, upon restarting it is 26%.
    I can no longer reach a 100% charge, but charging stops at 99%. If I attempt a bump charge by powering down at 99% and continuing charging, I have never yet (since my installation of Virtuous 3.1 on 10/19) seen a green LED, and when restarting the charge level is reported anywhere from 65-90%.

    This behavior is observed in both my stock 1300 and 1500 batteries, so I have to look to hardware or software issues for the source. I have charged as fully as possible and wiped battery stats each time I switch batteries. I have only noticed the behavior since my clean install of Virtuous 3.1 with the newest kernel. I have added the Inc. rEVOlution theme.

    My battery life overall appears to have dropped as much as 1/3 with my same usage patterns compared to previous ROM/Kernel combos. Based on what I've read here about the new kernel and battery life, I should be seeing the opposite.

    I'd like to try applying an older kernel (the previous stock V.4) to see if that addresses the behavior.

    My question to you is: is applying an older kernel advisable? Am I chasing my tail with this whole issue?

    Everyone here knows a lot more than I, and I apologize for even mentioning battery problems, but I really prefer this ROM overall and I want it to work for me.

    Thank you.
     

    Advertisement
  2. jbuck1984

    jbuck1984 Well-Known Member

    Joined:
    Apr 25, 2010
    Messages:
    422
    Likes Received:
    39
    You can try various kernals, and if you use ROM manager you can revert back to the stock kernal if the others don't work for you.
     
  3. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    do a nandroid and go to another rom and kernel and see if you still have the issue, this way you can see if it's software related.

    If it's still there than you know you probably have a hardware problem, so then try a new battery or unroot, go s-on and take the phone to verizon and tell them your phone won't charge correctly and see what they can do for you.
     
  4. baciv

    baciv Active Member This Topic's Starter

    Joined:
    Jul 2, 2010
    Messages:
    44
    Likes Received:
    3
    Switched back to the adrenalyne kernel, and first charge got 100%, bumped to green, problem seems to have been solved. Thanks for the responses, and I hope this helps someone else down the line :)
     

Share This Page

Loading...