Waiting for HOME ('android.process.acore') to be launched


Last Updated: 2012-03-26 06:07:01
  1. bravishanker3

    bravishanker3 New Member

    Hi

    I am working on building the Hello world app from the Android developers page. I have the emulator running but it does not display the Text hello world. It freezes with the Android booting symbol page and the console displays the following:
    Waiting for HOME ('android.process.acore') to be launched

    No errors are thrown. I am not able to figure out the error. The log cat has the following errors:

    06-18 19:40:34.679: ERROR/vold(26): Error opening switch name path '/sys/class/switch/test' (No such file or directory)
    06-18 19:40:34.679: ERROR/vold(26): Error bootstrapping switch '/sys/class/switch/test' (No such file or directory)
    06-18 19:40:34.685: ERROR/vold(26): Error opening switch name path '/sys/class/switch/test2' (No such file or directory)
    06-18 19:40:34.685: ERROR/vold(26): Error bootstrapping switch '/sys/class/switch/test2' (No such file or directory)
    06-18 19:44:49.015: ERROR/BatteryService(60): usbOnlinePath not found
    06-18 19:44:49.035: ERROR/BatteryService(60): batteryVoltagePath not found
    06-18 19:44:49.065: ERROR/BatteryService(60): batteryTemperaturePath not found
    06-18 19:44:49.345: ERROR/SurfaceFlinger(60): Couldn't open /sys/power/wait_for_fb_sleep or /sys/power/wait_for_fb_wake
    06-18 19:51:24.427: ERROR/vold(26): Error opening switch name path '/sys/class/switch/test' (No such file or directory)
    06-18 19:51:24.427: ERROR/vold(26): Error bootstrapping switch '/sys/class/switch/test' (No such file or directory)
    06-18 19:51:24.427: ERROR/vold(26): Error opening switch name path '/sys/class/switch/test2' (No such file or directory)
    06-18 19:51:24.427: ERROR/vold(26): Error bootstrapping switch '/sys/class/switch/test2' (No such file or directory)
    06-18 19:54:56.587: ERROR/BatteryService(61): usbOnlinePath not found
    06-18 19:54:56.597: ERROR/BatteryService(61): batteryVoltagePath not found
    06-18 19:54:56.627: ERROR/BatteryService(61): batteryTemperaturePath not found
    06-18 19:54:56.987: ERROR/SurfaceFlinger(61): Couldn't open /sys/power/wait_for_fb_sleep or /sys/power/wait_for_fb_wake

    Also I tried installing eclipse again and the android plugin again. Please help me.Thanks

    Advertisement
  2. Steven58

    Steven58 Reformed PH VIP Member

    hi..welcome. i moved your post to where it will be getting the most exposure.
  3. IanGClifton

    IanGClifton Well-Known Member

    Could be a bad device setup. Try starting the Android SDK and AVD Manager and creating a new virtual device. Then launch it directly to make sure it gets to the home screen. If it does, try installing your hello world APK and see what the logs show.
  4. miley

    miley New Member

    Sawadee... I was having the problem running on XP. On the AVD, I reset the VM Heap from 48 to 24 and it did the trick. Below is the console output...

    [2012-03-26 06:43:44 - helloWorld] Android Launch!
    [2012-03-26 06:43:45 - helloWorld] adb is running normally.
    [2012-03-26 06:43:46 - helloWorld] Performing ie.plextech.helloworld.HelloWorldActivity activity launch
    [2012-03-26 06:43:47 - helloWorld] Automatic Target Mode: using existing emulator 'emulator-5554' running compatible AVD 'DefaultAVD'
    [2012-03-26 06:43:47 - helloWorld] Uploading helloWorld.apk onto device 'emulator-5554'
    [2012-03-26 06:43:48 - helloWorld] Installing helloWorld.apk...
    [2012-03-26 06:44:38 - helloWorld] Success!
    [2012-03-26 06:44:40 - helloWorld] Starting activity ie.plextech.helloworld.HelloWorldActivity on device emulator-5554

Share This Page