1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Wanted - Widget to turn OFF Phone and Cellular Data, but leave WIFI On!


Last Updated:

  1. sjdorst

    sjdorst Member This Topic's Starter

    Joined:
    Dec 7, 2009
    Messages:
    6
    Likes Received:
    1
    Phone: Droid
    Situation: On airplane with in flight wireless. Want to allow wireless, but disallow cellular, including 2g/3g data. Anything already out there?

    Thanks
     

    Advertisement
    Syberjj likes this.
  2. mjschmidt

    mjschmidt Well-Known Member

    Joined:
    Jun 27, 2009
    Messages:
    1,272
    Likes Received:
    113
  3. spgiva

    spgiva Active Member

    Joined:
    Dec 6, 2009
    Messages:
    33
    Likes Received:
    0
    I second this. I was not sure if this was specific to the hardware or software. I have had a couple smartphones that could use wifi as well as the regular cell network but there has always been a way to turn off the phone but keep wifi on.

    Thanks in advance,
    -spg
     
  4. eltzsch

    eltzsch New Member

    Joined:
    Dec 7, 2009
    Messages:
    3
    Likes Received:
    0
    If you turn on airplane mode, then turn on wireless, phone and cell will be deactivated, but wireless will work.
     
  5. spgiva

    spgiva Active Member

    Joined:
    Dec 6, 2009
    Messages:
    33
    Likes Received:
    0
    When i tried this thevphonewould not let me turn on wifi with airplanemods turned on. Now i only tried this using my widgets, i did not go to the settings menu.
    -spg
     
  6. sjdorst

    sjdorst Member This Topic's Starter

    Joined:
    Dec 7, 2009
    Messages:
    6
    Likes Received:
    1
    ELTSZH said:
    To which SPGIVA replied
    I just tried it using 2 widgets - 1 to turn on wireless mode, then 1 to turn wireless back on - it worked!!!

    Just ran out of battery, but I'll try and identify the widgets when I can!

    Thanks to ELTSZH
     
  7. spgiva

    spgiva Active Member

    Joined:
    Dec 6, 2009
    Messages:
    33
    Likes Received:
    0
    ? U turned on wireless then turned on wireless?

    I trird with both the widgets and through the settings menu and could not do it. With airplane on i can not turn on wifi. I know of no other way to turn off the phone reception
    -spg
     
  8. FrayAdjacent

    FrayAdjacent Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    274
    Likes Received:
    4
    Turn on Airplane mode, which turns everything off, then turn WiFi back on.

    BAM.
     
  9. spgiva

    spgiva Active Member

    Joined:
    Dec 6, 2009
    Messages:
    33
    Likes Received:
    0
    Yeah, i have triee that and like i said before, with airplane mode on the htc droid eris will not let me turn on wifi. Not sure if this is a hardware issue or because the eris still runs 1.5.
    -spg
     
  10. spgiva

    spgiva Active Member

    Joined:
    Dec 6, 2009
    Messages:
    33
    Likes Received:
    0
    Yeah, i have triee that and like i said before, with airplane mode on the htc droid eris will not let me turn on wifi. Not sure if this is a hardware issue or because the eris still runs 1.5.
    -spg
     
  11. sjdorst

    sjdorst Member This Topic's Starter

    Joined:
    Dec 7, 2009
    Messages:
    6
    Likes Received:
    1
    No, I turned AIRPLANE mode on with a widget, then turned Wireless ON with another widget.

    I've since experimented with the built in controls, and it can be done by turning ON Airplane mode (long push on power switch, then choose airplane mode ON) then settings/wireless/turn wireless on.
     
  12. sjdorst

    sjdorst Member This Topic's Starter

    Joined:
    Dec 7, 2009
    Messages:
    6
    Likes Received:
    1
    I've got the Motorola Droid running 2.0, so that might explain the difference.
     
  13. beitinsw

    beitinsw Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    59
    Likes Received:
    3
    Which widget? I enabled airplane mode in settings then tried in settings then with Switchers--the Samsung widget to turn on wifi, and wifi in both cases were "unclickable."

    Phone was Samsung Galaxy.
     
  14. sjdorst

    sjdorst Member This Topic's Starter

    Joined:
    Dec 7, 2009
    Messages:
    6
    Likes Received:
    1
    I actually don't know which widget! I tried installing 4 or 5 until I found ones whose 1x1 control I liked, and I haven't taken time to figure out which of them I'm actually USING! When I can make the time, I will.

    In the mean time, it looks like the trend on this topic is that it works in 2.0, but not earlier Android versions
     
  15. mjschmidt

    mjschmidt Well-Known Member

    Joined:
    Jun 27, 2009
    Messages:
    1,272
    Likes Received:
    113
    I just tried on my HTC Magic with 1.5 by doing the following:

    1. Long-press on end call button. Chose Airplane mode.
    2. Navigated to Settings > Wireless settings. All wireless settings were greyed out, so I could not select WiFi.

    Since that didn't work I tried this:

    1. Long-press on end call button. Chose Airplane mode.
    2. Use the "Toggle WiFi" shortcut app (NOT a widget) to try to turn WiFi on. Did not work.

    I currently don't have an actual WiFi widget installed, so I could not test that method.
     
  16. ErnieC

    ErnieC New Member

    Joined:
    Jul 30, 2010
    Messages:
    1
    Likes Received:
    0
    After turining on Airplane mode, I tried turning on WiFi via Settings. It just kept trying to get an IP address and the icon never came on.

    I then switched to the Tricorder app, selected WiFi power on under EMS, and it worked like a charm. Aiplane mode is still on, and so is WiFi and it is working.

    EC
     
  17. Syberjj

    Syberjj New Member

    Joined:
    Jul 30, 2010
    Messages:
    2
    Likes Received:
    0
    I also can't do it here on my Xperia X10.
    I spend lots of weekends at a place where there is no cell phone coverage but a good internet connection with a wireless hot spot. I use VOIP to receive calls when I am here.
    My cell phone's battery doesn't last though because it is always searching for the normal cell phone coverage.

    Is there no application to handle this? This would be even better if it could be configured to enable normal phone data every x mins (like every 30 mins leave it enable for 5 minutes to see if you get any new SMS)
     
  18. MaukaRunner

    MaukaRunner Well-Known Member

    Joined:
    Apr 9, 2010
    Messages:
    49
    Likes Received:
    1
    I use an app called Airplane Mode Wi-fi Tool which should be able to do what you want.
     
  19. TheBrit

    TheBrit Well-Known Member

    Joined:
    Aug 25, 2009
    Messages:
    1,188
    Likes Received:
    114
    When my Hero was on 1.5 this was impossible but since the 2.1 update it is now possible.
     
  20. Drhyde

    Drhyde Well-Known Member

    Joined:
    Dec 23, 2009
    Messages:
    493
    Likes Received:
    89
    I use switchpro. it allows me to turn off mobile data while leaving wifi on.
     
  21. K-Rizzle

    K-Rizzle Well-Known Member

    Joined:
    Nov 21, 2009
    Messages:
    367
    Likes Received:
    20
    I just tried putting my phone into AP mode manually and using status toggle to turn on my wifi, on my moment and it worked. Good to know, thanks for the idea, I had never thought of this before. lol. :)
     
  22. Loch

    Loch Well-Known Member

    Joined:
    May 27, 2010
    Messages:
    87
    Likes Received:
    10
    Curvefish makes one available in the market.

    Forget the name at the moment, but just search for Curvefish and it is on the list.
     
  23. EasyEEE

    EasyEEE Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    466
    Likes Received:
    176
    For Sprint HTC EVO 4G, just add appropriate Settings Widgets - turn all off, turn on airplane mode, turn on the "wifi's". ( :p ) No problems at all. Obviously you have to connect to WiFi via normal means.
     
  24. psychocandy

    psychocandy Well-Known Member

    Joined:
    Jul 25, 2010
    Messages:
    114
    Likes Received:
    0
    Anyone got any working on the samsung galaxy?
     

Share This Page

Loading...