WARNING: Application does not specify an API level requirement!


Last Updated: 2011-03-03 01:00:39
  1. StevenHu

    StevenHu Well-Known Member

    I get this message in the console when testing on an Android device: "WARNING: Application does not specify an API level requirement!"

    I checked my AVD manager in Eclipse and the API level is there. But how do I specify it in the application?

    Thanks!

    Advertisement
  2. cr5315

    cr5315 Well-Known Member Developer

    In your AndroidManifest, go to the </application> tag and right under that put
    <uses-sdk android:minSdkVersion="3" />

    The 3 is the API level for Android 1.5
    If you want other levels, use:
    1.5 - 3
    1.6 - 4
    2.1 - 7
    2.2 - 8
    2.3.1 - 9
    2.3.3 - 10

Share This Page