Warning Camera Failed Error Message(SGS2)Support

Last Updated:

  1. MrPhotog

    MrPhotog Member

    Just got a "Warning Camera Failed" error when opening my camera app. I had to drop the battery out and put it back in - appears to be working fine now. Is there a better fix out there? If so, how do I get it?

    eezil74 likes this.
  2. mghtbgiant

    mghtbgiant Member

    I have had the same issue for over a month now.. I have installed two phone updates since I got the phone in June. I bought this unlocked from the UK. I have also tried installing the new camera firmware apk floating around in forums to no avail. I start the camera and 999 times out of 1000 it comes up black. I have done about everything aside from a factory reset. Some people are reporting that the reset does not correct the issue so I'm not that excited about trying it. Sometimes a reboot will get it to come up sometimes it won't. I can only assume there is something else that got installed that is accessing the camera that's conflicting with something else.

    My phone is not rooted. All the updates I've installed were official. This is unacceptable and irritating. FIX IT!
  3. SGS2

    SGS2 Well-Known Member

    did you also try to delete all the data on the camera app? this will mean you will need to re-enter your camera settings. just a thought. i have not had this problem.
  4. mghtbgiant

    mghtbgiant Member

    I am in an inexplicable and unprecedented (since the issue first arose) trend of the camera working more often than not as of today. I did just clear there camera data and the camera is still opening as expected. I noticed the flashlight lite app which utilizes the camera LED would only shine it for about 5 seconds before the flash would shut off and the flashlight app would barf and force close. does anyone else thats having camera issues have this app and experience similar behavior?

    thanks for the 'clear data' suggestion!
  5. mghtbgiant

    mghtbgiant Member

    No dice.. The camera was working for a little bit so any tests were probably moot. I can reboot and have the camera SOMETIMES actually open. IF it does open, I can let the phone sit without using it for some undetermined timeframe (let's say 10 minutes) and then go to open the camera and have it not work. I have tried clearing the Camera application's data, Task Manager > Clear RAM, rebooting..

    Nothing solves the problem predictively. the flash light application, when the camera isn't working, also doesn't work. When the camera IS working, the LED light for the flashlight app will come on for about 5 seconds and then the app crashes.

    Absolutely ridiculous. I still haven't tried a factory reset because of the reports that it doesn't solve the problem. Maybe I should start backing up my information.
  6. mghtbgiant

    mghtbgiant Member


    NO WORKIE :mad:

    I bought this phone from the UK in June before the US release. I am in the US. Adding my google account worked flawlessly the first time when I first set up the phone. Now, I can't do much on it without getting it set up. If it doesn't give me the "Could not connect to a reliable server" message, it tells me the username/password is incorrect. And, some of you knee-jerk forum posters might think something smarmy like "well, are you sure it IS correct??" the answer is yes.

    I can't for the life of me seem to manage to wind up with a phone that doesnt have some sort of malfunction.

    So, Samsung Customer Care here I come...
  7. leo9891

    leo9891 Well-Known Member

    I just got my Galaxy SII (refurbished) in the mail last night andtried out the camera, all seemed to be fine until I tried to change the filter to cartoon and it said the camera failed. There was an update I downloaded so hopefully it fixed it, I haven't tried it since that first time.
  8. Yielar

    Yielar New Member

    I'm having the same issue and I'm running the Samsung S2X from Telus in Canada. Come to think of it I started getting the "Could not connect to a reliable server" message a few days ago just when the problems started. My phone freezes up with every phone app I try now including the stock app along with paper camera, panorama and my favorite camscanner. When it freezes the screen turns black and the phone shuts down. I then have to hold the power button down for approx 10 seconds before the phone powers back on.

    I've done a factory reset without signing into my Google account and without downloading a single app with the same issue after trying the stock camera app.

    I'm now getting similar problems visiting several websites and can't seem to watch any Youtube videos without the phone freezing and shutting down.

    Not sure what the problem is but I've done everything I know including the factory reset, clearing the memory and cache in all problematic apps and avoiding signing into my Google account.

    Anyone else have the same problem with there S2 or S2X? This is very annoying as my phone was running solid with NO problems since September until a few days ago now. Please help!
  9. mghtbgiant

    mghtbgiant Member

    i finally got ahold of samsung service UK and got them to start the claim process for me. the crappy part is that i now get to ship this overseas from the US and be galaxy less for who knows how long. i would suggest finding out what camera firmware your phone is running; there were apparently 3 different camera modules samsung used in these phones. 2 out of 3 are good. such is my luck in life.
  10. mghtbgiant

    mghtbgiant Member

    did you happen to install a new ROM? i have been installing everything i could get ahold of hoping my problem was firmware and not hardware. in any case, something i installed wiped my APN for my carrier here and i then was unable to receive packet data via my mobile provider. i got the above message when i noticed i had no data connection.

  11. harkin

    harkin New Member

    I had the same issue with the camera error message on my galaxy s2 after uninstalling some video chat software ;)
    I couldn't get stickam to work either so uninstalled it too.
    After searching the forums with no real success I resorted to the old IT adage of "have you turned it off and back on again". I cleared the camera data then rebooted the phone. And it worked!
    I know a previous poster has had issues after rebooting but it is always the best thing to try first.
    If the camera error comes back I will repost.
  12. Sneddy

    Sneddy Member

    How to clear the camera data?
  13. TheAdvocator

    TheAdvocator Member

    Any updates?
  14. gavinch

    gavinch New Member

    Anyone has been able to fix this problem? Is it a hardware/firmware problem??
    I'm facing the same intermittent working problem. It doesn't work most of the times. Did you find a solution??
    About the camera modules can you throw some light??
    On typing *#34971539# and then press Phone/CAM FW Ver Check I get these:
    Cam FW Ver: SCEF02
    Phone FW Ver: TBEC28
    Please help me out. I'm highly frustrated. Its been since Sept I'm facing this issue :(
  15. NY Yankees 23

    NY Yankees 23 Member

    Been getting a black screen for about a month nopw. Sometimes it says camera failed and sometimes I get a picture but with fuzzy white lines going around the edges of the abjects. It almost looks like a camera effect. Anyway. I did the factory restart, reinstalled ROM and kernel. Nothing. Its a hardware failure, I am sure of it.

    I just ordered a new camera and it should be here early next week. I am gonna try and install it myself. THIS is a very good YouTube video on taking this phone apart. If you are somewhat handy, you might want to consider it. Anyway I will get back here to post when I get it installed.

    EDIT: I just replaced the camera module and that did not do the trick.. Having the same issues. Seems like Samsung is getting a phone call. Sorry everyone, I really thought that would do the trick, but obviously, it didnt.

Share This Page