Warning Camera Failed - hardware issue?Support


Last Updated:

  1. mkoprulu

    mkoprulu New Member

    Hi all,

    I've had my Samsung Galaxy S for a couple of weeks now, and the last time i took pictures with it was on 29th August. I tried the camera yesterday and got this message.

    What happens is the camera app opens, and instantly displays this message and all you can do is click ok. When you do that, the app closes.

    I tried many things, including trying to press other buttons quickly before the error message comes. I managed to switch to camcorder mode and even press the record button in that time, but all i got was video recording failed message.

    I checked on the forums for people who had similar problems and here's a list of things i tried so far:

    1- Uninstall Fring
    2- Return to Factory Settings
    3- Fully Recharge Phone
    4- Take out battery, sim, external sd card, wait for 5 mins and restart
    5- Take out external sd card altogether and restart

    So far nothing has worked. I haven't dropped or hit the phone anywhere. It hasn't been in temperatures less than 10 degrees celcius or over 25.

    I can't think of anything else to do really, other than calling up warranty line. The problem is i'm going on holiday soon and the only reason i wanted to get this phone before my previous contract ended was to be able to use the camera while on holiday and now all my plans have gone down the drain.

    I even tried reinstalling fring and making a test call with it, and i can confirm my front facing camera is working fine. It's the one on the back that's not working.

    I tried installing other applications as well which would use the phone's camera and every each of them force closed when i tried.

    Please can someone give me any ideas?

    I can't send it off with warranty until i come back from holiday anyway, so maybe froyo would be rolled out by my provider by then... I wonder if that would fix things... But i thought returning to factory settings would have fixed it too, which it didn't...

    Advertisement
  2. mistertee

    mistertee New Member

    Hello,

    I've only had my phone a few days but I had the same problems as you. I ended up calling it "camera roulette" because it was a bit of a lottery wether or not you could fire the camera up.

    I had a chat with my provider (Orange UK) and came up with the conclusion that the camera was faulty, so I should get a new one tomorrow. If that doesn't solve it, I'll let you know. At least they we'll know its a software/driver problem.
  3. kaza777

    kaza777 Active Member

    I had exactly the same u need to send it back theres nothin you can do. I am still waiting for dialaphone to get stock in thou it s bin nearly 2 weeks. but orange might have stock . I think we should be reinbursed for all the hassle really . It seems to be so common .Ave took insurance out now in case it happens again..:confused:
  4. t sport 1978

    t sport 1978 Well-Known Member

    I had this problem and it turend out to be Fring that was causing the camera failure.

    Investigate apps that you have installed before deciding that it is a hardware problem.

    With the quality assurance nowadays, its is far more likely when a problem persists it is due to software rather that hardware.
  5. ozosrt4

    ozosrt4 Member

    I'm getting same warning and will immediately start recording another video (HD) with same settings and will work. No Fringe installed.
  6. syzygy

    syzygy New Member

    I had exactly this problem today, and started uninstalling apps until it worked again. In my case, I could see the little satellite icon flashing, and concluded that it might well have been a navigation software I'd recently installed.

    I remembered that I had updated Google Maps, so I uninstalled that (which replaced it with the 'factory version') and the camera came back to life.

    Obviously this may not be the same for everyone, but I thought I'd share my experiences.

    Cheers

    james
  7. brossow

    brossow New Member

    Had this exact problem tonight. I'm positive I isolated the issue. I had recently installed Google Maps but never launched it. When I launched the Maps app there was a license agreement or similar message. When I accepted / acknowledged it and quit Maps, the camera worked as normal. Thought I should mention this as it might save someone a lot of time in troubleshooting and uninstalling / reinstalling apps.
    brown705 and ch0ps like this.
  8. ch0ps

    ch0ps New Member

    Started experience trouble my camera and with the voice search icon on the google search widget today. I followed what brossow posted and opened up google maps (after the latest update in May 2011). After that, I opened up the camera again and voila, camera works. Seems to have fixed the google voice search widget as well.

    hope this works for you too.
  9. RinusD

    RinusD New Member

    It started to fail after I installed an application called gps compass. After uninstalling this app, the camera worked fine again. Problem seems to be related to the gps, as can be seen from many of the related posts. Hope this helps.
  10. renee7

    renee7 New Member

    Can't use my camera, it keeps saying camera failed. Last night I installed an app and it said I had to install adobe air to use it then my camera stopped working. I uninstalled the app but still nothing..
  11. snapper.fishes

    snapper.fishes Well-Known Member

    Did you uninstall both the app and adobe air?
  12. miss_sjg_x

    miss_sjg_x New Member

    Do you have the official Twitter app installed? If so uninstall it. It's worked across the board in many forums and online help, and also worked for me. My phone also would not play youtube vids either and getting rid of twittter has also fixed that.

    Hope this helps :)
  13. sira9aris

    sira9aris New Member

    Check this link. It gives better explanation why camera failed warning message appears.
  14. whiterockbc

    whiterockbc New Member

    In app's I went to task manager, clicked on RAM then clicked on Clear memory and the camera then worked fine.
  15. Dene74

    Dene74 New Member

    Hi Guys

    I had this from the day I bought the phone.. I found out today that is a common error and I found out that - in my case - it was caused by the fact that Adobe Flash was not updated - once I went to the market and clicked on my "to be updated" apps - then it worked fine

Share This Page