Was able to root, but nothing else is working


  1. JonnieBlaze

    JonnieBlaze New Member

    ...I'm really starting to hate this phone (Spring HTC Hero). Everyday it tells me I'm low on space, it can't except incoming messages because of the low space, random application errors because of the low space, etc, etc. I've done everything short of a factory reset to try to free up space but its just not working. My whole reason to root (which I'm obviously new at) is to be able to install some ROM (have no idea which one) that will allow me to install applications to my SD card. If there is a simpler solution, I'm all ears.

    So far I've been able to root with z4mod. It took several reboots before it actually took affect, but now it is rooted. For the past week and a half I've been trying to figure out how to do a nandroid backup. I've following all the posts and wiki instructions i can find to install the clockworkmod manually or the Amon RA recovery....all of them fail at the "Flash_Image" part saying "flash_image" is not recognized.

    So then i tried to find RomManager to do it that way. Problem is I have 2.1, can't download RomManager from the market, and when I download the free .apk file and install it I get a "Unable to parse" or something error.

    I have no idea what to do now. I'm to the point where all the how-tos and help files and forum posts I'm reading are the same ones I found 10 days ago that I couldn't get working either.

    Advertisement
  2. casper55117

    casper55117 Active Member

    not to sound like a jerk but are you sure your rooted. if i were you id dl terminal emulater from the market and just type in "su" with out the quotes. it will pop up and ask you if you would like to allow super user privileges. if it does your rooted. the next step is to clear the data cache for the superuser app. maby you accidently denied the superuser privilege for cwr
  3. JonnieBlaze

    JonnieBlaze New Member

    I've had it ask me for superuser rights since I've ran z4mod. I think I was trying to open "App Installer" app to install Rom Manager from the .apk file I put on my SD Card and it asked. I can try the terminal emulator you suggested, but I think I really am rooted. (rom manager never installed, it failed with a parsing error)

    You said the next step was to "clear the data cache for the superuser app". I thought I had to have a recovery installed (like clockwork mod or amon ra) before I could boot into recovery, clear/wipe the cache, then create a nandroid? Thats the thing I can't install. Or do you mean going to menu>programs>go the superuser app that is now visible>clear data cache>then try installing the recovery?
  4. casper55117

    casper55117 Active Member

    yes go menu>programs>superuser app> clear data> i had an issue once accidently denied super user. if you did the same thing this will fix it
  5. LBPHeretic

    LBPHeretic Well-Known Member

    The Sprint HTC Hero is a fairly old handset at this point, so the guides are fairly old now too. A few things have changed, but the steps are mostly the same as they ever were.

    I will give you a couple hints. After you root your Sprint HTC Hero with Z4Root, you will need to go find ROM Manager in .apk form because ROM Manager no longer supports Android 2.1 and below. Once you find the .apk for ROM Manager, you can sideload it to your handset. That entails, copying the ROM Manager .apk file to your microSD card or just downloading it to your microSD card from the web browser on your handset, installing a file explorer like EStrongs File Explorer, finding the ROM Manager .apk file and then clicking it and installing it. Once, ROM Manager is installed you can flash ClockworkMod Recovery and then boot into that recovery. From recovery you can go to Backup and Restore and make a Nandroid backup. Now, hopefully you have already selected a ROM capable of moving apps to the microSD card. I would recommend something like CyanogenMod 7 which you can find here: CyanogenMod Mirror Network - Powered by TDRevolution . You will also need to flash the Google Apps, also known as GApps after the ROM, which can be found here: Goo-inside.me Downloads - Downloading gapps-gb-20110828-signed.zip . Before you flash anything, verify you did do a Nandroid backup, then wipe cache and data and go into Advanced and wipe Dalvik cache. Finally, go into Partitions and format boot, cache, data, and system, but do not format your microSD card. After you finish flashing the two things I mentioned above, you can boot back into Android and proceed to sign back into your Google account.
  6. JonnieBlaze

    JonnieBlaze New Member

    Wow, thanks a lot for the mini-tutorial LBPHeretic. That was short and to the point, nothing confusing at all. Really appreciate it. So far I've made it to the nandroid backup and that is backing up fine.

    I tried downloading the current Rom Manager and installing with ES File Explorer. That also gave me the "unable to parse" error. So then I found a thread that said to use Rom Manager 4.8.0.7. I downloaded that from apktops.com, and again, got the same error. So then I tried Rom Manager 4.7.0.2 and so far so good! :D

    Thanks again for the help. Mucho appreciated.
  7. LBPHeretic

    LBPHeretic Well-Known Member

    Glad to be of service. I believe that ROM Manager version 4.7.0.2 was the last Android 2.1 supported version, so what you experienced makes sense.

    CyanogenMod 7.2 Release Candidate 1 was just released several days ago, so you can give that a try for your new ROM, if you want. It has many Android 4.0 features, bugs, and so forth incorporated into it.

Share This Page